Highlighted

Animate CC 2018 timeline playback is slow

Community Beginner ,
Feb 13, 2018

Copy link to clipboard

Copied

Hi,

Since upgrading to Animate CC 2018 I have found that no matter what complexity my project is, timeline play back lags really badly. I have to publish my work to get any sense of timing, which for an animation tool is incredible inefficient. I also have Flash CS6 installed on my computer, and the same files do not lag when played on the timeline. I am tempted to go back to CS6 for the sake of efficiency, however this is obviously not the solution.

I am using an iMac (Retina 5K, 27-inch, 2017), 3.5 GHz Intel Core i5, 16 GB 2400 MHz DDR4. Coincidentally, I upgraded my computer AND Animate CC at the same time. But I have to assume it is the software, not the computer, given that Flash CS6 performs just fine.  FYI, unlike another similar post, I am not using any tapered line work etc. Just super simple animation struggles.

Any help would be great, it's really driving me nuts!
Amy

Correct answer by KirstenL | Community Beginner

I'm having a similar problem where Flash...sorry...ANIMATE... would playback slowly, but only sometimes. I'm doing frame by frame animation and thought maybe the line work was too complicate to process quickly, although I've been animating this way for years and haven't had this problem before. My timeline fps is 24, although most of the time I was getting 12fps playback speeds.I just noticed a weird bug/fix which is that if I play back my timeline while selection tool is selected, then playback is fine (24fps). But when I have the Free Transform Tool selected, I get much slower playback.

Don't know if this will help in your particular case, but was a good discovery for me.

TOPICS
Product issue, Timeline

Views

10.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Animate CC 2018 timeline playback is slow

Community Beginner ,
Feb 13, 2018

Copy link to clipboard

Copied

Hi,

Since upgrading to Animate CC 2018 I have found that no matter what complexity my project is, timeline play back lags really badly. I have to publish my work to get any sense of timing, which for an animation tool is incredible inefficient. I also have Flash CS6 installed on my computer, and the same files do not lag when played on the timeline. I am tempted to go back to CS6 for the sake of efficiency, however this is obviously not the solution.

I am using an iMac (Retina 5K, 27-inch, 2017), 3.5 GHz Intel Core i5, 16 GB 2400 MHz DDR4. Coincidentally, I upgraded my computer AND Animate CC at the same time. But I have to assume it is the software, not the computer, given that Flash CS6 performs just fine.  FYI, unlike another similar post, I am not using any tapered line work etc. Just super simple animation struggles.

Any help would be great, it's really driving me nuts!
Amy

Correct answer by KirstenL | Community Beginner

I'm having a similar problem where Flash...sorry...ANIMATE... would playback slowly, but only sometimes. I'm doing frame by frame animation and thought maybe the line work was too complicate to process quickly, although I've been animating this way for years and haven't had this problem before. My timeline fps is 24, although most of the time I was getting 12fps playback speeds.I just noticed a weird bug/fix which is that if I play back my timeline while selection tool is selected, then playback is fine (24fps). But when I have the Free Transform Tool selected, I get much slower playback.

Don't know if this will help in your particular case, but was a good discovery for me.

TOPICS
Product issue, Timeline

Views

10.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 13, 2018 1
Adobe Community Professional ,
Feb 13, 2018

Copy link to clipboard

Copied

Do you generally animate to a sound in the timeline? If you do, you probably have the sound's sync set to Stream, so that frames are skipped to make it keep up.

With HTML5 Canvas you don't get Stream, and so every frame is played, giving the impression that it's going slow.

For general animating it's best to use an ActionScript 3 FLA, then you can use the sound Stream sync, as well as getting more filters and better performance.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2018 1
Community Beginner ,
Feb 13, 2018

Copy link to clipboard

Copied

Hi Colin,

I have no sound and I am using an ActionScript 3 template.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2018 0
Adobe Community Professional ,
Feb 13, 2018

Copy link to clipboard

Copied

An empty FLA, or a template file? Is there something I can try to see the same issue?

Also, what frame rate are you set to, and what rate does previewing the timeline give you? Is there any difference if you change View/Preview Mode to Fast?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2018 1
Community Beginner ,
Feb 19, 2018

Copy link to clipboard

Copied

Hi Colin,

An empty FLA I think? So, when i start a new file, I just choose ActionScript 3 from the 'General' tab.

I am animating at 25 fps, and previewing on the timeline varies I think - anywhere from 100%-50% or maybe even slower at times. Changing the preview mode to fast didn't help, unfortunately.

Here is a file I am frustrated by at the moment. Very simple. Works fine in Flash CS6.

Dropbox - tirePressure.fla

Thanks,

Amy

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 19, 2018 0
Adobe Community Professional ,
Feb 19, 2018

Copy link to clipboard

Copied

I'm not able to make your FLA go at less than 25 fps, other than in CS6, where it occasionally drops to 18 fps. I even set the preview mode to Full, to try and get it to go slow, but it wouldn't.

It occurred to me that you're on Retina, so I tried on my MacBook Pro Retina screen. It's a lot slower machine than your iMac, but still did ok. Here's a screen recording of the timeline while your animation is running:

http://colin.scienceninja.com/25fps.mp4

That was on my Retina screen, with preview mode set to Full, and also while doing a screen recording. Twice it briefly drops to around 18 fps, but otherwise keeps up well.

As I did more tests I did get times when it dropped to 12 fps, but I'm not sure what was different right then. I tried various workspace options, but couldn't be sure about what was making any difference. I also tried using a Stream sound in the timeline, to see if that indeed would make it keep up, even if it dropped frames. Unfortunately, I couldn't get it to go slow again, and whether on Event or Stream, I was getting 25 fps all the time.

Last thing I tried was to set it to 50 fps. With Event sound I still got 25 fps, which makes me think that my machine was going as fast as it could to give me the 25 fps. When set to Stream sound it did do 50 fps, but was no doubt skipping frames.

So, there are some oddities, but you could get real time previews if you had a timeline Stream sound, even if it's silence.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 19, 2018 0
Community Beginner ,
Jun 01, 2018

Copy link to clipboard

Copied

I'm having a similar problem where Flash...sorry...ANIMATE... would playback slowly, but only sometimes. I'm doing frame by frame animation and thought maybe the line work was too complicate to process quickly, although I've been animating this way for years and haven't had this problem before. My timeline fps is 24, although most of the time I was getting 12fps playback speeds.I just noticed a weird bug/fix which is that if I play back my timeline while selection tool is selected, then playback is fine (24fps). But when I have the Free Transform Tool selected, I get much slower playback.

Don't know if this will help in your particular case, but was a good discovery for me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2018 2
Community Beginner ,
Jun 01, 2018

Copy link to clipboard

Copied

Ah thank you so much for posting this! That is such a peculiar bug, but you're right - my animations play fine in the timeline if the selection tool is active. Slow if the transform tool is active. So stupid but I can live with it UNTIL ADOBE FIXES IT WHICH I HOPE THEY WILL BECAUSE ITS STUPID AND ANNOYING.

Thanks again!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 01, 2018 0
Explorer ,
Nov 05, 2018

Copy link to clipboard

Copied

I'm having this issue on a Retina iMac. The file you posted plays back at average of 12 fps on my iMac (Retina 5K, 27-inch, Late 2015) with the display set to 2560 x 1440. Switching tools does not seem to affect performance.

However, when I drag the Animate window onto my Cintiq 22HD (which is a 1920 x 1080 display) the playback never drops below 25 fps.

I found a solution that worked for me on another thread:

In Finder, choose File-Get Info (Command-I) with the Animate App icon selected and tick "Open in Low Resolution"

Now the file plays at full speed on my iMac display.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 05, 2018 5
New Here ,
Nov 06, 2018

Copy link to clipboard

Copied

Almost semi old post. But thank you! This really worked on my end! Doing what you said, saving and reopening my project got it to go at full frame rate speed. Thank you

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 06, 2018 1
New Here ,
Mar 22, 2020

Copy link to clipboard

Copied

Thank you! Works for me!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 22, 2020 1
New Here ,
Apr 08, 2020

Copy link to clipboard

Copied

thank you, it worked perfectly for me too!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 08, 2020 1
New Here ,
Apr 24, 2020

Copy link to clipboard

Copied

Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 24, 2020 1
New Here ,
Jun 26, 2020

Copy link to clipboard

Copied

Low Resolution mode worked for me too!  Constant 24fps playback.  Best thing about Flash is that it always played in realtime so still having this is a saving grace for an app I've refused to abandon.  Compare that to the cached playback in After Effects and it's a godsend for frame-by-frame artists.  Similarly, the solution to slow C4D animation playback was solved this way.  Seems like retina resolution is the problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 26, 2020 0
New Here ,
Aug 01, 2018

Copy link to clipboard

Copied

I found A FIX (you might not like it)

If you're using the camera either wait until the end of your project to include it or turn it off while you're working 

 

If you're not using camera (do the following)

     try to open old project and play it on animate cc, if it plays-back good, then the project thats not playing back good is corrupted so copy the layers and put it in a new template (the part you're probably not going to like), then it should run smoothly, I hope... Mine did!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 01, 2018 1
New Here ,
Oct 23, 2018

Copy link to clipboard

Copied

I was having the same issue but it mysteriously solved itself after plugging in my laptop to charge

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 23, 2018 0
Adobe Community Professional ,
Sep 20, 2019

Copy link to clipboard

Copied

Playback lags significantly if the Free Transform tool is selected. Switch to the Selection (black arrow) tool or other.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2019 0