Highlighted

Animate cc Adding mp3 file creates javascript error on publishing HTML5 canvas

Community Beginner ,
Jan 09, 2019

Copy link to clipboard

Copied

I have a simple cartoon with about 10 symbols, one animation and one sound file. I test once and it is fine, the second time I test it I receive this error:

"A javascript error occurred."

and in the output box it says:

An unexpected error occurred during export. [JSX]

When I remove the sound file, I can test as many times as I like.

I was able to publish it, it plays in Google chrome, and Edge, but there is no sound on anything from APPLE.

Any Ideas would be of great help.

In the publish settings turn off the Export document as texture feature and every thing works fine File -> Publish -> (Uncheck) Export file as texture.

TOPICS
Discussions

Views

351

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Animate cc Adding mp3 file creates javascript error on publishing HTML5 canvas

Community Beginner ,
Jan 09, 2019

Copy link to clipboard

Copied

I have a simple cartoon with about 10 symbols, one animation and one sound file. I test once and it is fine, the second time I test it I receive this error:

"A javascript error occurred."

and in the output box it says:

An unexpected error occurred during export. [JSX]

When I remove the sound file, I can test as many times as I like.

I was able to publish it, it plays in Google chrome, and Edge, but there is no sound on anything from APPLE.

Any Ideas would be of great help.

In the publish settings turn off the Export document as texture feature and every thing works fine File -> Publish -> (Uncheck) Export file as texture.

TOPICS
Discussions

Views

352

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 09, 2019 0
Adobe Community Professional ,
Jan 10, 2019

Copy link to clipboard

Copied

are you clicking something on your canvas to trigger the sound to start?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 10, 2019 0
Community Beginner ,
Jan 10, 2019

Copy link to clipboard

Copied

I have the same problem. Canvas document. Added sound that extends the full length of the 6 sec. timeline. Did the new auto-sync. Now it won't play sound and I can't test or output to html except for the first time after I open the file (tried this a few times to test it). No button to trigger the sound.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 10, 2019 0
Adobe Community Professional ,
Jan 10, 2019

Copy link to clipboard

Copied

add your sound to a button listener and test.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 10, 2019 0
Community Beginner ,
Jan 10, 2019

Copy link to clipboard

Copied

I found that if I design and test as an action script 3.0 document, since I have no javascript code, I can just convert to HTML5 canvas and publish. I have not tried the button yet but will, thanks for all your help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 10, 2019 1
Adobe Community Professional ,
Jan 10, 2019

Copy link to clipboard

Copied

you’re welcome.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 10, 2019 0
Community Beginner ,
Jan 12, 2019

Copy link to clipboard

Copied

I found a solution to the problem. If you don't place two of the same symbols on the same layer, for example a pair of eyes, the HTML5 canvas tests fine as many times as you like.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 12, 2019 1
Community Beginner ,
Jan 31, 2019

Copy link to clipboard

Copied

In the publish settings turn off the Export document as texture feature and every thing works fine File -> Publish -> (Uncheck) Export file as texture.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 31, 2019 0