Highlighted

Animate CC: Masking Problem in Symbol

Community Beginner ,
Nov 22, 2019

Copy link to clipboard

Copied

Hello fellow animators and artists! 

There appears to be a bug in Animate CC. 

 

This only happens when exporting a video file or SWF. Masking inside the symbol does not work like it did in the 2019 version, even though I turned it on. What only shows is the item that's meant to be masked, in my case, the gradient boxes in this image. 

 

Movies & TV 11_22_2019 12_32_55 PM.png

 

This is what the image below is supposed to look like, with the masking applied. It seems masking in the symbol only works when exporting an image.

 

Demo-Reel-Poster.jpg

 

This happened on a different project file too, confirming it's a bug and not me forgetting to turn on the mask. I will be clear that that masking in the main timeline works, but the masking in the symbol doesn't work.

 

Will this issue be fixed sometime soon, please?

 

Thanks!
Sam "Qwest44" Long

Hi mate,

 

It may have worked in some version, but more likely it was a bug there.

 

What you show here is a very specific usage scenario where you are using a text field as a mask.

 

Masks are by definition shapes.

 

So, break apart your text down to raw vector shapes (you may need to press Ctrl+B more than once) and it will work as a mask in An 20 as in any other version of Flash or Animate.

 

Hope this helps!

 

TOPICS
Error, Product issue, Timeline

Views

489

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Animate CC: Masking Problem in Symbol

Community Beginner ,
Nov 22, 2019

Copy link to clipboard

Copied

Hello fellow animators and artists! 

There appears to be a bug in Animate CC. 

 

This only happens when exporting a video file or SWF. Masking inside the symbol does not work like it did in the 2019 version, even though I turned it on. What only shows is the item that's meant to be masked, in my case, the gradient boxes in this image. 

 

Movies & TV 11_22_2019 12_32_55 PM.png

 

This is what the image below is supposed to look like, with the masking applied. It seems masking in the symbol only works when exporting an image.

 

Demo-Reel-Poster.jpg

 

This happened on a different project file too, confirming it's a bug and not me forgetting to turn on the mask. I will be clear that that masking in the main timeline works, but the masking in the symbol doesn't work.

 

Will this issue be fixed sometime soon, please?

 

Thanks!
Sam "Qwest44" Long

Hi mate,

 

It may have worked in some version, but more likely it was a bug there.

 

What you show here is a very specific usage scenario where you are using a text field as a mask.

 

Masks are by definition shapes.

 

So, break apart your text down to raw vector shapes (you may need to press Ctrl+B more than once) and it will work as a mask in An 20 as in any other version of Flash or Animate.

 

Hope this helps!

 

TOPICS
Error, Product issue, Timeline

Views

490

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 22, 2019 0
Guide ,
Nov 22, 2019

Copy link to clipboard

Copied

Hi mate,

 

It may have worked in some version, but more likely it was a bug there.

 

What you show here is a very specific usage scenario where you are using a text field as a mask.

 

Masks are by definition shapes.

 

So, break apart your text down to raw vector shapes (you may need to press Ctrl+B more than once) and it will work as a mask in An 20 as in any other version of Flash or Animate.

 

Hope this helps!

 

- Nick: Character designer and animator, Flash user since 1998
Member of Flanimate Power Tools team - extensions for character animation

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 22, 2019 1
Community Beginner ,
Nov 22, 2019

Copy link to clipboard

Copied

Hi N! 

 

Your suggestion worked! Thank you very much!

 

Sam

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 22, 2019 0
Guide ,
Nov 22, 2019

Copy link to clipboard

Copied

You're most welcome, Sam!

 

Good luck!

 

- Nick: Character designer and animator, Flash user since 1998
Member of Flanimate Power Tools team - extensions for character animation

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 22, 2019 0