Highlighted

Animate CC nested symbols

Community Beginner ,
Feb 13, 2019

Copy link to clipboard

Copied

Hi!

I use Animate cc in conjunction with greensock to develope banners and animation.

In Animate cc 19.1 there looks to be a bug or change in code that affects how nested animations work in symbols.

Used to be able to do this:

tl.to([this.sym1.sym2],1,{x:"-=500"},"+=0");

Moves sym2 inside sym1 500 pixels.

Making a new animation in "19.1" this no longer works. However opening a file in "19.1" made in version "18.whatever" this still works.

If possible please confirm behaviour. Or perhaps there is a better way of targeting nested symbols.

Adobe Community Professional
Correct answer by kglad | Adobe Community Professional

disable advanced layers (modify>document>untick 'use advanced layers') and retest.

info about advanced layers: https://helpx.adobe.com/animate/using/timeline-layers.html#advanced-layers

TOPICS
Discussions

Views

230

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Animate CC nested symbols

Community Beginner ,
Feb 13, 2019

Copy link to clipboard

Copied

Hi!

I use Animate cc in conjunction with greensock to develope banners and animation.

In Animate cc 19.1 there looks to be a bug or change in code that affects how nested animations work in symbols.

Used to be able to do this:

tl.to([this.sym1.sym2],1,{x:"-=500"},"+=0");

Moves sym2 inside sym1 500 pixels.

Making a new animation in "19.1" this no longer works. However opening a file in "19.1" made in version "18.whatever" this still works.

If possible please confirm behaviour. Or perhaps there is a better way of targeting nested symbols.

Adobe Community Professional
Correct answer by kglad | Adobe Community Professional

disable advanced layers (modify>document>untick 'use advanced layers') and retest.

info about advanced layers: https://helpx.adobe.com/animate/using/timeline-layers.html#advanced-layers

TOPICS
Discussions

Views

231

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 13, 2019 0
Adobe Community Professional ,
Feb 13, 2019

Copy link to clipboard

Copied

disable advanced layers (modify>document>untick 'use advanced layers') and retest.

info about advanced layers: https://helpx.adobe.com/animate/using/timeline-layers.html#advanced-layers

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2019 1
Community Beginner ,
Feb 13, 2019

Copy link to clipboard

Copied

Yes. Fixes the issue.

Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2019 0
kglad LATEST
Adobe Community Professional ,
Feb 13, 2019

Copy link to clipboard

Copied

you're welcome.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2019 0