Highlighted

Animate no longer exporting to SVG - 'undefined' error

Explorer ,
Feb 02, 2017

Copy link to clipboard

Copied

I use Animate's legacy Export to SVG function frequently (and don't understand why this was relegated to being a legacy export anyway), but recently it appears to have stopped working.

All the dialog boxes appear as usual. When the export has completed, the only file generated is a text file called 'undefined'. This file cannot then be opened in any app at all.

Any advice on how to manage this would be welcome. I have many files already designed in Animate which I don't want to have to redesign all over again in Illustrator.

Hi All,

This issue has been addressed in the update released for Animate CC 2017. This update also comes with an improved Brush sketching experience and other important bug fixes. For more details please refer to New features summary for the 2017 release of Animate CC

Please update your copy of Animate CC 2017 to the latest (16.2.0.24) using Adobe Creative Cloud desktop application. If you do not see the update for Animate under the Apps panel of Adobe Creative Cloud application then please click on the gear icon and choose Check for App Updates menu.

Thanks!

Mohan

Views

5.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Animate no longer exporting to SVG - 'undefined' error

Explorer ,
Feb 02, 2017

Copy link to clipboard

Copied

I use Animate's legacy Export to SVG function frequently (and don't understand why this was relegated to being a legacy export anyway), but recently it appears to have stopped working.

All the dialog boxes appear as usual. When the export has completed, the only file generated is a text file called 'undefined'. This file cannot then be opened in any app at all.

Any advice on how to manage this would be welcome. I have many files already designed in Animate which I don't want to have to redesign all over again in Illustrator.

Hi All,

This issue has been addressed in the update released for Animate CC 2017. This update also comes with an improved Brush sketching experience and other important bug fixes. For more details please refer to New features summary for the 2017 release of Animate CC

Please update your copy of Animate CC 2017 to the latest (16.2.0.24) using Adobe Creative Cloud desktop application. If you do not see the update for Animate under the Apps panel of Adobe Creative Cloud application then please click on the gear icon and choose Check for App Updates menu.

Thanks!

Mohan

Views

5.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Feb 02, 2017

Copy link to clipboard

Copied

works for me.

you could try resetting your preferences -

by removingr

Win:

C:\Users\<username>\AppData\Local\Adobe\Animate CC 2017\ and

C\Users\<username>\AppData\Roaming\Adobe\Animate\2017\

Mac: 

/Users/<username>/Library/Application Support/Adobe/Animate CC 2017/ and

/Users/<username>/Library/Preferences/Adobe/Animate/2017

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 02, 2017

Copy link to clipboard

Copied

Thanks - on my Mac (running El Capitan) I don't appear to have either of the folders you list.

Within the Library/Application Support/Adobe folder, Animate isn't listed.

Within my Preferences folder, there are no Adobe subfolders.

I do have a strange folder in Library/Shared/Adobe/OOBE, containing a single file 'ffc'.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 02, 2017

Copy link to clipboard

Copied

You may have been looking in /Library instead of ~/Library. In Finder use the Go menu to Go to Folder. Paste this in: ~/Library/Preferences/Adobe/Animate/2017

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 02, 2017

Copy link to clipboard

Copied

I've removed these folders, and also done a clean re-install of Animate CC 2017... but SVG export is still not working.

Other formats (JPEG, PNG, etc.) export fine. But when exporting to SVG Animate doesn't appear to be generating a file. I'm now not even getting the 'undefined' file appearing as it was before.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 02, 2017

Copy link to clipboard

Copied

I have also noticed that in the dialog export box, the SVG Profile box now appears to be inactive... I wonder if this is related to the issue. Screen Shot 2017-02-02 at 23.17.45.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 02, 2017

Copy link to clipboard

Copied

i can't select profiles either (probably because i only have one), but exporting still works for me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 02, 2017

Copy link to clipboard

Copied

That it works for you is nice for you, but doesn't help me a great deal.

I've installed CC 2015.2 and will use that instead - I've just tried it and the exporting works fine in the earlier version.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 02, 2017

Copy link to clipboard

Copied

For what it's worth, I get the same apparent successful export, but get no file. Not even a text one. It could be a Mac only bug worth reporting.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 02, 2017

Copy link to clipboard

Copied

At least now I know it's not just me!

I've filed a bug report.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 02, 2017

Copy link to clipboard

Copied

I know this doesn't help but on my 2012 MacBook Pro running Animate CC V 16.0.1.119 it exported to SVG successfully. Is this an issue you are experiencing on windows? What is your current build version of Animate?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 02, 2017

Copy link to clipboard

Copied

Maybe the problem only showed up in the latest version. We're on 16.1.0.86, that is, 2017.1. You must still be on 2017.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 02, 2017

Copy link to clipboard

Copied

windows with 16.1.0.86 works.  mac with previous versions works, we think.

it's mac with 16.1.0.86 that's failed for two people.  actually, 3 people because i just tested on my mac and no file was created, at all.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 02, 2017

Copy link to clipboard

Copied

That's right... all was working fine until the latest build.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 02, 2017

Copy link to clipboard

Copied

I know you logged a bug, I've posted a note in the prerelease forum too, so the Animate team get to read about the problem.

Likes

1 Like

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 02, 2017

Copy link to clipboard

Copied

Quick response from the Animate team. The issue is being looked into. For now, Publish Settings, check the SVG box, click the Publish button, does work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 02, 2017

Copy link to clipboard

Copied

[this is getting funnier.  are you talking to yourself now?]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 02, 2017

Copy link to clipboard

Copied

I got emails from the prerelease and from here at the same time, and thought I had replied to the prerelease. I deleted one message here that was meant just for prerelease. I hadn't said anything bad, but it didn't help with the conversation here at all. I could have deleted message 17 too, because Mohan beat me, but I had written more specific steps than he did.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Feb 03, 2017

Copy link to clipboard

Copied

No worries at all. More information is less than no information.

There have been times when someone else beat me to my answer making the OP wonder why I had to repeat information that had already been posted.

Thanks,

Preran

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Feb 02, 2017

Copy link to clipboard

Copied

Hi,

Thanks for reporting this issue. This is a Mac only, build 86 specific issue and we are looking into it. In the interim, could you please use File>Publish workflow to generate SVG files if that helps?

Thanks!

Mohan

Likes

1 Like

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 02, 2017

Copy link to clipboard

Copied

lol.  that worked for me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 13, 2017

Copy link to clipboard

Copied

Hi,

I just thought I'd add, that I can't export an svg either way. When exporting via the legacy option, i have no save button in the small dialogue box (no cancel or save button) just a space as to where they should be.

And also the publish svg option does not generate the svg (swf is fine, as that appears). I'm working on the latest 16.1.0.86 version and I'm running on Windows 10 under bootcamp on a Mac.

Will the team be looking into this too?

Cheers,

Richard

Also, why, as a vector drawing and animating package can you not make it easier to export a vector image? In previous versions you could export as an ai, but no more? Seems odd that the only vector export is via the (legacy) route?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Feb 13, 2017

Copy link to clipboard

Copied

Hi Richard,

Can you please share the snap shot of your Display settings from your system? (Settings > System > Display). Since you are on Windows both Export and Publish should generate SVG as expected.

Thanks!

Mohan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 13, 2017

Copy link to clipboard

Copied

Hi Mohan,

Please find attached the display settings screenshot.

Is there any further information that you might need?

Cheers,

Richard

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Feb 13, 2017

Copy link to clipboard

Copied

Hi Richard - sorry I don't see the snap shot in your post

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 13, 2017

Copy link to clipboard

Copied

Sorry here it is attached this time,

Regards,

Richard

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 13, 2017

Copy link to clipboard

Copied

When using Publishing Settings/SVG, there isn't a Save button. You use the Publish button at the bottom of the dialog. If you don't see Help Publish Cancel OK along the bottom of that panel, then the team are suspecting that you're not up to date with Animate, and that your display scaling settings are not at the default value.

As for Ai, I can't even remember there being an Ai exporter, but it wouldn't be needed if you are working with Ai. You can copy and paste from Animate to Illustrator.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 13, 2017

Copy link to clipboard

Copied

Hi Colin,

As far as I’m aware I am up to date with Animate, 2017.1 Release, Build 16.1.0.86 (updated it only just last week). My creative cloud app doesn’t mention any new updates.

I’m running at 5120x2880 with 200% display scaling for accessibility.

My mistake re Ai export, I was referencing Flash CS4 (an old version we used) and thought that animate was a direct updated version of that. However, copy and pasting from Animate to illustrator seems to paste a bitmap version of the vectored image, so is not really what I was after.

Regards,

Richard

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 13, 2017

Copy link to clipboard

Copied

That version should be ok. Do you see the Publish button at the bottom, and does using that create an SVG?

Good point about the bitmap in Illustrator, I should have noticed that! Flash Pro had a major rewrite after CS4, so some old features were removed for a while.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 13, 2017

Copy link to clipboard

Copied

Hi Colin,

This is what I see (see attached), no buttons at the bottom at all, and so it doesn’t create the svg.

It does seem a shame that they lost that ability to easily save out a vector file. It’s far easier to create logos, icons, cartoon gfx in flash/animate than in any other package. I’ve worked with flash for illustration purposes since flash2 (long long time ago) and it seems that every time they expanded the coding side of things they rarely touched the graphics side.

Regards,

Richard

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 13, 2017

Copy link to clipboard

Copied

Your attachments are not showing up, other than the one in message 21. I'm not sure where that dialog appears, I don't have any panels that say ExportSVG against a yellow background.

If it is the Publish Settings dialog, it's about the right height, but all the elements are at 2X size. Which would suggest that the latest fixes in 16.1.0.86 don't include the Publish Settings dialog.

Could you set your display to 100%, just long enough to see if the buttons do appear, and if an SVG is published?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 13, 2017

Copy link to clipboard

Copied

Hi Colin, at last!

It looks as though you were right, the cancel and ok buttons appeared when I went back to 100% mode on the display settings (mind you, trying to use it at that size is impossible). Would the fix be in soon? However a rather odd thing has occurred, when I just switched back to the 200% display and tried again, the publish settings dialog had the ok and cancel button in them! It’s like it remembered the positions.

Regards,

Richard

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 13, 2017

Copy link to clipboard

Copied

It's possible that the preferences files from Animate before the fix could have been interfering with the after the fix version. Hopefully it will stay looking ok now.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 13, 2017

Copy link to clipboard

Copied

Let’s hope so, I’ll check later when I reboot my system.

On a separate but related note, when trying to export a svg from a file on our network I get a small dialogue box saying that “A javascript error has occurred”. I’ve been told that we have a UNC network and maybe there is a pathname issue? Does that ring any bells your end?

Regards,

Richard

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 13, 2017

Copy link to clipboard

Copied

I have heard of various network drive issues, though not specifically to do with Animate. It may be to do with how paths can have a long English version and a DOS compatible version. But I'm mostly guessing! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Feb 13, 2017

Copy link to clipboard

Copied

Ok Colin,

Thanks for your help with all this stuff,

Regards,

Richard

Likes

1 Like

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Mar 05, 2017

Copy link to clipboard

Copied

I'm having this exact problem. I've even uninstalled Animate CC and reinstalled. Is there a solution yet?

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Mar 05, 2017

Copy link to clipboard

Copied

I have a feeling that there will be an update in the not too distant future. Hopefully the SVG thing will be fixed.

Make sure though that you know about the easy work-around. Go into Publish Settings and check just the box for SVG Image, then do a Publish.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Mar 23, 2017

Copy link to clipboard

Copied

I have the same issue, but the work-around is working - any update on when it'll be fixed properly?

It's a bit of a pain.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Mar 29, 2017

Copy link to clipboard

Copied

Hi All,

This issue has been addressed in the update released for Animate CC 2017. This update also comes with an improved Brush sketching experience and other important bug fixes. For more details please refer to New features summary for the 2017 release of Animate CC

Please update your copy of Animate CC 2017 to the latest (16.2.0.24) using Adobe Creative Cloud desktop application. If you do not see the update for Animate under the Apps panel of Adobe Creative Cloud application then please click on the gear icon and choose Check for App Updates menu.

Thanks!

Mohan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...