Animation of Avatar in Apps

Community Beginner ,
Feb 22, 2021 Feb 22, 2021

Copy link to clipboard

Copied

Good evening everyone!

I have an application in HTML5 canvas and I want to add some basic animations of two characters in the main page. 

I added one character (make him a symbol graphic) and then inside the symbol I made a motion tween with the alpha parameter (for that I remake a new symbol graphic, so a symbol inside a symbol).

In the stage, I see the changes ok and everything, but when I publish to see the result in the browser, the animation is not visible at all. What I did wrong here?

Help if know the problem, please!

Views

72

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 23, 2021 Feb 23, 2021

Copy link to clipboard

Copied

open your browser's developer console and check for errors.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 23, 2021 Feb 23, 2021

Copy link to clipboard

Copied

The mistakes that the console shows are the following:

penelope16B6_0-1614091738825.png

But I do not understand the meaning in the animation perspective... "Not Found"...What exactly not found, if I see it in my stage and when I play it ( in my stage it´s ok)?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 23, 2021 Feb 23, 2021

Copy link to clipboard

Copied

You can ignore the favicon warning. The second warning is letting you know that the property 'x' is being addressed on an object referece that doesn't exist in your code. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 23, 2021 Feb 23, 2021

Copy link to clipboard

Copied

The certain mistake that refres to is not the animation that I cannot see...

So when I remove the element that I tell you, I have no mistakes in the console but I still cannot see my animation of my avatar...

penelope16B6_0-1614093516672.png

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 23, 2021 Feb 23, 2021

Copy link to clipboard

Copied

LATEST

that javascript error is causing the problem and is the reason i suggested opening that console.  you need to fix that error.  and i'm not sure what "element" you removed but that's probably causing a different problem.  so replace the "element" and fix the error.

 

if you need help with that, click the link and then copy (and paste here) the lines just above the error, the line with the error and a few lines below the error.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines