Highlighted

Animation problem with te skill Bones

Community Beginner ,
Oct 06, 2020

Copy link to clipboard

Copied

I am repeating my problem because I have not had an answer.
I work with ADOBE ANIMATE 2020 and with an HTML5 CANVAS version and with characters in vector format (worked with ADOBE ILLUSTRATOR integrated into ANIMATE via copy / paste).
I try to make 2 characters walk with the "Bones" tool and via a structure of nested symbols (the main character / its different parts (legs, arms, etc.) and in each part the animation of the leg and the arms.
with copies of the arm and leg symbols for the 2nd arm / leg.
Everything works fine when I watch the animation in the software, but as soon as I watch it in the browser (Chrome or Firefox), the second left leg and the second arm of my character do not move (no animation )?
And I don't understand.

I have started over several times with different options and never managed to avoid this problem.
Could someone help me?

Views

47

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Animation problem with te skill Bones

Community Beginner ,
Oct 06, 2020

Copy link to clipboard

Copied

I am repeating my problem because I have not had an answer.
I work with ADOBE ANIMATE 2020 and with an HTML5 CANVAS version and with characters in vector format (worked with ADOBE ILLUSTRATOR integrated into ANIMATE via copy / paste).
I try to make 2 characters walk with the "Bones" tool and via a structure of nested symbols (the main character / its different parts (legs, arms, etc.) and in each part the animation of the leg and the arms.
with copies of the arm and leg symbols for the 2nd arm / leg.
Everything works fine when I watch the animation in the software, but as soon as I watch it in the browser (Chrome or Firefox), the second left leg and the second arm of my character do not move (no animation )?
And I don't understand.

I have started over several times with different options and never managed to avoid this problem.
Could someone help me?

Views

48

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 06, 2020 0
Guide ,
Oct 06, 2020

Copy link to clipboard

Copied

Since it's a Canvas file, have you applied Color effect to the instance, for example negative Brightness?

This can be causing the described behaviour. It's a limitation of Canvas.

You would have seen warnings in Output upon publish. Read them carefully.

 

- Nick: Character designer and animator, Flash user since 1998
Member of Flanimate Power Tools team - extensions for character animation

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 06, 2020 0
Community Beginner ,
Oct 06, 2020

Copy link to clipboard

Copied

Finally !
Bigs thanks to you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 06, 2020 1
Guide ,
Oct 06, 2020

Copy link to clipboard

Copied

Well done, mate!

I'm glad I could help.

 

- Nick: Character designer and animator, Flash user since 1998
Member of Flanimate Power Tools team - extensions for character animation

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 06, 2020 0