Arrow keys don't work inside groups or movie clips (nudging subselections)

New Here ,
Jan 04, 2021 Jan 04, 2021

Copy link to clipboard

Copied

This is an age old issue but I never asked about it before. If you group something or make it a symbol, and then try to use the subselection tool, somtimes it wont work. You end up having to break the object and start over, or redraw the part. Just wondering why that is and if there is a way to avoid that. Is it a setting?

 

Thanks in  advance!

Views

101

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 05, 2021 Jan 05, 2021

Copy link to clipboard

Copied

i wouldn't expect you to be able to work within a movieclip or group unless you double click it.  that's part of the purpose of grouping/using a movieclip

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 12, 2021 Jan 12, 2021

Copy link to clipboard

Copied

What I am trying to say is, once you double click to get inside the group or clip, sometimes the arrow keys do not work, sometimes they do. When trying to make very fine changes, that is an issue. Just wondering why the inconsistancy? Is it a setting? I've been working with this program since it was Macromedia, and this has always been an issue. At least it seems to me. Am I the only one this happens to?

 

I have a lot of MCs with MCs nested inside, and if you get into subselections of nested MCs or groups inside them, things get really funky. Especially when I am zoomed in at 400 percent... Normally I dont care that much, but I am building a lot of schematics and blueprints that I export as SVG, and since they have that built in IE zoomability, precision is paramount.

That's why I had the other post about snapping. Even if you do everything right, AN is still very inconsistant. Where you grab an object seems to determine where it will snap. I am actually trying to make SVG a standard for DOD training.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 12, 2021 Jan 12, 2021

Copy link to clipboard

Copied

I wonder how small are your assets? If you zoom your stage to 100%, are your assets very very small relative to the stage?

Animator and content creator for Animate CC

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 12, 2021 Jan 12, 2021

Copy link to clipboard

Copied

i just made a normal line, about 250 pixels long, turned it into a symbol, opened it and made the line a group. I opened that group and the sub selction (A) would no longer work with the arrow keys. No one else see this problem?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jan 13, 2021 Jan 13, 2021

Copy link to clipboard

Copied

I just followed those same steps on a Mac and on Win using the latest version of AnCC and I didn't have a problem editing the line with the sub-selection tool. But what has me confused is why you are using the arrow keys? Are you trying to simply move the line with the arrow keys? If so, use the Selection tool (black arrow) to select the line and then move with the arrow keys.

Animator and content creator for Animate CC

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 14, 2021 Jan 14, 2021

Copy link to clipboard

Copied

I am trying to make fine adustments to lines most of the time. I do no want to move the entire line, just one end. I can supply an FLA file that shows exactly what I am talking about. I just dont know how to post an fla here. Last time I tried, I got an error saying the file extension did not match. V tool always works when inside an MC or group. A tool, sometimes not. I you break the group, then the A tool works again. I thought it may be a snap setting but I can't seem to nail it down. If that does not resonate with anyone, I will just let it go. Not a show stopper, just a thing I have seen thru the years...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 14, 2021 Jan 14, 2021

Copy link to clipboard

Copied

LATEST

Hello,

 

Can you please share a short recording or a sample file to mail id:  abv@adobe.com

Please zip the file and share it across. This will help us investigate the issue. Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines