Bad resolution layers when importing from PS

New Here ,
Dec 16, 2016 Dec 16, 2016

Copy link to clipboard

Copied

So, I made a small background in photoshop and I want to animate the clouds, but when I imported the layers to Animate, they all got with a terrible resolution, my low oppacity layers are all pixelated and have white all around them, Can someone help me?

http://i.imgur.com/G1FAVoz.png

(sorry for my bad english tho)

Views

975

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Dec 17, 2016 Dec 17, 2016
There are at least two things you can set to improve the image. In the Library select the images and click the Properties i button. In there you can enable Smoothing, and also change the quality to lossless or high quality JPEG. The other thing is to increase the stage quality. Put this script in the Actions panel of frame 1 in the timeline:stage.quality = "best";That should make it look a lot better.

Likes

Translate

Translate
Adobe Community Professional ,
Dec 17, 2016 Dec 17, 2016

Copy link to clipboard

Copied

is that a screenshot?

if so, of the animate stage?  or the published swf?  something else?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 17, 2016 Dec 17, 2016

Copy link to clipboard

Copied

it's from the animate stage, although the swf looks similar.

Ive tried changing the quality to lossless and all but its still pixelated, I dont know if I have to do something in photoshop before importing or not

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 17, 2016 Dec 17, 2016

Copy link to clipboard

Copied

oh never mind, I fixed it, wasnt changing from Lossy to Lossless when importing, thank you

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 17, 2016 Dec 17, 2016

Copy link to clipboard

Copied

With the export from Photoshop you may as well make it be either PNG or PSD. No point in JPEG compressing it at that stage, if file size becomes an issue you can set the JPG compression in Animate.

Make sure you try the stage.quality = "best"; line too, that can make a big difference.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 17, 2016 Dec 17, 2016

Copy link to clipboard

Copied

There are at least two things you can set to improve the image. In the Library select the images and click the Properties i button. In there you can enable Smoothing, and also change the quality to lossless or high quality JPEG. The other thing is to increase the stage quality. Put this script in the Actions panel of frame 1 in the timeline:

stage.quality = "best";

That should make it look a lot better.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 08, 2020 Jun 08, 2020

Copy link to clipboard

Copied

LATEST

you are an angel person, thank you so much! had this same issue and thought it was just part of the program

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines