Brush tool not working and Color Swap not even an option

New Here ,
Apr 11, 2021 Apr 11, 2021

Copy link to clipboard

Copied

Rather than create the usual line or shape, whatever line or shape I draw with the brush tool is immediately converted into an outline of the shape or line once I release the pressure from the stylus. Similarly, if I try to use the fill tool, instead of filling a given gap or hole, the whole layer's worth of drawings are converted to these outlines. These outlines look similar to the outline shown when I press the "Show Layer as Outline" button, but in whatever color is currently selected as the "Fill Color". This without the "Show Layer as Outline" button even being selected for the layer I'm drawing on.

If I do activate the "Show Layer as Outline" button, what I see is each individual stroke or shape drawn as it's own outline as if the "Object Drawing" button was selected (by this I mean that rather than a large shape being shown by it's own outline, I would see every single stroke taht makes up that larger shape. A nightmarish mish-mash of lines on lines layering on top of one another). It's not on, but it shows it that way anyways (and I should mention, it's not actually making these strokes object, I can still select them as a normal vector drawing, there is no blue box like there would be if it were a selected object).

The Color swap otion does not work either. On the left of the screen where I have my tools panel, I can see both the fill color and the stroke color as usual. But in the Color window, no stroke color can be selected, it's stuck as a window with that red dash through it and I cannot select it, much less select a color.

I have reset and restarted Animate twice. I've restarted my computer. I've checked my preferences. There is no indication anywhere that I can see that I have changed my preferences or made a wrong selection. I don't know why it's doing this. It wasn't doing it yesterday and it just started doing it in a project that had no other previous issues. . . Other than the frequent crashes that have become all too common with Animate.

Does anyone else have this issue? Is there a way to fix this?

Also, If I could get Animate to stop crashing once or twice every day, that'd be nice too.

TOPICS
ActionScript, Other, Performance

Views

58

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 11, 2021 Apr 11, 2021

Copy link to clipboard

Copied

Hello rhyse96676966, I'm afraid I can't help with Brush tool problem.  I've one experimented with the tool a few times and I don't remember the problem you're describing.  However, I may be able to give you a tip with the color swap.  When the most recent edition of Animate came out the color tools were not working as simply.  Before, when I clicked a fill or stroke color with one of the three options for controling color (from the tool bank, opening the Color Window with ctrl-shft-F9, or the Properties Window with ctrl-F3), then that color would be transfered to the other two.  Now that doesn't always work.  If I have to transfer a color I usually open the Properties Window and use that to transfer to the other two, although that doesn't always seem to work and sometimes I have to play with it.  So my recommendation is if the your having problems getting the Color Window to do what you need then open the Properties Window.  

 

I also may be able to tell you why there's no stroke color in your Color Window.  That's what happens if you select a fill object without a line.  If you only select a line without a fill you won't see a fill color in your Color Window.  The only thing I can recommend is if you can't get your Color Window to do what you want then work with the tool bank or Properties Window. 

 

This is all very frustrating because none of this was an issue with previous editions of Flash, but now we have to work with what we got. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Apr 11, 2021 Apr 11, 2021

Copy link to clipboard

Copied

Regarding the permanent 'outline issue', go to your View>Preview Mode menu and switch to something like Anti-alias or Full.

 

Clipboard-1.png

Nick – Character designer and animator, Flash user since 1998
Member of Flanimate Power Tools team – extensions for character animation – flash-powertools dot com

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines