Highlighted

Cannot install HTML5 Canvas Audio Component Extension!

Explorer ,
Feb 04, 2020

Copy link to clipboard

Copied

Please can someone tell me if the HTML5 Canvas Audio Component is compatible with Animate 19.2.1.

I have tried all sorts of ways to try and install it:

- Directly from extensions web site

- Manually using Anastasiy Extension Manager application

- Manually using ZXPInstaller application

- Manually using ExManCmd command line manager

Nothing seems to work.

The zxp file seems to be more than a renamed .zip file so I can extract it manually.

If someone can please help with any information on compatibility and any other methods I could use to install the extension.

Thank you.

Hi mate,

 

From what I see, it puts just this folder called "audio" in HTML5Components in Config.

 

So I repackaged for you and here is a ZIP with the folder and files:

https://drive.google.com/file/d/1IxZVxLsSGaCHjh96P_63ewwX3y5wgpwC/view?usp=sharing

Unzip and put the folder called "audio" inside your HTML5Components in Config

 

You should do this while Animate is closed.

Find your Config folder:

on Win:

C:\Users\YourUserName\AppData\Local\Adobe\Animate CC YourVersion\YourLocale\Configuration

on Mac:

HD\Users\YourUserName\Library\Application Support\Adobe\Animate CC YourVersion\YourLocale\Configuration
 
Then find HTML5Components and put the 'audio' inside.
Clipboard-1.png
 
Start Animate (19.2.1).
Create a HTML5/Canvas file.
Open Components.
Clipboard-2.png
 
Hope this helps!
 

Topics

Download and install, Exchange extensions, How to, Product issue

Views

1.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Cannot install HTML5 Canvas Audio Component Extension!

Explorer ,
Feb 04, 2020

Copy link to clipboard

Copied

Please can someone tell me if the HTML5 Canvas Audio Component is compatible with Animate 19.2.1.

I have tried all sorts of ways to try and install it:

- Directly from extensions web site

- Manually using Anastasiy Extension Manager application

- Manually using ZXPInstaller application

- Manually using ExManCmd command line manager

Nothing seems to work.

The zxp file seems to be more than a renamed .zip file so I can extract it manually.

If someone can please help with any information on compatibility and any other methods I could use to install the extension.

Thank you.

Hi mate,

 

From what I see, it puts just this folder called "audio" in HTML5Components in Config.

 

So I repackaged for you and here is a ZIP with the folder and files:

https://drive.google.com/file/d/1IxZVxLsSGaCHjh96P_63ewwX3y5wgpwC/view?usp=sharing

Unzip and put the folder called "audio" inside your HTML5Components in Config

 

You should do this while Animate is closed.

Find your Config folder:

on Win:

C:\Users\YourUserName\AppData\Local\Adobe\Animate CC YourVersion\YourLocale\Configuration

on Mac:

HD\Users\YourUserName\Library\Application Support\Adobe\Animate CC YourVersion\YourLocale\Configuration
 
Then find HTML5Components and put the 'audio' inside.
Clipboard-1.png
 
Start Animate (19.2.1).
Create a HTML5/Canvas file.
Open Components.
Clipboard-2.png
 
Hope this helps!
 

Topics

Download and install, Exchange extensions, How to, Product issue

Views

1.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Guide ,
Feb 04, 2020

Copy link to clipboard

Copied

Hi mate,

 

From what I see, it puts just this folder called "audio" in HTML5Components in Config.

 

So I repackaged for you and here is a ZIP with the folder and files:

https://drive.google.com/file/d/1IxZVxLsSGaCHjh96P_63ewwX3y5wgpwC/view?usp=sharing

Unzip and put the folder called "audio" inside your HTML5Components in Config

 

You should do this while Animate is closed.

Find your Config folder:

on Win:

C:\Users\YourUserName\AppData\Local\Adobe\Animate CC YourVersion\YourLocale\Configuration

on Mac:

HD\Users\YourUserName\Library\Application Support\Adobe\Animate CC YourVersion\YourLocale\Configuration
 
Then find HTML5Components and put the 'audio' inside.
Clipboard-1.png
 
Start Animate (19.2.1).
Create a HTML5/Canvas file.
Open Components.
Clipboard-2.png
 
Hope this helps!
 
- Nick: Character designer and animator, Flash user since 1998
Member of Flanimate Power Tools team - extensions for character animation

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 04, 2020

Copy link to clipboard

Copied

Many thanks, that worked a treat!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 04, 2020

Copy link to clipboard

Copied

Hmmm - it should work with 2018, 2019, and 2020... I'm the author so am worried if it isn't working for some people!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 04, 2020

Copy link to clipboard

Copied

It was the installation of the extension that I had trouble with.

On various attempts,depending on what method I tried, it was saying things like:

Invalid license

Unable to connect

Not compatable with software version

 

Some of which were as Error Code references.

 

I'm behind a company firewall, so I don't know if that was mucking things up.

It seemed to be trying to validate licensing during the installation, via various web-site interactions.

Anyway, extracting the unencrypted version above to the correct location seems to install correctly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 04, 2020

Copy link to clipboard

Copied

Hmmm - that may be why. I believe it is encrypted via the Adobe system. Thank you! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Guide ,
Feb 04, 2020

Copy link to clipboard

Copied

Hi Joseph,

 

Let me know if you want me to remove the ZIP and delete my post.

It's helped the OP and there is no point of it staying here any more if you find this unpleasant.

 

Best regards

- Nick: Character designer and animator, Flash user since 1998
Member of Flanimate Power Tools team - extensions for character animation

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Feb 04, 2020

Copy link to clipboard

Copied

Hey, Nick! No, no - no problems at all. Thank you for asking but it's absolutely fine to distribute through other means. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Mar 31, 2020

Copy link to clipboard

Copied

I had a similar issue with the component, I discovered it was installing it under Animate 2020/en_GB (I am UK based) but Animare was using en_US. Once I copied the files accross to the en_US folder the component showed up. My only issue with the component is the autoplay, it doesn't, any suggestions?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Apr 11, 2020

Copy link to clipboard

Copied

Yes am also UK and cant get it to work trying all the standard and above suggestions, I didnt even have a 'HTML5Components' folder, tried to creating and placing files but still no dice.

 

mactep_0-1586616781222.png

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Guide ,
Apr 11, 2020

Copy link to clipboard

Copied

Your path is incorrect, mate.

You're looking for Config at the wrong place.

 

On Mac Config is:

HD\Users\YourUserName\Library\Application Support\Adobe\Animate CC YourVersion\YourLocale\Configuration

 

- Nick: Character designer and animator, Flash user since 1998
Member of Flanimate Power Tools team - extensions for character animation

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Apr 11, 2020

Copy link to clipboard

Copied

Thank you, my 'Library' folder was hidden, hence the other destination I found originally.

I too had the GB and US folders, once copied into US it is now appearing :o)

Just need to wait for Adobe to release some code snippets and actions to control audio, seems such a basic feature considering its purpose

https://community.adobe.com/t5/animate/controlling-audio-in-canvas/td-p/11041033?page=1

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 12, 2020

Copy link to clipboard

Copied

I have the same issue, when I look in the Application Support folder there isn't one for Adobe Animate.

Screenshot 2020-04-12 at 16.11.52.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Guide ,
Apr 12, 2020

Copy link to clipboard

Copied

You don't have the same problem, mate.

Can you even follow a path?

https://osxdaily.com/2016/12/12/show-user-library-folder-macos-sierra/

 

- Nick: Character designer and animator, Flash user since 1998
Member of Flanimate Power Tools team - extensions for character animation

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 12, 2020

Copy link to clipboard

Copied

Can you answer a question without sarcasm?

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 09, 2020

Copy link to clipboard

Copied

Hi I added audio component. I have Autoplay problem. I ticked autoplay but sound didnot autoplay. I uncheck autoplay but sound did not autoplay.

I try to change in js code(components.js).

I changed " {"name": "PROP_AUTOPLAY", "variable": "autoplay", "type": "Boolean", "default": "true"}," 

but not working. 

Please help how can ı autoplay sound.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 09, 2020

Copy link to clipboard

Copied

Also, when adding the component, if you cannot see the component properties directly in the properties menu, you can find it from the picture I have specified below. I hope you have experienced this problem will help you. Maybe someone can help me with my problem.

ekrna.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 09, 2020

Copy link to clipboard

Copied

I solved autoplay problem

if I run on program (ctrl+enter) not working autoplay.  I publish in file menu and open html file thats work. thats time working good.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jul 09, 2020

Copy link to clipboard

Copied

Generally most browsers have autoplay restrictions. So while testing your content using test movie (ctrl+enter) , you need to allow autoplay sound in browser settings for localhost url. Please try and see if it helps in your case. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...