Classic Tweening Glitch/Bug?

New Here ,
Feb 08, 2021 Feb 08, 2021

Copy link to clipboard

Copied

So, I was using the classic tween to animate I decided to tween the legs for a normal walk cycle, but when I played the animation, it seemed to be that the leg just started moving upward, and then snap to the position I put the leg in. Though I figure out this one, I used to have this problem with the body and when I tweened it along with the arns, the character just breaks apart and once again snaps to the position I put it in. The problem I currently have is for the legs. Even though I only have a problem with the legs, can you please tell how to fix both?

Thanks!

TOPICS
Error, Product issue

Views

157

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Guide , Feb 08, 2021 Feb 08, 2021
Hi mate, This is neither a bug, nor a glitch. What you describe is the common manifestation of moved Transformation points in one of the keyframes of the Classic Tween.The quick fix is to double-click the Transformation points with the Free Transform tool so that they snap back over the Registration points. Here is an in-depth article that will give you a good understanding of the problem and how to avoid complications in the future:  https://flash-powertools.com/understanding-symbol-registration/...

Likes

Translate

Translate
Adobe Community Professional ,
Feb 08, 2021 Feb 08, 2021

Copy link to clipboard

Copied

the fix depends on what caused the problem and that's unknown.  you can get general help but that may not help you solve the problem.

 

to get more help you should start by explaining what kind of tweens you're using.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Feb 08, 2021 Feb 08, 2021

Copy link to clipboard

Copied

Hi mate,

 

This is neither a bug, nor a glitch.

 

What you describe is the common manifestation of moved Transformation points in one of the keyframes of the Classic Tween.

The quick fix is to double-click the Transformation points with the Free Transform tool so that they snap back over the Registration points.

 

Here is an in-depth article that will give you a good understanding of the problem and how to avoid complications in the future:  https://flash-powertools.com/understanding-symbol-registration/

 

Nick – Character designer and animator, Flash user since 1998
Member of Flanimate Power Tools team – extensions for character animation – flash-powertools dot com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied

Thank you, I realized the points were wrong on my character, so I fixed the points on several different characters, now they can be tweened normally!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Feb 09, 2021 Feb 09, 2021

Copy link to clipboard

Copied

LATEST

Well done, mate!

 

Nick – Character designer and animator, Flash user since 1998
Member of Flanimate Power Tools team – extensions for character animation – flash-powertools dot com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines