Highlighted

Copying Armature Not Working

New Here ,
Apr 24, 2020

Copy link to clipboard

Copied

I have learned how to construct a simple character sprite using the Bone tool. Im able to make this character move any way I want and it seems to work fine. However, I wanted to have a scene where the character was talking to himslef, and when I duplicate the sprite along with the IK Armature, it seems to break. The symbols and the armature are still there, but they are disconnected. The symbols are able to move freely and arent restrained to the skeleton I made for it. It even sometimes stretches them everywhere. I am also not able to edit any poses later on in the animation with this duplicated character.

 

Is there a way to duplicate a character with IK Armature and have all the parts stay in tact?

 

(Also, the shoulder piece of the rig seems to be stuck in place, even though I never locked it.)

mikel99473745_0-1587793874696.png

mikel99473745_1-1587793904934.png

 

 

TOPICS
How to

Views

133

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Copying Armature Not Working

New Here ,
Apr 24, 2020

Copy link to clipboard

Copied

I have learned how to construct a simple character sprite using the Bone tool. Im able to make this character move any way I want and it seems to work fine. However, I wanted to have a scene where the character was talking to himslef, and when I duplicate the sprite along with the IK Armature, it seems to break. The symbols and the armature are still there, but they are disconnected. The symbols are able to move freely and arent restrained to the skeleton I made for it. It even sometimes stretches them everywhere. I am also not able to edit any poses later on in the animation with this duplicated character.

 

Is there a way to duplicate a character with IK Armature and have all the parts stay in tact?

 

(Also, the shoulder piece of the rig seems to be stuck in place, even though I never locked it.)

mikel99473745_0-1587793874696.png

mikel99473745_1-1587793904934.png

 

 

TOPICS
How to

Views

134

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 24, 2020 0
Guide ,
Apr 24, 2020

Copy link to clipboard

Copied

Hi mate,

 

No one really uses the armature feature for one simple reason - it is unusable for any practical purposes.

The sooner you abandon the attempts to make it work across scenes and files, the more pain and frustration this will save you.

 

Try to see if the built-in Layer Parenting is good enough for you or upgrade to Smart Magnet Rigs.

 

- Nick: Character designer and animator, Flash user since 1998
Member of Flanimate Power Tools team - extensions for character animation

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 24, 2020 0