Highlighted

Disabling hidpi screens adn responsive scaling

New Here ,
Nov 10, 2019

Copy link to clipboard

Copied

Hey there, 

I am using Animatecc in a web app where I created an API that adds some DomElements to the animation and replace the dynamic texts initially inserted. the problem is that when zooming in or out, the transform matrix is being recalculated by the function

makeResponsive which tries to adjust the canvas width and height and all elements within the animation_container. 

My question is whether there is an option to disable this in Animate or should I comment this line of code each time I am generating an animation to make it work. 

thank you. I tried to disable the responsiveness in the publish options but it didn't work.

 

Capture.JPG

You could go to publish settings, go to HTML/JS and export there the standard publishing template. There you can remove the following code:

//Code to support hidpi screens and responsive scaling.
$RESP_HIDPI

TOPICS
ActionScript, Code, How to, Other

Views

169

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Disabling hidpi screens adn responsive scaling

New Here ,
Nov 10, 2019

Copy link to clipboard

Copied

Hey there, 

I am using Animatecc in a web app where I created an API that adds some DomElements to the animation and replace the dynamic texts initially inserted. the problem is that when zooming in or out, the transform matrix is being recalculated by the function

makeResponsive which tries to adjust the canvas width and height and all elements within the animation_container. 

My question is whether there is an option to disable this in Animate or should I comment this line of code each time I am generating an animation to make it work. 

thank you. I tried to disable the responsiveness in the publish options but it didn't work.

 

Capture.JPG

You could go to publish settings, go to HTML/JS and export there the standard publishing template. There you can remove the following code:

//Code to support hidpi screens and responsive scaling.
$RESP_HIDPI

TOPICS
ActionScript, Code, How to, Other

Views

170

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 10, 2019 0
Adobe Employee ,
Nov 11, 2019

Copy link to clipboard

Copied

I found a forum post with a solution https://community.adobe.com/t5/Animate/How-to-disable-High-DPI-scaling-in-Animate/td-p/9976467 Can you check and let me know? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 11, 2019 1
Contributor ,
Nov 11, 2019

Copy link to clipboard

Copied

The piece of code should tell you it's a createjs canvas export and not a userinterface problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 11, 2019 1
Contributor ,
Nov 11, 2019

Copy link to clipboard

Copied

You could go to publish settings, go to HTML/JS and export there the standard publishing template. There you can remove the following code:

//Code to support hidpi screens and responsive scaling.
$RESP_HIDPI

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 11, 2019 1
Mcamin LATEST
New Here ,
Nov 13, 2019

Copy link to clipboard

Copied

Thank You. That what I was looking for.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 13, 2019 0