error creating swf movie file

New Here ,
May 19, 2010 May 19, 2010

Copy link to clipboard

Copied

Why am I getting this error message when I try to test a clients swf file from a fla file....Error creating SWF movie file    Be sure the destination file is not locked or on a locked drive

How do I fix it?  I've gotten this before and dont remember what causes it.

Barb

TOPICS
ActionScript

Views

8.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , May 19, 2010 May 19, 2010
save the fla with a new name, use the default swf name and retest.

Likes

Translate

Translate
Adobe Community Professional ,
May 19, 2010 May 19, 2010

Copy link to clipboard

Copied

save the fla with a new name, use the default swf name and retest.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 07, 2020 Jan 07, 2020

Copy link to clipboard

Copied

I am encountering the same problem, getting the "Error creating SWF movie file. Be sure the destination file is not locked or on a locked drive. Also, check that file name is not too long."

I've tried all solutions mentioned in here but nothing works. Help please!

The .fla file is: https://drive.google.com/file/d/1kD5v8XHblAoMXG-nz_vssfdXUBuKEu1Z/view?usp=sharing

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Jan 07, 2020 Jan 07, 2020

Copy link to clipboard

Copied

Just downloaded your file, mate. 

Exports a SWF just fine on my win 10 machine.

 

Nick – Character designer and animator, Flash user since 1998
Member of Flanimate Power Tools team – extensions for character animation – flash-powertools dot com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 07, 2020 Jan 07, 2020

Copy link to clipboard

Copied

Thanks for your quick respond n__tilcheff.

Sorry, I should have explained my initial intention. I actually need to export it as a video file (.mp4), so I tried to do File > Export > Export Video/Media > Quicktime. I'll then convert the .mov file to .mp4 with AME.

I could do the File > Export > Export movie > SWF but that won't get me an .mp4 file unfortunately.

Any idea how else could I export that animation into .mp4?

 

Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Jan 07, 2020 Jan 07, 2020

Copy link to clipboard

Copied

Hi again, mate!

 

I understand.

 

What you can do and what has always worked for me is to export and PNG image sequence, from which you then render an MP4.

This can be done in Premere, AfterEffects, possibly even in AME or any other video application.

 

A long time ago I posted detailed explanation here: https://community.adobe.com/t5/animate/export-issue-stops-mid-export/td-p/10424361

Just read the whole topic for a full picture.

 

Hope this helps!

 

Nick – Character designer and animator, Flash user since 1998
Member of Flanimate Power Tools team – extensions for character animation – flash-powertools dot com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 08, 2020 Jan 08, 2020

Copy link to clipboard

Copied

Thanks again for your prompt response, Nick!

Yeah, I was hoping there could be another solution rather than exporting as hundreds of PNG images.

I guess that is the only solution. 

Alright, that will have to do. Thank you, Nick! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 14, 2021 Feb 14, 2021

Copy link to clipboard

Copied

bagh5CF6_1-1613286163969.png

 

after this i press publish

bagh5CF6_2-1613286164239.png

 

and this

bagh5CF6_3-1613286164212.png

 

what could i do

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 15, 2021 Feb 15, 2021

Copy link to clipboard

Copied

LATEST

i can't read that error message, but try:

 

1. save your fla to a new folder on your desktop

2. click file>publish settings and make sure the output name contains no path symbols (eg, slashes)

3. click file > publish

 

any problem?  (a non-existant path in 2 is a common issue.)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 19, 2010 May 19, 2010

Copy link to clipboard

Copied

I know I can always count on kglad!  It took a couple of tries, but it works now. Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 19, 2010 May 19, 2010

Copy link to clipboard

Copied

you're welcome.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 20, 2010 May 20, 2010

Copy link to clipboard

Copied

Hi,

Back again,  trying to open this fla file from client, yesterday I saved it with new name and today it is locked again, the new name is too!  I have saved it under different names as suggested yesterday, also on external harddrive,  but nothing will open it!  Any tricks to this? Maybe I should delete everything and re download it?

Barb

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 20, 2010 May 20, 2010

Copy link to clipboard

Copied

I figured it out, I clicked on default names at the publish swf screen, that worked.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Dec 02, 2017 Dec 02, 2017

Copy link to clipboard

Copied

Same problem here, nothing mentioned works.

Screen Shot 2017-12-02 at 1.13.42 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines