Exporting video with a transparent background

New Here ,
Jun 21, 2017

Copy link to clipboard

Copied

I have three simple character animation sequences I've created in Adobe Animate CC, and need to export them into some sort of video format so I can drop them in Sony Vegas Pro 14 to edit them from there. The only problem is, I need the backgrounds to be transparent. When exporting them as a .mov, I know you can select the option to ignore the stage color, but all that does is make the background a solid black instead of white. It's still there, and still not transparent.

I can't open .swf files in Vegas, so exporting them as that is out of the question, and Adobe Media Encoder can't open them either. Any ideas on how I can solve this?

TOPICS
Import and export

Views

29.5K

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

1 Correct Answer

Adobe Community Professional , Jun 21, 2017
Colin Holgate Adobe Community Professional , Jun 21, 2017
Look at the track properties to make sure you have set it to use the alpha channel:http://content.videoblocks.com/tipstricks/tutorials/how-to-use-alpha-channel-special-effect-footage-in-sony-vegas/

Likes

Translate

Translate
Jump to answer Jump to answer
Adobe Community Professional ,
Jun 21, 2017

Copy link to clipboard

Copied

It may look black, but really it's transparent. Are you using the MOV, or are you sending it to Adobe Media Encoder? That could cause the alpha channel to be lost. Use the MOV version.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jun 21, 2017

Copy link to clipboard

Copied

what I did was I exported it as a .mov in Animate, then dropped that exact file directly into Vegas. It's still completely black, however, if I try to put a background image layer or anything else under it, it won't show through.

here, I'll provide screenshots. Here's my project, with the animation I made as a "transparent" .mov over some audio

Gyazo - 9614431d9a4abf2d8a4dce903553e036.png

now here is the same project, only this time I put a blank white background underneath the video to test if it really was transparent

Gyazo - ea29799f3b7f7432dfe822e4b4a62550.png

as you can see, it doesn't show through, so the background isn't actually transparent

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jun 21, 2017

Copy link to clipboard

Copied

Look at the track properties to make sure you have set it to use the alpha channel:

http://content.videoblocks.com/tipstricks/tutorials/how-to-use-alpha-channel-special-effect-footage-...

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jun 22, 2017

Copy link to clipboard

Copied

this worked!! thank you so much for your help dang this was a real life-saver!!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jun 22, 2017

Copy link to clipboard

Copied

I gave Asymetrical a 'helpful' too, because what he said about interpret footage was how the same problem would be solved in After Effects.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Aug 27, 2018

Copy link to clipboard

Copied

I'm having the same problem, but I'm trying to put mine into iMovie?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Aug 27, 2018

Copy link to clipboard

Copied

I just tried, and in iMove you don't have to do anything, the exported MOV from Animate works on top of backgrounds in iMovie. If your animation is opaque against background in iMove, make sure you had these settings when you exported:

Screen Shot 2018-08-27 at 3.11.27 PM.png

Don't send it to Adobe Media Encoder, just directly use the MOV in iMovie.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Enthusiast ,
Jun 21, 2017

Copy link to clipboard

Copied

Why don't you have Premiere?

I believe you can export a variety of video formats, it's been a while since I've used anything other than .swf. Are you able to export as a TIF image sequence, that should ignore the background.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jun 21, 2017

Copy link to clipboard

Copied

Premiere isn't able to import SWFs, but After Effects could. But no doubt there's a reason she is using Sony Vegas.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jun 21, 2017

Copy link to clipboard

Copied

I'm using Vegas because that's the editing program I have the most experience in, I'm more used to it. This is my first time attempting animation in Animate CC, so there very well could be something really simple that I just don't understand, or that I'm missing here!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Advocate ,
Jun 21, 2017

Copy link to clipboard

Copied

I remember having this same issue with Animate on a recent project and a lady on the beta team, Terry Toepfer showed me how to do it. I'm not sure how that relates to Vegas but maybe you have a similar option?

To see the alpha channel you have to use Media Encoder and look at the settings for the format you are using. I'll upload a photo showing it. I took your file into After Effects and set the alpha to show using the Interpret footage dialog so I could smooth the edges. I then added a simple loop under it to show that your movie does have an alpha, otherwise the background would render out using the default black.

1zfs8j67zfkx.jpeg

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jun 21, 2017

Copy link to clipboard

Copied

What you describe is for people who use Adobe Media Encoder to process the MOV. In this case the MOV is being used directly, so AME isn't involved.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Dec 08, 2017

Copy link to clipboard

Copied

Dear Colin,

I´ve got a problem that is quite similar, but not solved by the above conversation:

When exporting an Animate file that uses Blur effects in the animation, the video I receive to work with in other software (Final Cut, iMovie) has transparency, sure, but the animated elements have grey shades around them, the alpha channel is not good.

I tried: the original .mov and the movie passed to media encoder.

In Media encoder i tried to find a codec/format that allows me to use 32bit – didn´t find any.

The only one I found was an Apple Prores 4444 using 16bit+alpha, but the effect was the same (grey shades around elements, no clean transparency).

As an info: its about doing title graphics for a movie - white typography that shall appear above the original video.

Is there some workflow that can handle this problem?

Thanks a lot!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Dec 08, 2017

Copy link to clipboard

Copied

If you are ok for drive space, use the MOV in Final Cut Pro X. Once the animation is on top of the background image, select the animation and in the Video Inspector/Compositing/Blend Mode, try using Premultiplied Mix:

premult.png

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jan 24, 2018

Copy link to clipboard

Copied

Dear Colin,

thank you very much! Premultiplied Mix did the trick!

Thanks again!

Lutz

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Nov 24, 2020

Copy link to clipboard

Copied

Dear Colin,

I have trouble with the exact same problem when rendering videos from Animate via Media Encoder, using them in FinalCut Pro.

- Exporting from Animate as QuickTime, Apple ProRes 4444 with alpha, Ignore stage colour clicked

- In Media Encoder, Export-Colour "Rec. 709", depth "16-bpc + Alpha"

I still have the grey shading around white elements when blurred. Or when using an opacity below 100, the element is getting grey. Even if I use "Premultiplied Mix" in FinalCut.

(The same video in AfterEffects, "Luminescent Premul", is fine!)

Is there more to do about this?

Thanks a lot! Best regards

Lutz

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more