Highlighted

Find and replace doesn't work Animate CC 2020,2019,2018

Community Beginner ,
Mar 29, 2020

Copy link to clipboard

Copied

Hello everybody. For some reason, the function "find and replace"  doesn't work for a specific color. I pick the color but error message popup and says it found no color. It worked until two days ago, but I've already tried to uninstall the latest windows updates and reinstall Animate. I thought it was a problem with privacy but now I'm pretty sure to have given all the necessary permits. I ask for help because find and replace is too usefull for me. thank you very much

 

 

Cattura.JPG

Hi mate,

 

The mystery is solved!

 

Many of your colours have 99% alpha.

Clipboard-1.png

 

Symbol Palette Control has no difficulty identifying the correct colour and then replacing it, but by design it keeps the alpha value. In one of your keyframes the colour seems to have been changed to solid.

 

Still with these semi-transparent colours you run into a color picker limitation, where the picker always samples a colour that is a composite - a blend of the actual colour value and what is beneath the shape, so you can't really identify it in the Symbol Palette Control set using the SPC Picker tool, because it relies on sampling from the stage.

 

The default Find and Replace can only work with solid colours (100% alpha) as source, i.e. you cannot search for a colour that is not solid.

 

So...

To fix your file you need to identify all the shapes that don't have a solid colour (100% alpha) and manually re-color them.

Also make sure you delete the 99% swatches and create new ones that are 100%.

 

After that both Find and Replace and Symbol Palette Control will work as they should.

 

As a general advice that has nothing to do with the current colour issue, I would suggest that you rethink your file and start using Symbols, rig the head with mouth and eyes on separate layers and so on.

I have written a lot about this and would like to offer you these two articles which should be very beneficial in long term: 

http://flash-powertools.com/workflow/

http://flash-powertools.com/character-rigging-for-flash-animation/

 

Finally, I wanted to say that I love the designs and your animation!

My criticism is only in regards to structure. A better structure will give you better editability and flexibility.

 

Hope this helps!

 

Views

92

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Find and replace doesn't work Animate CC 2020,2019,2018

Community Beginner ,
Mar 29, 2020

Copy link to clipboard

Copied

Hello everybody. For some reason, the function "find and replace"  doesn't work for a specific color. I pick the color but error message popup and says it found no color. It worked until two days ago, but I've already tried to uninstall the latest windows updates and reinstall Animate. I thought it was a problem with privacy but now I'm pretty sure to have given all the necessary permits. I ask for help because find and replace is too usefull for me. thank you very much

 

 

Cattura.JPG

Hi mate,

 

The mystery is solved!

 

Many of your colours have 99% alpha.

Clipboard-1.png

 

Symbol Palette Control has no difficulty identifying the correct colour and then replacing it, but by design it keeps the alpha value. In one of your keyframes the colour seems to have been changed to solid.

 

Still with these semi-transparent colours you run into a color picker limitation, where the picker always samples a colour that is a composite - a blend of the actual colour value and what is beneath the shape, so you can't really identify it in the Symbol Palette Control set using the SPC Picker tool, because it relies on sampling from the stage.

 

The default Find and Replace can only work with solid colours (100% alpha) as source, i.e. you cannot search for a colour that is not solid.

 

So...

To fix your file you need to identify all the shapes that don't have a solid colour (100% alpha) and manually re-color them.

Also make sure you delete the 99% swatches and create new ones that are 100%.

 

After that both Find and Replace and Symbol Palette Control will work as they should.

 

As a general advice that has nothing to do with the current colour issue, I would suggest that you rethink your file and start using Symbols, rig the head with mouth and eyes on separate layers and so on.

I have written a lot about this and would like to offer you these two articles which should be very beneficial in long term: 

http://flash-powertools.com/workflow/

http://flash-powertools.com/character-rigging-for-flash-animation/

 

Finally, I wanted to say that I love the designs and your animation!

My criticism is only in regards to structure. A better structure will give you better editability and flexibility.

 

Hope this helps!

 

Views

93

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 29, 2020 0
Guide ,
Mar 29, 2020

Copy link to clipboard

Copied

Hi mate,

 

I can't replicate the problem in AA 20.0.2. Maybe something went wrong with your specific file.

If you post a link to your FLA I will look into it in an attempt to determine what may be causing the issue.

 

I would also suggest that you look into Symbol Palette Conrol, esp. in you do serious work in Animate.

 

- Nick: Character designer and animator, Flash user since 1998
Member of Flanimate Power Tools team - extensions for character animation

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 29, 2020 0
Community Beginner ,
Mar 29, 2020

Copy link to clipboard

Copied

wow! I don't know why "Find and Replace didn't work but now with the tool you recommended me, see works and also it's a very interesting tool. Thank you so much

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 29, 2020 0
Community Beginner ,
Mar 29, 2020

Copy link to clipboard

Copied

Sorry i talk too soon. It works only for some colors. I think it's a windows problem but if you want to give me a hand and you can check if the same problem occurs also in your computer, i'll be very grateful to you

 

https://drive.google.com/open?id=1RLw5SQrz-gk9f_svuuyJZoEeamTy3iAL

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 29, 2020 0
Guide ,
Mar 29, 2020

Copy link to clipboard

Copied

Hi mate,

 

The mystery is solved!

 

Many of your colours have 99% alpha.

Clipboard-1.png

 

Symbol Palette Control has no difficulty identifying the correct colour and then replacing it, but by design it keeps the alpha value. In one of your keyframes the colour seems to have been changed to solid.

 

Still with these semi-transparent colours you run into a color picker limitation, where the picker always samples a colour that is a composite - a blend of the actual colour value and what is beneath the shape, so you can't really identify it in the Symbol Palette Control set using the SPC Picker tool, because it relies on sampling from the stage.

 

The default Find and Replace can only work with solid colours (100% alpha) as source, i.e. you cannot search for a colour that is not solid.

 

So...

To fix your file you need to identify all the shapes that don't have a solid colour (100% alpha) and manually re-color them.

Also make sure you delete the 99% swatches and create new ones that are 100%.

 

After that both Find and Replace and Symbol Palette Control will work as they should.

 

As a general advice that has nothing to do with the current colour issue, I would suggest that you rethink your file and start using Symbols, rig the head with mouth and eyes on separate layers and so on.

I have written a lot about this and would like to offer you these two articles which should be very beneficial in long term: 

http://flash-powertools.com/workflow/

http://flash-powertools.com/character-rigging-for-flash-animation/

 

Finally, I wanted to say that I love the designs and your animation!

My criticism is only in regards to structure. A better structure will give you better editability and flexibility.

 

Hope this helps!

 

- Nick: Character designer and animator, Flash user since 1998
Member of Flanimate Power Tools team - extensions for character animation

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 29, 2020 0
Community Beginner ,
Sep 18, 2020

Copy link to clipboard

Copied

Oh thank you very much!

I read it only today, and sadly at time i had to replace manually all the colours. 

But despite of all, thanks: it's very usefull to know for the future.

However i saw your site and read some of your tips and your work is great!

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 18, 2020 1
Guide ,
Sep 18, 2020

Copy link to clipboard

Copied

All the best, mate!

 

- Nick: Character designer and animator, Flash user since 1998
Member of Flanimate Power Tools team - extensions for character animation

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 18, 2020 0