Highlighted

Fla Animate CC 2019 does not work in Animate CC 2018

Dec 19, 2018

Copy to clipboard

Copied

In Animate CC I added some movieclips with linkage name BlackMc with Javascript

for(var i = 0; i < 5; i++){

var mc = new lib.BlackMc();

mc.x = 200 + i* 20;

mc.gotoAndStop(i);

mc.y = 200;

this.addChild(mc);

}

I have put another movieclip on the stage by hand. Lets call it mc2

When I open this fla file in Animate 2018 and publish it there is a problem, the BlackMc Movieclips are in the upper left corner.

If there is no mc2 it works fine in Animate 2018.

If I export the frames and copy the Movieclip BlackMc in a new fla File in AnimateCC 2018 it will work.

I have also the problems that some files does not open in Animate CC 2019

Adobe Community Professional
Correct answer by kglad | Adobe Community Professional

i don't see that unless advanced layers are enabled in the 2019 file.

disable advanced layers (modify>document>untick 'use advanced layers').

info about advanced layers: https://helpx.adobe.com/animate/using/timeline-layers.html#advanced-layers

(and your link is a 404)

Views

338

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Fla Animate CC 2019 does not work in Animate CC 2018

Dec 19, 2018

Copy to clipboard

Copied

In Animate CC I added some movieclips with linkage name BlackMc with Javascript

for(var i = 0; i < 5; i++){

var mc = new lib.BlackMc();

mc.x = 200 + i* 20;

mc.gotoAndStop(i);

mc.y = 200;

this.addChild(mc);

}

I have put another movieclip on the stage by hand. Lets call it mc2

When I open this fla file in Animate 2018 and publish it there is a problem, the BlackMc Movieclips are in the upper left corner.

If there is no mc2 it works fine in Animate 2018.

If I export the frames and copy the Movieclip BlackMc in a new fla File in AnimateCC 2018 it will work.

I have also the problems that some files does not open in Animate CC 2019

Adobe Community Professional
Correct answer by kglad | Adobe Community Professional

i don't see that unless advanced layers are enabled in the 2019 file.

disable advanced layers (modify>document>untick 'use advanced layers').

info about advanced layers: https://helpx.adobe.com/animate/using/timeline-layers.html#advanced-layers

(and your link is a 404)

Views

339

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Dec 20, 2018

Copy to clipboard

Copied

are advanced layers enabled in your 2019 fla?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 20, 2018

Copy to clipboard

Copied

Its HTML5 / Canvas   its just normal layers.

you can download the fla at:

https://www.on-design.de/test/animatecc/test.fla

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Dec 20, 2018

Copy to clipboard

Copied

i don't see that unless advanced layers are enabled in the 2019 file.

disable advanced layers (modify>document>untick 'use advanced layers').

info about advanced layers: https://helpx.adobe.com/animate/using/timeline-layers.html#advanced-layers

(and your link is a 404)

Likes

1 Like

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Dec 20, 2018

Copy to clipboard

Copied

The advanced layers is a great new add-on but seems a lot of folks are having issues when they try to code.

Advanced layers were added for the animator, not the programmer. So If you are programming Advanced layers should be turned off.

Likes

1 Like

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 20, 2018

Copy to clipboard

Copied

Thanks  a lot for the information. Now everything works fine.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
kglad LATEST
Adobe Community Professional ,
Dec 20, 2018

Copy to clipboard

Copied

you’re welcome.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...