Highlighted

Groups move when I double click out of them.

Explorer ,
Oct 14, 2020

Copy link to clipboard

Copied

Hi all,
I was hoping someone could fix this VERY annoying issue I'm having in Animate CC 2020.
I'm using a top of the line Windows 10PC with a 1080 16GB graphics card so there's no issue in hardware. This issue also wasn't a problem just a few weeks ago. I believe it is native to the new patch.
Anyway, when I click out of a group the entire group moves and I have to keep clicking out until it moves back in to place before I can go back in again and work, then it does it again. I'm attaching a video so you guys can see the problem. All I'm doing in the video is clicking in and out of the groups and using ctrl Z a few times.
Anyone else havinbg this issue and know how to fix it? A restart didn't seem to help.
Thanks. 
Here's the link to the video: https://youtu.be/XABRMD6Hko0

Enjoy the videos and music you love, upload original content, and share it all with friends, family, and the world on YouTube.

Hi again, mate,

 

It's good that you have determined that it is related to the camera. If it is always reproducible, you should report a bug.

 

As to what you can do right now: you have a choice to make - either don't use groups or camera; if it only happens in the second, third and so on scenes, do not use scenes.

 

Personally, I never use groups as they have been problematic for many years and outlawed in some of the studios I have worked at in the past.

Also, I never use the camera as it's full of all kinds of bugs, it seems. I just do things the old-school way, nesting my content inside a Graphic symbol and using that container as a camera the way we used to do it in the Flash 5 days...

 

I also never use Scenes, since that, too, has been considered bad practice for years...

 

So right now you will have to give up one thing to be able to continue your work.

And hopefully in the future they will fix the bug so that in a year or two you can go back to how you prefer doing things 🙂

 

Your project looks awesome!

Good luck!

 

Views

105

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Groups move when I double click out of them.

Explorer ,
Oct 14, 2020

Copy link to clipboard

Copied

Hi all,
I was hoping someone could fix this VERY annoying issue I'm having in Animate CC 2020.
I'm using a top of the line Windows 10PC with a 1080 16GB graphics card so there's no issue in hardware. This issue also wasn't a problem just a few weeks ago. I believe it is native to the new patch.
Anyway, when I click out of a group the entire group moves and I have to keep clicking out until it moves back in to place before I can go back in again and work, then it does it again. I'm attaching a video so you guys can see the problem. All I'm doing in the video is clicking in and out of the groups and using ctrl Z a few times.
Anyone else havinbg this issue and know how to fix it? A restart didn't seem to help.
Thanks. 
Here's the link to the video: https://youtu.be/XABRMD6Hko0

Enjoy the videos and music you love, upload original content, and share it all with friends, family, and the world on YouTube.

Hi again, mate,

 

It's good that you have determined that it is related to the camera. If it is always reproducible, you should report a bug.

 

As to what you can do right now: you have a choice to make - either don't use groups or camera; if it only happens in the second, third and so on scenes, do not use scenes.

 

Personally, I never use groups as they have been problematic for many years and outlawed in some of the studios I have worked at in the past.

Also, I never use the camera as it's full of all kinds of bugs, it seems. I just do things the old-school way, nesting my content inside a Graphic symbol and using that container as a camera the way we used to do it in the Flash 5 days...

 

I also never use Scenes, since that, too, has been considered bad practice for years...

 

So right now you will have to give up one thing to be able to continue your work.

And hopefully in the future they will fix the bug so that in a year or two you can go back to how you prefer doing things 🙂

 

Your project looks awesome!

Good luck!

 

Views

106

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 14, 2020 0
Guide ,
Oct 14, 2020

Copy link to clipboard

Copied

Your video is set to private, mate, so no one can see it.

 

- Nick: Character designer and animator, Flash user since 1998
Member of Flanimate Power Tools team - extensions for character animation

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 14, 2020 0
Explorer ,
Oct 14, 2020

Copy link to clipboard

Copied

Ahhh, sry. Thanks for letting me know. I just set it to public to hopefully it works now. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 14, 2020 0
Guide ,
Oct 14, 2020

Copy link to clipboard

Copied

The video works well now, mate!

 

I tried to replicate in 20.5.1 with a bunch of nested groups on the main timeline, but couldn't, so maybe there are some other factors that you should try to identify to make it reproducible or to trouble-shoot.

 

Do you have Layer Parenting?

Maybe try switching Advanced Layers off.

 

I can see you are in Scene 2. Does it also happen in Scene 1?

 

Do you have any display scaling (other than 100%)?

Is this your only monitor?

 

These are just some things that might influence coordinates. I've no idea what is causing the behaviour.

Maybe you can install a previous version that does not display the issue and work in it for a while.

 

Good luck!

 

- Nick: Character designer and animator, Flash user since 1998
Member of Flanimate Power Tools team - extensions for character animation

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 14, 2020 0
Explorer ,
Oct 14, 2020

Copy link to clipboard

Copied

Thanks for the advice! I'll try out all those things tomrorrow and post back if any of them work. Cheers.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 14, 2020 1
Explorer ,
Oct 15, 2020

Copy link to clipboard

Copied

So, I just fiddled around with some things and the problem seems to be with the camera. 
It also persists in the previous version, and only on this scene, so far.
Anyway, when I turn advanced layers off, the problem stops BUT the whole stage moves.
Then when I turn advanced layers back on the stage moves back.
I think, when I'm clicking out of the groups (while advanced layers is on), the objects are jumping to where they are when advanced layers is off.
Any advice? 
Here's a vid:
https://youtu.be/TQ3g0THoqYM

Enjoy the videos and music you love, upload original content, and share it all with friends, family, and the world on YouTube.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2020 0
Guide ,
Oct 15, 2020

Copy link to clipboard

Copied

Hi again, mate,

 

It's good that you have determined that it is related to the camera. If it is always reproducible, you should report a bug.

 

As to what you can do right now: you have a choice to make - either don't use groups or camera; if it only happens in the second, third and so on scenes, do not use scenes.

 

Personally, I never use groups as they have been problematic for many years and outlawed in some of the studios I have worked at in the past.

Also, I never use the camera as it's full of all kinds of bugs, it seems. I just do things the old-school way, nesting my content inside a Graphic symbol and using that container as a camera the way we used to do it in the Flash 5 days...

 

I also never use Scenes, since that, too, has been considered bad practice for years...

 

So right now you will have to give up one thing to be able to continue your work.

And hopefully in the future they will fix the bug so that in a year or two you can go back to how you prefer doing things 🙂

 

Your project looks awesome!

Good luck!

 

- Nick: Character designer and animator, Flash user since 1998
Member of Flanimate Power Tools team - extensions for character animation

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2020 1
Explorer ,
Oct 15, 2020

Copy link to clipboard

Copied

Hey, thanks again.
Good stuff to know. 
I'm not an animator so I don't know what the professional practices are working in Animate. Last time I animated in the program it was still called Flash so a lot of the these features are new to me. This is just a personal project I'm doing.
I'll take everything you've said in to consideration and try and find a better workflow. 
Thanks again!

-L

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2020 1
New Here ,
Oct 15, 2020

Copy link to clipboard

Copied

I also facing this issue on my PC. I don't understand whats the issue with tha. My most of work disturbe due to this issue. If you find any guide that how to resolve this please share here.Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2020 0
Explorer ,
Oct 15, 2020

Copy link to clipboard

Copied

So, turning off advanced layers seems to stop the issue for me... but it's annoying because I need advance layers on for camera movement. I think it's an issue with the camera. When I turn advanced layers off everything on my stage is moved slightly. It looks like, based on where everything moves too, this is the same place the groups jump when clicking in and out of them when advanced layers are on. I'm attaching a screen vid of what I'm talking about. Let me know if yours does the same. 
https://youtu.be/TQ3g0THoqYM

Enjoy the videos and music you love, upload original content, and share it all with friends, family, and the world on YouTube.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2020 0
Community Beginner ,
Oct 19, 2020

Copy link to clipboard

Copied

Hi ,

  @I_AM_LOTAN @Marion5FE7 @n. tilcheff  thanks for bringing this issue to our notice. we are able to reproduce the issue at our end. I have logged a bug for this and its under investigation. 

Thanks!

Arvind 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 19, 2020 1