Highlighted

Hidden layers

Explorer ,
Aug 28, 2020

Copy link to clipboard

Copied

Here's a weird thing:  I have two layers, locked and hidden;  I have a movieclip symbol that's supposed to bounce through the piece.  But, when I use Test Movie to preview my animation, they show up.  Worse yet, my movieclip symbol doesn't move when I save as an animated GIF...

Views

34

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Hidden layers

Explorer ,
Aug 28, 2020

Copy link to clipboard

Copied

Here's a weird thing:  I have two layers, locked and hidden;  I have a movieclip symbol that's supposed to bounce through the piece.  But, when I use Test Movie to preview my animation, they show up.  Worse yet, my movieclip symbol doesn't move when I save as an animated GIF...

Views

35

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 28, 2020 0
Adobe Community Professional ,
Aug 28, 2020

Copy link to clipboard

Copied

Hiding layers will only hide themduring authoring - you could make those layers be Guide Layers and they would not be output. As for the MoivieClip nested animation ot playing back in the GIF... change its behaviour to that of a Graphic Symbol and then it should render the internal animation on output. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 28, 2020 0
Explorer ,
Aug 31, 2020

Copy link to clipboard

Copied

I think I figured it out...  When I simply used the Export/Export Animated GIF, I got no motion from neither my movieclip symbol *nor* a Graphic symbol version of the same loop I wanted to use.  I tried different formats of exporting/publishing but when I used Export/Export Video/Media and chose and Animated GIF there - my looping symbol worked, even as a movieclip.  

 

So much more to learn...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 31, 2020 0
Adobe Community Professional ,
Aug 29, 2020

Copy link to clipboard

Copied

Hi.

 

Besides the guide approach mentioned by Joseph, it's possible to prevent Animate from publishing hidden layers by going to File > Publish Settings... (Ctrl/Cmd + Shift + F12) and unchecking Include hidden layers.

 

Regards,

JC

__________________________________________
HTML5, JSFL, and AS3 samples: http://bit.ly/2mJgDoG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 29, 2020 0