Highlighted

How to stop at last frame but keep mouseover button

Community Beginner ,
Feb 19, 2019

Copy link to clipboard

Copied

Hi,

Sorry this is a really newbie question as this is one of the first projects I'm building in Animate.

I'm making a HTML 5 banner and cannot figure out how to get it to stop properly. I turned off 'Loop timeline' in publish settings, but then it keeps jumping to the very first (blank) frame of the animation rather than ending on the last frame of animation.

So I added the code "this.stop" to the last frame on the timeline. However, this kills the mouseover action I had on my buttons. I had built different states for my button for it to change color on mouse over, but this doesn't work anymore when the movie freezes on the last frame.

Please any ideas would be much appreciated! Is there a way to tell Animate to stop correctly at the last frame without using 'stop'?

Thanks for the file.

I got it to work okay BUT that was after I turned off Advanced Layers on this. When Advanced Layers is on it acts like you described but when I switched it off it worked okay. And this is weird because you say you don't have the option for Advanced Layers on your Animate CC version. So I am confused as to what is happening. I'm wondering if problem connected to the Camera even after you have switched off the camera? Does anyone else work on this file? Can you update your Animate CC?

I tested it and run okay for me- both on Chrome and Firefox. Even when it stops playing.

The only other thing I changed in Publish Settings was the Output name just to 'Troubleshooting file' as I was testing it in a test folder on my desktop.

Here is my saved version of the FLA- try this...

WeTransfer

Views

204

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

How to stop at last frame but keep mouseover button

Community Beginner ,
Feb 19, 2019

Copy link to clipboard

Copied

Hi,

Sorry this is a really newbie question as this is one of the first projects I'm building in Animate.

I'm making a HTML 5 banner and cannot figure out how to get it to stop properly. I turned off 'Loop timeline' in publish settings, but then it keeps jumping to the very first (blank) frame of the animation rather than ending on the last frame of animation.

So I added the code "this.stop" to the last frame on the timeline. However, this kills the mouseover action I had on my buttons. I had built different states for my button for it to change color on mouse over, but this doesn't work anymore when the movie freezes on the last frame.

Please any ideas would be much appreciated! Is there a way to tell Animate to stop correctly at the last frame without using 'stop'?

Thanks for the file.

I got it to work okay BUT that was after I turned off Advanced Layers on this. When Advanced Layers is on it acts like you described but when I switched it off it worked okay. And this is weird because you say you don't have the option for Advanced Layers on your Animate CC version. So I am confused as to what is happening. I'm wondering if problem connected to the Camera even after you have switched off the camera? Does anyone else work on this file? Can you update your Animate CC?

I tested it and run okay for me- both on Chrome and Firefox. Even when it stops playing.

The only other thing I changed in Publish Settings was the Output name just to 'Troubleshooting file' as I was testing it in a test folder on my desktop.

Here is my saved version of the FLA- try this...

WeTransfer

Views

205

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 19, 2019 0
Adobe Community Professional ,
Feb 20, 2019

Copy link to clipboard

Copied

There has to be something else going on, as disabling looping in Publish Settings or this.stop(); should both work. Perhaps the web browser console is throwing an error?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2019 0
Community Beginner ,
Feb 20, 2019

Copy link to clipboard

Copied

Thanks so much for your answer. This is the error I get:

WARNINGS:

Frame numbers in EaselJS start at 0 instead of 1. For example, this affects gotoAndStop and gotoAndPlay calls. (18)

Content with both Bitmaps and Buttons may generate local security errors in some browsers if run from the local file system.

It looks like the first error might be relevant but I don't know how to resolve that.

If I use this.stop(), it does work and stops at the last frame. But then mouseover on my button doesn't call the over the state.

Any tips much appreciated!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2019 0
Engaged ,
Feb 20, 2019

Copy link to clipboard

Copied

advancedlayers.jpg

Not sure if it's 'Advanced Layers'. But to check it is switched off then press CTRL and J to make sure it is not ticked.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2019 0
Community Beginner ,
Feb 20, 2019

Copy link to clipboard

Copied

Thanks! I don't see the options when I open it. Please see attached.

settings.PNG

Perhaps because I am in the office and looking at the file using a slightly older version of Animate (18.0.2), is this something only available in the latest Animate please?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2019 0
Engaged ,
Feb 20, 2019

Copy link to clipboard

Copied

Ah right! Yeah it was a new thing added to recent version of Animate CC as default that has been causing problems for users. As your version doesnt have it then we can rule out 'Use Advanced Layers' option.

Could you supply a screen shot of your layers? And also the code you have on them? Or is it a simple this.stop(); you are using?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2019 0
Community Beginner ,
Feb 20, 2019

Copy link to clipboard

Copied

Thank you for your help! Please see a screenshot of my layers and the code that is on the last frame.

animate.PNG

With this code the movie stops on the last frame correctly, and the button works when I click it, but mouse over states of the button doesn't work.

Many thanks, much appreciated!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2019 0
Engaged ,
Feb 20, 2019

Copy link to clipboard

Copied

Hi,

so you are using the camera and I have never used it. It may or may not be causing a problem (e.g. a setting that needs changed) but hopefully someone who knows the camera well can suggest.

On your browser page can you right-click, select 'Inspect' (or 'Inspect Element' - this can differ for different browsers). Then go to the Console tab and take screen shot if any errors or messages in there.

Regarding the button- do you mean when you hover over it and not when you click it? Do you have different frames on the 4 frames in your button (i.e. Up, Over, Down, Hit)? Or do you mean it works (i.e. the hover over state) until you click the button for the first time and then the hover state doesnt work after that? Does the web page open okay in a new tab?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2019 0
Community Beginner ,
Feb 20, 2019

Copy link to clipboard

Copied

thanks so much for your help! I deleted the camera but still got the same issue.

When I do Inspect Element and Console, there aren't any error messages.

I simplified the project and attached it here if it makes things easier.

WeTransfer

I do have different colours set for the button in the up, over, down hit states. If you mouseover the button before the movie stops playing, you can see the button works correctly. But once we hit the last frame, only the click works correctly because presumably I had added the event listener code outside of the button at the last frame. I just can't get the mouseover action to work at the last frame (i.e. go to 'Over' Frame at mouseover).

Thanks so much!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2019 0
Engaged ,
Feb 20, 2019

Copy link to clipboard

Copied

Thanks for the file.

I got it to work okay BUT that was after I turned off Advanced Layers on this. When Advanced Layers is on it acts like you described but when I switched it off it worked okay. And this is weird because you say you don't have the option for Advanced Layers on your Animate CC version. So I am confused as to what is happening. I'm wondering if problem connected to the Camera even after you have switched off the camera? Does anyone else work on this file? Can you update your Animate CC?

I tested it and run okay for me- both on Chrome and Firefox. Even when it stops playing.

The only other thing I changed in Publish Settings was the Output name just to 'Troubleshooting file' as I was testing it in a test folder on my desktop.

Here is my saved version of the FLA- try this...

WeTransfer

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2019 3
Community Beginner ,
Feb 20, 2019

Copy link to clipboard

Copied

Thanks so much! Perfect, it works now!!

I'm so confused, because I built this at home where I had the latest version of Animate and where I probably had Advanced Layers turned on. But I have been testing it here in office where I have an older version of Animate with no advanced layers, and it still wasn't working right.

So the only thing that fixes it is to take it into the latest version Animate and TURN OFF Advanced Layers to get it working again?

Maan this software is really difficult to use. But thank you so much for your help you have really saved my day!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2019 1
Engaged ,
Feb 20, 2019

Copy link to clipboard

Copied

So glad it's sorted! 🙂 (Might need to change the font back on that version I sent- as I didnt have your font installed).

And yeah, Advanced Layers has been a major dropping of the ball by Adobe. Hopefully sorted soon.

Good luck!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2019 0
Adobe Community Professional ,
Feb 20, 2019

Copy link to clipboard

Copied

Same here. I tried it is 2018 and 2019 versions and both had Advanced Layers turned on. As for Gory Greg, it worked after turning it off.

Yes, Advanced Layers seems to cause a lot of problems at this time.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2019 3
Community Beginner ,
Feb 20, 2019

Copy link to clipboard

Copied

Amazing, it works now even if I take off the code at the last frame, which is perfect. Thanks so much again!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2019 1
Community Beginner ,
Feb 20, 2019

Copy link to clipboard

Copied

Thank you so much for your help in testing this! Much appreciated.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2019 0