Is there a way to build an apk using a 1024 certificate?

Engaged ,
Dec 10, 2020 Dec 10, 2020

Copy link to clipboard

Copied

I have an app that was uploaded to Google Play with a 1024 certificate. Updating it with a 2048 certificate would require a complete new app from scratch and I don´t want to loose all the users, impressions, clicks and income.

 

In the past I was able to update it with the original 1024 certificate using Animate 2017 but not anymore. I don´t know if it is because of the new AIR SDKs or the new Admob ANE from Distriqt.

 

In this thread there seems to be a solution but I have not been able to make it work.

 

Does anyone have a workaround to this issue?

 

https://community.adobe.com/t5/animate/getting-quot-unable-to-load-a-certificate-in-this-file-quot-w...

 

I find the solution :

The problem isn't Animate but Java who force you to compile to 2048

you need to Java 1.6 

and compile in command line :

java -jar "****\SDKAIR\AIR26.0\lib\ADT.jar" -package -target apk-captive-runtime -arch armv7 -storetype PKCS12 -keystore "*****.p12" -storepass "****" "*****.apk" "****.xml" -C "****.swf"

change *** by your stuff ^^

 

Does anyone have a workaround to this issue?

TOPICS
ActionScript, Code, Other, Publish package

Views

69

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 11, 2020 Dec 11, 2020

Copy link to clipboard

Copied

you have to use an older version of animate (cc 2015.2 is the latest, i believe).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Dec 11, 2020 Dec 11, 2020

Copy link to clipboard

Copied

So there´s no way to do it on a mac with Catalina. Right?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 11, 2020 Dec 11, 2020

Copy link to clipboard

Copied

LATEST
  • Mac OS X v10.9 (64 bit), v10.10 (64 bit), or v10.11 (64 bit)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines