Highlighted

moving a symbol to position glitch

New Here ,
Mar 03, 2020

Copy link to clipboard

Copied

Hi All 

 

I have a problem with moving a symbol to a new location on a new frame. It seems to jump in the opposite direction to what I move it in. https://youtu.be/9WXOqnj_az0 

I tried attaching the actual Animate file but it does not allow me to upload an.F L A file please see google drive share link below

https://drive.google.com/open?id=1wnVNUlceF-V_kDzCzGW33Ei9GSJj0gW_

Hello, The Internet. I have a problem with moving a symbol to a new location on a new frame. It seems to jump in the opposite direction to what I move it in....
TOPICS
Error, How to, Product issue

Views

116

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

moving a symbol to position glitch

New Here ,
Mar 03, 2020

Copy link to clipboard

Copied

Hi All 

 

I have a problem with moving a symbol to a new location on a new frame. It seems to jump in the opposite direction to what I move it in. https://youtu.be/9WXOqnj_az0 

I tried attaching the actual Animate file but it does not allow me to upload an.F L A file please see google drive share link below

https://drive.google.com/open?id=1wnVNUlceF-V_kDzCzGW33Ei9GSJj0gW_

Hello, The Internet. I have a problem with moving a symbol to a new location on a new frame. It seems to jump in the opposite direction to what I move it in....
TOPICS
Error, How to, Product issue

Views

117

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 03, 2020 0
Guide ,
Mar 03, 2020

Copy link to clipboard

Copied

Hi mate,

 

I believe this to be a bug related to Layer Parenting. Factors that may contribute to the erratic behaviour: your arm symbol is flipped horizontally and the two symbol instances - arm and hand - have different scaling. Also arm layer has keyframes on frames 18-35 while the hand layer only has one on #18.

If you reset the transformation of the arm and flip it horizontally the problem disappears.

 

General observation:

There are too many dead ends with Layer Parenting and too many bugs and glitches there for it to be a viable option for anything but carefully crafted demos.

 

General advice how to get out of the unpleasant situation:

My suggestion is to look into Smart Magnet Rigging.

The only thing that you will need to change in the way you work is the registration of symbols, which can be done quickly and easily with a dedicated tool.

 

Good luck!

- Nick: Character designer and animator, Flash user since 1998
Member of Flanimate Power Tools team - extensions for character animation

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 03, 2020 1
New Here ,
Mar 04, 2020

Copy link to clipboard

Copied

Hi Nick, 

 

Thank you for the feedback. I will have a look at the solutions you provided.

 

 

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 04, 2020 1
Adobe Community Professional ,
Mar 03, 2020

Copy link to clipboard

Copied

Try using a classic tween instead.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 03, 2020 0