Highlighted

MP4 blurry after exporting

Participant ,
Jan 03, 2020

Copy link to clipboard

Copied

Some frames in some of my exported mp4's turn out blurry, not all frames and it doesn't happen with all mp4's, just some of them. It often happens in the beginning of the mp4 and then clears up. Example linked below. It's not a consistent issue. I have not identified any patterns with the stage size or images used. Process I use for exporting: File > Export > Video/Media > H.264 & Match Source. 

 

An additional odd part of this is when I use a 10-yr old laptop with the latest Animate/AME software so both machines using the exact same software versions, using the same .FLA file, and the same export settings will produce a perfectly fine mp4. No blurriness. So my new laptop produces the blurry, old laptop mp4s are fine (I do not want to rely on this old laptop going forward).

 

If anyone can identify any settings or errors in the attached that will clear up the blurry export of mp4s that'd be great! 

 

https://drive.google.com/open?id=1iut06STu_OJLEewo44phlxFX545CiJie

https://drive.google.com/open?id=1TqcCKk9zBRrU_R7sNfyXmnDOoHq2AUVx

 

Adobe Community Professional
Correct answer by ClayUUID | Adobe Community Professional

This sort of video is the perfect candidate for two-pass VBR, so the codec can intelligently allocate bandwidth between the frames where nothing changes and the frames with sudden drastic changes. Also, since this looks unlikely to be seeked around in by the user, you can crank the keyframe distance up to the max. Finally, you were exporting 44 kHz source audio as 48 kHz, which burned bandwidth for no quality gain. And you have a glitchy drumstick at frame 150.

 

By correcting the above noted issues, I was able to get the video export down to 303K with perfect quality, vs the 1077K sample you posted.

https://drive.google.com/open?id=1cVBA444e6pZvrTnu17cNWAgypOCscJWL

 

Export settings:

VBR, 2 pass, Target 0.19 Mbps, Max 0.19 Mbps, Key Frame Distance 300

AAC, 64 kbps, 44 kHz, Stereo

TOPICS
How to, Import and export

Views

954

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

MP4 blurry after exporting

Participant ,
Jan 03, 2020

Copy link to clipboard

Copied

Some frames in some of my exported mp4's turn out blurry, not all frames and it doesn't happen with all mp4's, just some of them. It often happens in the beginning of the mp4 and then clears up. Example linked below. It's not a consistent issue. I have not identified any patterns with the stage size or images used. Process I use for exporting: File > Export > Video/Media > H.264 & Match Source. 

 

An additional odd part of this is when I use a 10-yr old laptop with the latest Animate/AME software so both machines using the exact same software versions, using the same .FLA file, and the same export settings will produce a perfectly fine mp4. No blurriness. So my new laptop produces the blurry, old laptop mp4s are fine (I do not want to rely on this old laptop going forward).

 

If anyone can identify any settings or errors in the attached that will clear up the blurry export of mp4s that'd be great! 

 

https://drive.google.com/open?id=1iut06STu_OJLEewo44phlxFX545CiJie

https://drive.google.com/open?id=1TqcCKk9zBRrU_R7sNfyXmnDOoHq2AUVx

 

Adobe Community Professional
Correct answer by ClayUUID | Adobe Community Professional

This sort of video is the perfect candidate for two-pass VBR, so the codec can intelligently allocate bandwidth between the frames where nothing changes and the frames with sudden drastic changes. Also, since this looks unlikely to be seeked around in by the user, you can crank the keyframe distance up to the max. Finally, you were exporting 44 kHz source audio as 48 kHz, which burned bandwidth for no quality gain. And you have a glitchy drumstick at frame 150.

 

By correcting the above noted issues, I was able to get the video export down to 303K with perfect quality, vs the 1077K sample you posted.

https://drive.google.com/open?id=1cVBA444e6pZvrTnu17cNWAgypOCscJWL

 

Export settings:

VBR, 2 pass, Target 0.19 Mbps, Max 0.19 Mbps, Key Frame Distance 300

AAC, 64 kbps, 44 kHz, Stereo

TOPICS
How to, Import and export

Views

955

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 03, 2020 0
Adobe Community Professional ,
Jan 03, 2020

Copy link to clipboard

Copied

I downloaded your files and yeah - weird how the quality is so low but here's what I think you did right and where you think you went "wrong":
I opened your FLA and exported it using H264 (High Bitrate) and after Media Encoder was finished, I opened up the MP4 in Quicktime (default) and it looks horribly compressed.
So I tried several other formats and codecs - all with same results.
But I then noticed something weird: When the exported videos were being viewed in Quicktime, they were larger than your original canvas. I tried to view than at "actual size" but that feature was grayed out.
So I went to Finder and selected the MP4 and simply hit the spacebar to preview the video and it opened at the actual size 140x190 and looked perfect. See attached images.
So I think what is happening is that Quicktime simply can't view at actual size below a certain standard. Therefore it was scaling up your video and since your video is really quite small, the scaling effected the quality.
Screen Shot 2020-01-03 at 10.27.23 AM.pngScreen Shot 2020-01-03 at 10.27.41 AM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 03, 2020 3
New Here ,
Mar 02, 2020

Copy link to clipboard

Copied

Thank you! I beleive this is the correct answer. There is nothing wrong with the video or export, it is quicktime's fault! Thank you for posting I've been searching and troubleshooting for an hour. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 02, 2020 0
Adobe Community Professional ,
Mar 02, 2020

Copy link to clipboard

Copied

It isn't the correct answer. QuickTime player's scaling issues aside, the problem, as noted in the accepted answer, was non-optimal compression settings.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 02, 2020 1
New Here ,
Mar 02, 2020

Copy link to clipboard

Copied

Cool, thanks. Will apply those settings. Is it possible to set the mp4 to loop?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 02, 2020 0
Adobe Community Professional ,
Jan 03, 2020

Copy link to clipboard

Copied

This sort of video is the perfect candidate for two-pass VBR, so the codec can intelligently allocate bandwidth between the frames where nothing changes and the frames with sudden drastic changes. Also, since this looks unlikely to be seeked around in by the user, you can crank the keyframe distance up to the max. Finally, you were exporting 44 kHz source audio as 48 kHz, which burned bandwidth for no quality gain. And you have a glitchy drumstick at frame 150.

 

By correcting the above noted issues, I was able to get the video export down to 303K with perfect quality, vs the 1077K sample you posted.

https://drive.google.com/open?id=1cVBA444e6pZvrTnu17cNWAgypOCscJWL

 

Export settings:

VBR, 2 pass, Target 0.19 Mbps, Max 0.19 Mbps, Key Frame Distance 300

AAC, 64 kbps, 44 kHz, Stereo

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 03, 2020 2
Participant ,
Jan 06, 2020

Copy link to clipboard

Copied

Thanks ClayUUID, especially for laying out the exact settings. It worked perfectly! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 06, 2020 0