Highlighted

None of the code works while trying to "Test" my file but plays as a regular video.

New Here ,
Aug 10, 2020

Copy link to clipboard

Copied

Hi,

I recently updated to the latest version of Adobe Animate. One of the files that I had started off before the update (which was working fine), has suddenly stopped responding to any piece of code that I add to "Actions". The file is supposed to display a 'start' button and a timeline which would lead to different pages. I had toggled visibility on click to navigate pages. But right now, all I get is a mess of all my pages overlapped. Any help is appreaciated. 
Thanks!

Views

27

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

None of the code works while trying to "Test" my file but plays as a regular video.

New Here ,
Aug 10, 2020

Copy link to clipboard

Copied

Hi,

I recently updated to the latest version of Adobe Animate. One of the files that I had started off before the update (which was working fine), has suddenly stopped responding to any piece of code that I add to "Actions". The file is supposed to display a 'start' button and a timeline which would lead to different pages. I had toggled visibility on click to navigate pages. But right now, all I get is a mess of all my pages overlapped. Any help is appreaciated. 
Thanks!

Views

28

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 10, 2020 0
Adobe Community Professional ,
Aug 10, 2020

Copy link to clipboard

Copied

And the error messages you're seeing in the browser developer console aren't helpful?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 10, 2020 0
New Here ,
Aug 12, 2020

Copy link to clipboard

Copied

Thanks!

No, I do not seem to be getting an error. The code runs fine.

I did some digging and I realized it is possible that some of my code won't work since it is not supported anymore. I am trying to toggle layer visibility on and off - I have been referencing the layer's name to do this:

this.layerName.visible=false;

This used to work on a previous version, I had it tested several times. Right after the update this stopped working. I did a test run on some other files without the layer visibility coed and it seems to work fine.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 12, 2020 0