Highlighted

Online error (animation does not run)

Explorer ,
Nov 20, 2019

Copy link to clipboard

Copied

Hello,

I have trouble running my animation made with Adobe Animate online. 

 

I do a very simple animation:

  1. In Adobe Animate I create a new HTML5 canvas.
  2. I draw in a simple circle and I animate it with motion tween.
  3. I Publish it with default settings with preloader checked.

 

I uplod it online and it does not animate:

  1. I uplod a html and js file in public-html in a C-Pannel of my host provider.
  2. Here it is: http://www.ortodroma.si/circleTest3.html
  3. The canvas is visible (see pink color of the stage).
  4. But animation is not running (circle is not moving).
  5. The Error in the Console says: Uncaught TypeError: Cannot read property 'getContext' of undefined   createjs.min.js:12 

 

In exact same way I uplod html and js file downloaded from this tutorial and it works just file. See here (this is just for test purposes, of course): http://www.ortodroma.si/animated-infographic.html

 

What could be the difference. Why is the animation from the tutorial working and mine not? 

 

The first thing I notice is that there are various server errors showing in console, which you will need to resolve.  For example, the preloader GIF (http://www.ortodroma.si/images/_preloader.gif) gives a server error, as does the atlas for the ball (http://www.ortodroma.si/images/circleTest3_atlas_.png).

 

The server error is "Unable to load your default controller. Please make sure the controller specified in your Routes.php file is valid."

TOPICS
Error, Performance, Publish package

Views

447

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Online error (animation does not run)

Explorer ,
Nov 20, 2019

Copy link to clipboard

Copied

Hello,

I have trouble running my animation made with Adobe Animate online. 

 

I do a very simple animation:

  1. In Adobe Animate I create a new HTML5 canvas.
  2. I draw in a simple circle and I animate it with motion tween.
  3. I Publish it with default settings with preloader checked.

 

I uplod it online and it does not animate:

  1. I uplod a html and js file in public-html in a C-Pannel of my host provider.
  2. Here it is: http://www.ortodroma.si/circleTest3.html
  3. The canvas is visible (see pink color of the stage).
  4. But animation is not running (circle is not moving).
  5. The Error in the Console says: Uncaught TypeError: Cannot read property 'getContext' of undefined   createjs.min.js:12 

 

In exact same way I uplod html and js file downloaded from this tutorial and it works just file. See here (this is just for test purposes, of course): http://www.ortodroma.si/animated-infographic.html

 

What could be the difference. Why is the animation from the tutorial working and mine not? 

 

The first thing I notice is that there are various server errors showing in console, which you will need to resolve.  For example, the preloader GIF (http://www.ortodroma.si/images/_preloader.gif) gives a server error, as does the atlas for the ball (http://www.ortodroma.si/images/circleTest3_atlas_.png).

 

The server error is "Unable to load your default controller. Please make sure the controller specified in your Routes.php file is valid."

TOPICS
Error, Performance, Publish package

Views

448

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 20, 2019 0
Participant ,
Nov 21, 2019

Copy link to clipboard

Copied

The first thing I notice is that there are various server errors showing in console, which you will need to resolve.  For example, the preloader GIF (http://www.ortodroma.si/images/_preloader.gif) gives a server error, as does the atlas for the ball (http://www.ortodroma.si/images/circleTest3_atlas_.png).

 

The server error is "Unable to load your default controller. Please make sure the controller specified in your Routes.php file is valid."

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 21, 2019 0