Preloader end before sound load

Explorer ,
Apr 18, 2021 Apr 18, 2021

Copy link to clipboard

Copied

After preloader.gif ends, I want to start the sound right in frame 0. But it display only image, no sound. How can I set it up?

Views

105

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Explorer , Apr 27, 2021 Apr 27, 2021
Stream sound didn't fix it. The sound didn't start right away and when I press the screen, sound start in the middle. I think I can fix it by making a button in frame 0 and press it before running the rest animation.Anw, I wonder if this is the only to fix.

Likes

translate

Translate

Translate
Adobe Community Professional ,
Apr 27, 2021 Apr 27, 2021

Copy link to clipboard

Copied

Gif can not have sounds in them.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 27, 2021 Apr 27, 2021

Copy link to clipboard

Copied

You've misunderstood me, what I mean is I make canvas animation with preloader is a gif. After preloading done, my canvas animation run but without sound.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 27, 2021 Apr 27, 2021

Copy link to clipboard

Copied

Ok. Makes sure your sound it's sent to stream. And see if that fixes the issue. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 27, 2021 Apr 27, 2021

Copy link to clipboard

Copied

Stream sound didn't fix it. The sound didn't start right away and when I press the screen, sound start in the middle. I think I can fix it by making a button in frame 0 and press it before running the rest animation.

Anw, I wonder if this is the only to fix.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Apr 27, 2021 Apr 27, 2021

Copy link to clipboard

Copied

I think it's the only fix. Many browsers require a user action to start sound playing. Whatever they clicked on, to get to the loader, to then load the animation and play it, is too disconnected from the user action. I'm sure that if you require a press to start the animation with its sound, the sound should work.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 27, 2021 Apr 27, 2021

Copy link to clipboard

Copied

Yes, I think that's wrapped it. Thank @Nicktendo28 @Colin Holgate 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines