Problems with Adobe animate. Cant hear any imported sound

New Here ,
Mar 04, 2020 Mar 04, 2020

Copy link to clipboard

Copied

So just recently before the newest Adobe update my sound was working fine and when I played it on the timeline nothing went wrong but now when I import sound or play sound from files that used to work, I cant hear them at all. I have tried messing around my settings, changing the audio files, and messing around animate settings. I need help as I worry I won't be able to fix the problem before my animation competition and will be screwed if it needs lips syncing. I'll tag some of the audio files. The old working ones and the changed audio version

TOPICS
File sync, Libraries

Views

1.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Explorer , Mar 09, 2020 Mar 09, 2020
I just loaded sounds into an ActionScript 3.0 file and they played on the timeline. Sounds I load into an HTML 5 Canvas document don't play on the timeline. I wonder if you are using HTML5 Canvas. If you look under File/Publish Settings...    you can tell; in HTML5 Canvas docs there are references to HTML5, whereas in Flash files there is a dropdown for Flash Player version and ActionScript version. If it's a Canvas doc, you can put this code in place of the timeline sound: createjs.Sound.play("...

Likes

Translate

Translate
Explorer ,
Mar 05, 2020 Mar 05, 2020

Copy link to clipboard

Copied

Do you mean your sounds used to work, then you updated animate, now they don't work? I'm having that problem too.

 

Or do you mean that when you import new sounds, those don't work? Are you working on an HTML Canvas doc or Flash file?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 07, 2020 Mar 07, 2020

Copy link to clipboard

Copied

I'm using the default Which I'm pretty sure is flash file. But the update did do something as it was working before but is not now

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 09, 2020 Mar 09, 2020

Copy link to clipboard

Copied

I just loaded sounds into an ActionScript 3.0 file and they played on the timeline.

 

Sounds I load into an HTML 5 Canvas document don't play on the timeline. I wonder if you are using HTML5 Canvas.

 

If you look under File/Publish Settings...    you can tell; in HTML5 Canvas docs there are references to HTML5, whereas in Flash files there is a dropdown for Flash Player version and ActionScript version.

 

If it's a Canvas doc, you can put this code in place of the timeline sound:

 

createjs.Sound.play("mySoundLinkageName", false, 0, 0, 0, 1);

 

where mySoundLinkageName is the linkage name you give your sound in the library (under "linkage" - click in that area and type it in)

 

Otherwise, if you can go back to version 18.2 of Animate, then your timeline sounds will work again. Try downloading from this site, it has links to 2018 versions

 

https://prodesigntools.com/adobe-cc-2019-direct-download-links.html

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 10, 2020 Mar 10, 2020

Copy link to clipboard

Copied

LATEST

I should add to this (or rather, correct myself): when using createJs.Sound.play in Animate, you shouldn't use any parameters. This worked in v18 and v19 but will throw an error in v20.

 

So the code in my example should just be:

 

createjs.Sound.play("mySoundLinkageName");

 

without all the parameters following.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 09, 2020 Mar 09, 2020

Copy link to clipboard

Copied

thanks! I was on a flash file. I had tried going back to an older version before but it must have not been old enough, the sound works now though! ill have to wait until adobe updates animate and fixes the sound before going to the newer ones again. :3

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines