Highlighted

Problems with moving graphic symbols in the Parenting View

Explorer ,
Oct 01, 2020

Copy link to clipboard

Copied

Hi there,

 

When I try to rotate certain layers (in this case the left leg layer), sometimes it does not seem to compute.

 

In the example below. I create a new key frame, and then select the left leg layer(graphic symbol), and rotate it. For somereason it shows the transform box in it's original position?

 

Screen Shot 2020-10-02 at 12.44.43 pm.png

  

Screen Shot 2020-10-02 at 12.49.45 pm.png

 

When I drag the timeline curson to anyother frame, the rotation of this graphic symbol appears to not have been actioned. It doesn't seem to make a difference whether I have converted into a classic tween either.

 

The strange thing is, sometimes it works, sometimes it doesn't. 

 

Any idea what I am doing wrong? Thanks

 

Hey Nick,

 

Originally it was flipped yes, that explains why it is going the wrong way. I just unflipped the symbole and it appears to have fixed it.

 

Ok cool, I look forwad to the to implementation, looks like things will be easier, thanks

TOPICS
Error, How to, Other, Product issue

Views

77

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Problems with moving graphic symbols in the Parenting View

Explorer ,
Oct 01, 2020

Copy link to clipboard

Copied

Hi there,

 

When I try to rotate certain layers (in this case the left leg layer), sometimes it does not seem to compute.

 

In the example below. I create a new key frame, and then select the left leg layer(graphic symbol), and rotate it. For somereason it shows the transform box in it's original position?

 

Screen Shot 2020-10-02 at 12.44.43 pm.png

  

Screen Shot 2020-10-02 at 12.49.45 pm.png

 

When I drag the timeline curson to anyother frame, the rotation of this graphic symbol appears to not have been actioned. It doesn't seem to make a difference whether I have converted into a classic tween either.

 

The strange thing is, sometimes it works, sometimes it doesn't. 

 

Any idea what I am doing wrong? Thanks

 

Hey Nick,

 

Originally it was flipped yes, that explains why it is going the wrong way. I just unflipped the symbole and it appears to have fixed it.

 

Ok cool, I look forwad to the to implementation, looks like things will be easier, thanks

TOPICS
Error, How to, Other, Product issue

Views

78

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 01, 2020 0
Guide ,
Oct 01, 2020

Copy link to clipboard

Copied

Mate, you have to have keyframes aligned vertically for all elements across all layers. 

Think of those as poses.

 

- Nick: Character designer and animator, Flash user since 1998
Member of Flanimate Power Tools team - extensions for character animation

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 01, 2020 0
Explorer ,
Oct 01, 2020

Copy link to clipboard

Copied

Thanks Nick, I think that may have sorted out the problem, however I ahve encourntered another problem that makes no sense, amybe it does to you.

 

I am attempted to move the grophic symbol of the right shin (leg) layer, slgihtly to the left, however when I drag and let go, it moves the right in a bad position. I have tried moving the right shin (leg) layer, and that moves around just fine.

 

Any idea why that would be happening?

 

Screen Shot 2020-10-02 at 2.55.21 pm.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 01, 2020 0
Guide ,
Oct 01, 2020

Copy link to clipboard

Copied

Is it a flipped symbol, mate?

If so, it's a bug.

 

The whole thing - Layer Parenting - is full of bugs and dead ends.

 

Depending on how much time you have and what your project goals are, you may want to look into Smart Magnet Rigging. For now it's FK only, but in a few months we will be releasing a pro-grade IK implementation.

 

Also here is an article on character rigging which you might find useful.

You can download a bunch of sample files too.

 

Hope this is somehow helpful!

 

- Nick: Character designer and animator, Flash user since 1998
Member of Flanimate Power Tools team - extensions for character animation

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 01, 2020 0
Explorer ,
Oct 01, 2020

Copy link to clipboard

Copied

Hey Nick,

 

Originally it was flipped yes, that explains why it is going the wrong way. I just unflipped the symbole and it appears to have fixed it.

 

Ok cool, I look forwad to the to implementation, looks like things will be easier, thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 01, 2020 0