Highlighted

SyntaxError: missing ) after argument list

Community Beginner ,
Jan 08, 2019

Copy link to clipboard

Copied

I made a logo animation in HTML5 Canvas

(I already uploaded a version here)

I made some changes and for some reason I can't test/export the file anymore, when I try I get this error: "A JavaScript error occured. SyntaxError: missing ) after argument list"

I've checked my code, but there doesn't seem to be anything wrong with it. (I don't know JavaScript, but I used a website and the bit of js knowledge I have)

I also tried to delete all the code, but it still didn't work.

What should I do?

If anyone wants it, this is the code:

(As far as I know, I didn't change the code since the last time it worked)

this.stop(0);

var frequency = 3;

stage.enableMouseOver(frequency);

this.hitbox.addEventListener("mouseover", fl_ClickToGoToAndPlayFromFrame.bind(this));

function fl_ClickToGoToAndPlayFromFrame() {

this.gotoAndPlay(0);

}

this.hitbox.addEventListener("click", fl_ClickToGoToWebPage_2);

function fl_ClickToGoToWebPage_2() {

window.open("http://klankiskoning.be", "_parent");

}

I fixed it!

I made a new file, and copied all layers into it.

The problem was caused by my custom loading screen (It happened again, but this time I had an extra save)

Views

1.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

SyntaxError: missing ) after argument list

Community Beginner ,
Jan 08, 2019

Copy link to clipboard

Copied

I made a logo animation in HTML5 Canvas

(I already uploaded a version here)

I made some changes and for some reason I can't test/export the file anymore, when I try I get this error: "A JavaScript error occured. SyntaxError: missing ) after argument list"

I've checked my code, but there doesn't seem to be anything wrong with it. (I don't know JavaScript, but I used a website and the bit of js knowledge I have)

I also tried to delete all the code, but it still didn't work.

What should I do?

If anyone wants it, this is the code:

(As far as I know, I didn't change the code since the last time it worked)

this.stop(0);

var frequency = 3;

stage.enableMouseOver(frequency);

this.hitbox.addEventListener("mouseover", fl_ClickToGoToAndPlayFromFrame.bind(this));

function fl_ClickToGoToAndPlayFromFrame() {

this.gotoAndPlay(0);

}

this.hitbox.addEventListener("click", fl_ClickToGoToWebPage_2);

function fl_ClickToGoToWebPage_2() {

window.open("http://klankiskoning.be", "_parent");

}

I fixed it!

I made a new file, and copied all layers into it.

The problem was caused by my custom loading screen (It happened again, but this time I had an extra save)

Views

1.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 08, 2019 0
Community Beginner ,
Jan 08, 2019

Copy link to clipboard

Copied

I fixed it!

I made a new file, and copied all layers into it.

The problem was caused by my custom loading screen (It happened again, but this time I had an extra save)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 08, 2019 0
Adobe Community Professional ,
Apr 16, 2020

Copy link to clipboard

Copied

The error does not seem to come from a custom loading screen. I am getting the same error more and more often now and I do not have any custom screen.

As you mentioned tho, I did the same thing and created a new file and copy pasted my layers from the file with the error and it works every time. 

I will report this bug today.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 16, 2020 0
Adobe Community Professional ,
Apr 17, 2020

Copy link to clipboard

Copied

I am wondering if you are working from a synched google drive.

Here is what I found when I get the error shown below. Most of the time I get this error message but also if I try another file I get a message concerning the publish path. 

1 - the publish path has changed to a long path starting with square brackets and [C:\\user\\\\....\Google drive\foldername\]

2-  the correct path should be ../foldername/index

3-  when correcting the path it is possible to publish.

 

It seems that when closing the file the path is changed to the long address.   (I do not give the whole address here for privacy reasons).

This is a new error since this never happened in the past. It is pretty recent. 

error message ANCC.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 17, 2020 0