The ActionScript [linkage] box is grayed out. [edited-kglad]

Community Beginner ,
May 26, 2017 May 26, 2017

Copy link to clipboard

Copied

When I want to add a class name from properties of the symbol. The ActionScript linkage box is grayed out and it does not work in Animate CC. I would appreciate your

help in this issue. Thanks.

Untitled.jpg

Views

1.2K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Advocate , May 27, 2017 May 27, 2017
That's because you're working in a HTML5 Canvas document, not ActionScript.  If you want to work with ActionScript, you can use the document type converter by clicking Commands > Convert to Other Document Formats, and selecting the document type that you want.

Likes

translate

Translate

Translate
Most Valuable Participant ,
May 26, 2017 May 26, 2017

Copy link to clipboard

Copied

You have a symbol type of Graphic selected. Graphic symbols to get Actionscript linkage. You'll need to change that symbol to a movieClip or a Button in order to use Actionscript with it.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 26, 2017 May 26, 2017

Copy link to clipboard

Copied

robdillon  wrote

Graphic symbols to get Actionscript linkage.

I'm guessing you meant "don't get".

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 26, 2017 May 26, 2017

Copy link to clipboard

Copied

Thanks for your replay. I have tryied to change the symbol to a movie clip or a button, but still I get the same issue.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
May 26, 2017 May 26, 2017

Copy link to clipboard

Copied

Once you change the symbol to a movieClip, select the check box "Export for Actionscript". Then  the Class name will fill in with your movieClip's name as the Class name. You can change it if you like.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 26, 2017 May 26, 2017

Copy link to clipboard

Copied

I did that but unfortunately I got the same result, the ActionScript is still not active.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
May 26, 2017 May 26, 2017

Copy link to clipboard

Copied

Here's a screen shot of the symbol window as it should look when creating a movieClip.

Screen Shot 2017-05-26 at 3.29.29 PM.png

How does your symbol window differ?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 26, 2017 May 26, 2017

Copy link to clipboard

Copied

unfortunately, it does not appear to me as the shot you posted. Here what it looks like in my program.

Untitled.jpg

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
May 26, 2017 May 26, 2017

Copy link to clipboard

Copied

Is this a new problem? Was Animate working correctly for you previously?

You may just need to re-start Animate, but you probably already tried that.

You may have a problem with your Preferences file, here's the link to the Adobe file on recreating the preferences:Re-create preferences

You may need to re-install Animate.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
May 27, 2017 May 27, 2017

Copy link to clipboard

Copied

That's because you're working in a HTML5 Canvas document, not ActionScript. 

If you want to work with ActionScript, you can use the document type converter by clicking Commands > Convert to Other Document Formats, and selecting the document type that you want.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
May 27, 2017 May 27, 2017

Copy link to clipboard

Copied

Also, when you create a new document, you can select your preferred document type from the list of options so no conversion is necessary:

Screen Shot 2017-05-27 at 11.25.16 AM.png

Screen Shot 2017-05-27 at 11.26.10 AM.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 27, 2017 May 27, 2017

Copy link to clipboard

Copied

Thanks. I think that is why I had this issue. I tried your suggestion and found work.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
May 27, 2017 May 27, 2017

Copy link to clipboard

Copied

Yes, that's where the problem is. I didn't see the Canvas indication in the upper left of your screen shot.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 27, 2017 May 27, 2017

Copy link to clipboard

Copied

Thanks for your help robdillon.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 06, 2020 Dec 06, 2020

Copy link to clipboard

Copied

Yes i convert to actionscript 3.0 but, still my actionscript linkage box is grayed... 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines