Trying to export an animation sequence WITHOUT a background, but it will not work.

New Here ,
Jan 24, 2021

Copy link to clipboard

Copied

I am not new to Animate, but the update has changed a lot of things. Some of my animations require me to ignore the background and just take what I've drawn -- as a .PNG of sorts. This was not an issue in the previous versions, but even when I select to ignore the background and NOT open Media Encoder, the system does what it wants anyway -- it keeps the background with the animation and opens Media Encoder, which I DO NOT want.

Is anyone else having these issues because this is going to set me back a week if they can't be resolved soon. Thanks in advance.

TOPICS
Error, Import and export, Other, Performance, Product issue

Views

74

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 25, 2021

Copy link to clipboard

Copied

reset your preferences, https://helpx.adobe.com/animate/using/set-preferences.html

 

if that doesn't help, what exactly are you doing?  eg, file>export>?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jan 25, 2021

Copy link to clipboard

Copied

     kglad, 

     Thanks for the reply. I have tried resetting my preferences, but the issue persists. What I am attempting to do is as follows:

 

     1: Once I have completed a small animation, I want to export the file to a folder designated for completed animations. 

     2: The path is: File>Export>Export Video/Media...

     3: I check 'Ignore stage color (generate alpha channel).

     4. I uncheck Start Adobe Media Encoder Render Queue immediately.

 

     Despite these efforts, the animation still renders with a background -- but it is not the same color as the one I have set in Animate; it renders with a black background. Adobe Media Encoder opens as well, which I do not want. 

 

     Traditionally, this method would work before the 2021 update. The files would be saved to .MOV formate, which I would import to Premiere and use the animations as an overlay to the video I am editing. It will not allow me to render in .MOV format for some reason. I am thinking that the format it suggests to export in (H.264) may not support backgrounds with 0% Alpha. 

 

     I have tried reinstalling the program, but, as before, the problem continues. This is very bothersome. I am trying to eliminate the possibility of this being a user error. If it is indeed a program issue and if I cannot fix this, I'm not going to be best pleased with this program and may consider other alternatives.

 

     Any other possibilities? Thanks in advance. 

 

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jan 25, 2021

Copy link to clipboard

Copied

     kglad, 

 

     I have found the issue. My hunch of the output format was correct. H.264 does not support transparency. I have chosen to render the animation in Quicktime format, which saves as .MOV. This was odd; tradionally, my program has always saved to .MOV format by default. 

 

     Thanks for your help. Problem solved. 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 25, 2021

Copy link to clipboard

Copied

it is saved as a mov, just in a tmp folder you can't control.

 

follow the steps above to control.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 25, 2021

Copy link to clipboard

Copied

1. when you untick the ame render queue, you're just stopping the automatic rendering.  the temp mov file still opens in ame (waiting to be renedered to something else like h.264 which is no use to you)

2.  right click the mov>click reveal source file

3.  move the mov somewhere convenient and rename it to something reasonable.

 

any problem?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jan 25, 2021

Copy link to clipboard

Copied

It looks like this was solved, but for future reference you need to pick a CODEC that supports an alpha channel.  Fof video formats, Aniamtion with Alpha is common and also Apple ProRes4444 with Alpha.  For a still image sequence, you can go with a PNG with Alpha.

 

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more