Multichannel Options Missing in Premiere 2022 for Windows

New Here ,
Nov 12, 2021 Nov 12, 2021

Copy link to clipboard

Copied

When recording multichannel via Mac, I see several options (shown below).

reproduce.png

 

In Windows, I'm only seeing 01M and 02M. Has anyone seen this problem? How can I restore the multichannel options on Windows?

 

Thanks in advance for your help.

TOPICS
Audio hardware , How to , User interface or workspaces

Views

61

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Nov 12, 2021 Nov 12, 2021

You will only get multichannel recording to work under Windows if you use ASIO as the drive class. The way Microsoft wrote the code makes it rather difficult for multichannel nodes to be exposed - certainly in WDM - and nobody bothers, because the code ends up being rather inefficient. With MME apparently it's a nightmare. ASIO is okay from this point of view though, as it bypasses most of the Windows OS layers and so has none of these restrictions.

 

So yeah, fair and square it's Microsoft's fa

...

Likes

Translate

Translate
Adobe Community Professional ,
Nov 12, 2021 Nov 12, 2021

Copy link to clipboard

Copied

You will only get multichannel recording to work under Windows if you use ASIO as the drive class. The way Microsoft wrote the code makes it rather difficult for multichannel nodes to be exposed - certainly in WDM - and nobody bothers, because the code ends up being rather inefficient. With MME apparently it's a nightmare. ASIO is okay from this point of view though, as it bypasses most of the Windows OS layers and so has none of these restrictions.

 

So yeah, fair and square it's Microsoft's fault - entirely. And it's been like that for a very long time...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 12, 2021 Nov 12, 2021

Copy link to clipboard

Copied

LATEST

Thanks! I had already installed the ASIO drivers, but didn't go through the configuration process.

 

All set and back in business! Thanks again!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines