Rode AI-1 ASIO driver only works at a Sample Rate of 48000 Hz (in Audition 13.0.13, 14.0 and Betas)

New Here ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

Hi there,

I've recently bought a Rode Complete Studio Kit that includes the AI-1 Interface. While it has excellent preamps and works well using MME and WASAPI drivers, on my fully updated Windows 10 (20H2) machine, Rode's ASIO drivers do only work at a Sample Rate of 48000 Hz in Audition. As soon as I change the Sample Rate to any other value, Audition tells me that the "device could not be opened".

The error occurs in Audition 13.0.13, 14.0 and the current Beta version – it occurs regardless of whether I check "Use machine-specific device defaults" and if I attempt to force the hardware to the document's Sample Rate, I end up with the driver running at 48000 Hz anyway (with no audio being recorded above 24 kHz, even though it should, had forcing the hardware actually succeded). The Sample Rate settings in Windows for input and playback devices do not affect the error at all. It's also worth noting that the exact same thing happens if I try the same settings in Adobe Premiere, which I assume is due to Premiere using the same audio engine?

Interestingly enough, the driver works at 96 kHz in Ableton Live 10 Lite that came with the Rode's kit, which basically rules out a hardware fault. I've also already tried different USB ports, cables, Windows user accounts, usb hubs, motherboard drivers and so on. So far, nothing has helped. 

I'm running a Ryzen 3900X build with a Gigabyte X570 Aorus Master motherboard and the latest chipset drivers.

Kind Regards

 

Audition_21_ASIO_error.JPG

TOPICS
Audio hardware , Freeze or hang

Views

2.3K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

First thing to try is putting a check in that box immediately above your warning message - the one about attempting to force the hardware to the document sample rate. That generally does it...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 15, 2021 Mar 15, 2021

Copy link to clipboard

Copied

Thank you very much for your input, Steve! Unfortunately, putting a check in that box does only lead to a recording that does not contain any audio above 22 kHz (not even noise), meaning that it seems as if the interface merely records at a Sampling Rate of 44,1 or 48 kHz in a file that is set to 96 kHz. In addition to that, the setting does not persist, but has to be set every time I launch Audition. Reinstalling Audition also hasn't helped in that regard.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

What makes you think that there's any audio to record above 22kHz? You'd need a whole load of quite exceptional kit before you'd see anything, and then only if there were bats around. There's a good chance that Rode has limited the frequency range, quite deliberately - it will keep potential intermodulation issues down.  Rode has specified the input as flat to 20kHz, implying that they've deliberately rolled it off after that. Here's why:

 

By the time you've reached adulthood, the range of your hearing will have deteriorated to the point where even if you'd got some of these frequencies to record, you'd have trouble hearing anything above 16-18kHz, and if you've spent a lot of time listening to loud music on headphones, it will be even lower.

 

If a file is set to record at 96k, then that is what the ADC will run at. And you will have used twice as much storage space on your hard disk and filled half of it with nothing. The upper limit of the audio and the sample rate are not intrinsically linked at all, up to the Nyquist rate; you can always bandwidth-limit the audio.

 

Consequently there is no point whatsoever in recording at anything higher than 48k if it's normal audio, and only at that rate because it's the norm for video, and Rode knows that - they also know that by limiting the bandwidth, the recording will be technically cleaner because it will reduce the possibility of interference sources getting in.

 

I'm pretty sure that Rode only allow the interface to run at 96k because everybody else does. There's absolutely no good reason to, other than specsmanship these days. All other arguments for higher bit rates disappeared a long time ago when massive levels of oversampling were introduced, removing the need for brickwall filters.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 16, 2021 Mar 16, 2021

Copy link to clipboard

Copied

Thanks again for your input, Steve! I've come to the conclusion that the ADC does in fact not run at 96 kHz if I put a checkbox in the "Attempt to force hardware to document sample rate" because of the following findings:
1.) If I record with my NT1 (using my AI-1 interface) at a sample rate of 96 kHz using Windows MME drivers, peaks reach up to 38 kHz (even though nobody is going to hear it, but Audition certainly can display it using the frequency plot)

[ Take a look at the right portion of the recording in the screenshot ]
2.) If I use the AI-1 ASIO driver with the checkbox, nothing is recorded, in the frequency range beyond 22 kHz... not even ADC noise. [ see the left portion of the recording in the screenshot ]

3.) If I run the AI-1 ASIO driver at 48000 kHz and record into a 96 kHz file, I get the exact same results as in 2.)

 

Due to Shannon-Nyquist-Limit and the design of the drivers, there cannot be anything above 22 to 24 kHz if the ADC does not run at a higher sampling rate. In addition to that, setting anything but 48 kHz in the device settings in Audition gives a "(not working)" message for the AI-1 ASIO driver.

 

Frequency Graph.JPG

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 23, 2021 Oct 23, 2021

Copy link to clipboard

Copied

LATEST

Hello, my self bidhan from india, i also use adobe audition and rode NT1 and AI1 inerface, now when i select ASIO in device class and select RODE AI-1 ASIO in device and when i am changing sample rate 48000 to 44100 it says the device couldnt be opened. Now if I select MME in device class, then everything is working fine. It is my request to all the senior members please help if anyone knows regarding this issue. I am glad and lucky i found this community to ask question.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines