• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Using a Korg nanoKontrol STUDIO as a control surface with Audition CC

Explorer ,
Sep 26, 2018 Sep 26, 2018

Copy link to clipboard

Copied

Hello.

I have a Korg nanoKontrol Studio that I used to use with Logic Pro.  Documentation is skint on using it with Audition

I went into control surfaces in preferences and chose Mackie as the Korg is Mackie compliant.  When I choose to edit the Mackie option, it shows me the nanoKontrol Studio as options for both Midi in and Midi out.  I make these selections, but when I try to use the device as a control surface, nothing happens inside Audition.  I can confirm that the device is connected to the computer via bluetooth and because Garageband sees it and operates with it properly.   I would much prefer to continue with Audition rather than to drop back to Garageband or Logic.

Any guidance offered will be appreciated.

Thanks

Ross

Views

4.5K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 14, 2018 Nov 14, 2018

Copy link to clipboard

Copied

Hello Ross, Did you manage to use it with Premiere? It seems as if the smaller version works with Premiere somehow but looking at the specs on the Korg site it seems as if this machine gives more controls and "feels" better than the cheaper one.

Thanks for your time and your reply if you will answer me.

Regards

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 03, 2018 Dec 03, 2018

Copy link to clipboard

Copied

I missed some days to adopt nanoKontrol Studio with adobe premiere, tried different versions, I did not find a solution. I think this is possible using the "Bome Midi translator", but i don't have time for this s..t. I think  manufacturer must take care of it.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 03, 2018 Dec 03, 2018

Copy link to clipboard

Copied

Hello I managed to find a solution as such:

Inserting the USB cable in NAnoControl2 press the SET MARKER and the REC button.

Then in Premiere go to Preferences and Surface control.

The Mackie control will appear. Select it and in the Settings Everything will appear automatically

The device works for almost everything: the five buttons on the lower part all function (FFward, Frewind, Stop, Play) all work.

Same with the sliders and the Mute and solo

I hope this helps

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 28, 2020 Jan 28, 2020

Copy link to clipboard

Copied

Hello

Are you using "Bome MIDI Translator"?

 

Because it's not working with me at all what you wrote!

 

Thank you

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 02, 2020 Feb 02, 2020

Copy link to clipboard

Copied

Hey Mohammed, try "Scene" and "Marker backwards" keys when starting the device.
Premiere (14.0) works with that solution.

Bildschirmfoto 2020-02-02 um 18.46.28.png

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 19, 2020 Apr 19, 2020

Copy link to clipboard

Copied

tks bro! rec + set works for me!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 12, 2020 Oct 12, 2020

Copy link to clipboard

Copied

this is what I did and it worked for me:

 

 

It worked for me on audition and premiere, what you have to do is to unnplug the nanoKontrol, then press and hold still "set" + "backwards"  until this last start to blink

then open Audition or premiere, then go to preferences, add surface control, add a mackie control, on adjustments select both input and output the nano Kontrol.

You´re ready to use it

Regards

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 21, 2022 Apr 21, 2022

Copy link to clipboard

Copied

What worked for me (in 2022) - and believe me, this took HOURS to figure out - lots of  "ok that doesn't work" leads and so finally in desperation I turned to "trying everything". The KORG manual is "not great" and this took a lot of detective work to piece together. SHORT ANSWER: use "PRO TOOLS" mode. (which in Audition shows as "Mackie HUI".

 

Prerequisites: KORG driver, KORG "Kontrol Editor".

 

1) Turn off Kontrol Studio

2) Hold down "SCENE" button + "REWIND" (<<) and power on the Kontrol Studio. This will place the unit in "Pro Tools" mode.

3) Open Korg Kontrol Editor, select nanoKontrol Studio, open GLOBAL settings (located in the upper Right), select "Common" tab and under "Controller Mode" you should see "Pro Tools". (note: you can also assign and "write" the mode to the Kontroller here as well and skip the whole "Scene + Rewind" power-up step)

4) In Adobe Audition: Edit > Preferences > Control Surface > Device Class... ADD "HUI" > Settings > Add "Midi Input Device" and "Midi Output Device" to "nanoKONTROL Studio 1 CTRL" > OK > The "Type" now says "Mackie HUI" > OK > Device class says "HUI" > OK

 

If it doesn't immediately work, or "kind of works" - save your file and restart Audition. I had to do this and it blew my mind it actually worked the next time I started Audition. THIS WAS ridiculously hard to figure out, and lots of "solutions" did not work for me, but this did! Maybe it will work for you 🙂 Hope so. Good luck. It is worth it in the end. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 22, 2022 Aug 22, 2022

Copy link to clipboard

Copied

scobot's instructions set me on the right track to get Nanokontrol2 working with Audition CC under Windows 10.  I didn't use Korg Kontrol Editor.  I used the Pro Tools power setup described in the Korg "manual," (set marker + play).  Then in Audition preferences under Control Surface, I did:

Cick on Add

In popup box Device Class dropdown, select "HUI" (not "Mackie")

Click on settings, "Mackie HUI" displays in box, highlight it and click "edit"

Set input and output devices to nanokontrol2 in dropdowns (only one choice in each for me)

Click OK until you're all the way out.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 23, 2022 Aug 23, 2022

Copy link to clipboard

Copied

LATEST

Thanks Alan for sharing this. This sounds way easier than what I did, and I will save these instructions for when (inevitably) I turn on Audition one day only to discover my Nanokontrol no longer "works". 😉

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines