Bridgeのバージョンが上がる度にBundle Identifierを変えるのを止めてほしい

勇敢なヒーロー ,
Oct 29, 2021 Oct 29, 2021

リンクをクリップボードにコピー

コピー完了

AdobeアプリケーションをAppleScriptやKeyboard Maestroで制御しています。

このBundle IDを使ってアプリケーションを指定すると、バージョンに左右されずに制御が可能になりますが、PhotoshopやIllustrator/InDesign/PremiereProなどは

com.adobe.photoshop / com.adobe.illustrator というふうに常に変わらないBundle IDが付けられていますが、なぜかかなり前から、Bridgeのみ

com.adobe.bridge11

などとBundle IDにバージョン番号を含めて設定されており、Bridgeのバージョンアップの度にスクリプト書き換えやKeyboard Maestroマクロの変更を迫られます。

 

そもそもBundle IDにバージョン番号を含めているアプリケーションを他に知りません。

 

よく覚えていませんが、com.adobe.bridge6あたりからずっとこうだったかと思います。

なぜBridgeだけが、Bundle IDにバージョン番号を含めてしまっているのかちょっと理解できないです。com.adobe.bridge に戻してほしい。

Yamonov
キーワード
機能改善リクエスト

表示

160

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines
Community Expert ,
Nov 18, 2021 Nov 18, 2021

リンクをクリップボードにコピー

コピー完了

最新

いいね

翻訳

翻訳

レポート

レポート
コミュニティガイドライン
他のユーザーへの思いやりを持ち、敬意を払いましょう。コンテンツの出典を明記し、投稿する前に内容が重複していないか検索してください。 さらに詳しく
community guidelines