• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Bridge CC 9.3 is slow [Branched from: CC 2019 - Very slow ]

Community Expert ,
Apr 10, 2019 Apr 10, 2019

Copy link to clipboard

Copied

After last update Bridge CC 9.3 is very slow. Impossible to work - those actions that used to take seconds, now last minutes. Back to previous version

Views

3.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Apr 10, 2019 Apr 10, 2019

Copy link to clipboard

Copied

Something fundamental is wrong with Bridge. Has been for a few updates now. Possibly since CC2019. No other Adobe app behaves like this.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 10, 2019 Apr 10, 2019

Copy link to clipboard

Copied

Branched to a new thread and successfully moved from Adobe Creative Cloud to Bridge

Disable all extensions and try that. If it works better, enable extension by extension until you find the culprit.

ABAMBO | Hard- and Software Engineer | Photographer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 10, 2019 Apr 10, 2019

Copy link to clipboard

Copied

I turned off all the extensions - it slightly accelerated the work. The previous version is still much faster.

Interestingly, working with the raw files in the bridge has become terribly slow, while the same files in the same version of the camera and the raw opened via photoshop are processed very quickly. In the bridge, any action becomes 3-4 times slower.

I tried to completely remove the application (without saving the settings) and reinstall it - no difference. Video card from the list of recommended adobe, latest drivers, win 10 x64 as well with all updates

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 10, 2019 Apr 10, 2019

Copy link to clipboard

Copied

If there is no specific reason to work with this version, feel free to reinstall a previous one.

ABAMBO | Hard- and Software Engineer | Photographer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Apr 10, 2019 Apr 10, 2019

Copy link to clipboard

Copied

I dropped Bridge 9.0.2 for its poor interface and the blurry previews and went back to Bridge 8.1

Adobe has to give us the choice to use the classic and elegant Bridge look or the new, crowded, attention seeking and way too busy interface.

And the preview problem also has to be fixed.

The other problems I have not encountered as my response to Bridge 9 was so negative it only lasted about ten minutes on my computer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 22, 2019 Apr 22, 2019

Copy link to clipboard

Copied

Dear Users,

We would like to know more about the workflows with which you are facing issue.

I have sent you an email seeking more information regarding the same.

Request you to share more details for us to investigate and we will  come back with resolutions accordingly.

Thanks for your patience.

Regards,

Abhishek Seth.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Apr 22, 2019 Apr 22, 2019

Copy link to clipboard

Copied

latest update (9.0.3.279) fixed this problem

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 22, 2019 Apr 22, 2019

Copy link to clipboard

Copied

Thanks Dmitry for letting us know that your problem is solved with our latest update.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 02, 2019 Aug 02, 2019

Copy link to clipboard

Copied

viewing images in full screen, zooming into 100% or scrolling to the next image takes forever.

even a brand new i7 laptop with 16GB RAM still struggles.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 02, 2019 Aug 02, 2019

Copy link to clipboard

Copied

What is the type and resolution of the pictures?

ABAMBO | Hard- and Software Engineer | Photographer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 04, 2019 Aug 04, 2019

Copy link to clipboard

Copied

20.2MP raw files (roughly 25MB) , the same size images in jpg aren't much better.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 05, 2019 Aug 05, 2019

Copy link to clipboard

Copied

20MP raw files are not enormous. Even that Bridge is not a runner, it should work with decent speed. Is there no other process running?

ABAMBO | Hard- and Software Engineer | Photographer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 05, 2019 Aug 05, 2019

Copy link to clipboard

Copied

nope, fresh laptop (Lenovo Legion Y540) purchased last week.

all that has been installed is essentially Adobe suite and was pretty shocked to see how slow Bridge v9.1 ran. Installed v8.1 and i can scroll through images like a video is playing, where v9.1 will take at least a few seconds at least to preview each image. Going full-screen or 100% preview is just as slow.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 03, 2019 Aug 03, 2019

Copy link to clipboard

Copied

I am having the same problem, latest version (and possibly the few before this in v 9.x) is sluggish to the point of being unusable . I'm on v9.1.0.338 now. Win 10 latest, 32 GB RAM, 9900K and 1080 Ti, so my computer should handle Bridge well. Everything else, Photoshop and Lightroom for instance, working well.

Bridge becomes un-responsive, down to a halt, when interacting with any view. Switching images, going full screen, changing folders, it all ends up taking minutes. My file sizes are in the 20 to 30 MB range, some CR2, some ARW and some TIFF, from a 5D MK II and a RX 100VA. If I simply click once on a thumbnail, I might get a preview top right but no metadata, and the Bridge window keeps flashing "Not Responding" for minutes before anything happens.

I have tried resetting Bridge, played with all settings, disabling Bitdefender. The thing is, eventually it seems to catch up, this is not regular.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 04, 2019 Aug 04, 2019

Copy link to clipboard

Copied

Quick update, after having tried so many different things, settings and shots in the dark, I seem to have better performance. Not blazing fast by any means, but workable. Of course now I can't pinpoint the fix if there was one. It involved multiple Bridge resets, cache resets, flipping the "Generate 100% previews" switch on and off multiple times, playing with performance settings, installing version 8.x, ditching it as it is ugly, creating exceptions for the cache in Bitdefender, and whatever else. In the end, every time I start Bridge now, I am worried it will freeze again and user experience is ruined. Not happy but hey, it's a subscription and I need Lightroom, so I'm hooked.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 05, 2019 Aug 05, 2019

Copy link to clipboard

Copied

vincem120  wrote

(...) creating exceptions for the cache in Bitdefender, (...)

Virus check can take up a lot of resources.

ABAMBO | Hard- and Software Engineer | Photographer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Aug 05, 2019 Aug 05, 2019

Copy link to clipboard

Copied

I don't use Bridge 9.3 at all.

It's in my opinion unusable. Terrible, ugly interface, impractical, blurry previews, bad coding.

Adobe should scrap the whole app, go back to version 8, and re-start the process.

And DO NOT CHANGE THE LAYOUT. I don't need anything new. I just need it to work and be adapted to changes of the internet and the computers that software runs on. Make it just work, Adobe. I'm paying for a professional instrument, not "new and improved features".

The key new feature for me was that Bridge could display in ProPhoto RGB (earlier it could only display sRGB, which was terrible). That was a good upgrade.

But this playing around with features and interface design is a bad idea. We don't need corporate identity in software user interfaces.

The less a software changes in the interface, the better. Just make it run smooth!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 05, 2019 Aug 05, 2019

Copy link to clipboard

Copied

New update: I'm back to a crawl, then tried each different version of V9.x, still unusable. I can't believe this is being kept up, is anybody having any luck running it?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 06, 2019 Aug 06, 2019

Copy link to clipboard

Copied

nope, i've given up.

a large reason for purchasing the new laptop was due to the speed Bridge was running on my desktop PC (quite a few years old now)
can imagine my disgust when it performed no better on the new machine.

Is it possible to upload video evidence of how the versions are behaving?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 09, 2019 Aug 09, 2019

Copy link to clipboard

Copied

I'm dying here because I rely so much on Bridge. I have a hot rod machine to handle both video and photography. Sad that I can only run iTunes, Bridge and photoshop wanting to jump off a 13 story building. Running a bare-bones bridge and it kills everything. EXTREMELY frustrating!!!!!!!!!!!!!!!! Check this out! Don't tell me to dump and re-install because I've been there - done that. Unbelievable that Adobe has yet to truly come out and say "yep, we see the problem everyone is having and we are investigating". Nope, it's check your extensions or just back to an older version.

bridge-taxing-mac.jpg

mac-spec.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 10, 2019 Aug 10, 2019

Copy link to clipboard

Copied

I literally can't preview more than three photos before it freezes.  I to have a new Mac.  This is beyond unacceptable.  They force us to "upgrade" to CC and it doesn't work right.  Its wedding season.  I can't even get an engagement session edited let alone a wedding.    

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 11, 2019 Aug 11, 2019

Copy link to clipboard

Copied

Please give more information on your system, the camera and the bridge version.

ABAMBO | Hard- and Software Engineer | Photographer

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 12, 2019 Aug 12, 2019

Copy link to clipboard

Copied

camera.jpgbridge.jpgbridge-taxing-mac.jpgmac-spec.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 13, 2019 Aug 13, 2019

Copy link to clipboard

Copied

Hi,

Apologies for the inconvenience you are facing.

There is thumbnail and cache generation process happens when you launch bridge and open any folder for the first time, by default it generates 100% preview. You can select prefer embedded which is faster. Uncheck the generate 100% previews option.

For Mac, if you are seeing 300%/400% CPU usage by Bridge, it is not concerning area, if your processor has 8 cores.. it can go upto 800%.. so its not like that bridge is using all of your CPU.

Also if you still see the issue, could you please share below details

1. Sample files on which you are encountering the problem @ swagarwa@adobe.com / ankursin@adobe.com

2. Are you accessing the files on network or local

3. How many images / videos are there in folders you are browsing

4. If you are facing the slowness for some specific operation.

5. Machine configuration and OS version

Thanks,

Bridge Team

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines