• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Hierarchical Keyword problem

New Here ,
Mar 01, 2024 Mar 01, 2024

Copy link to clipboard

Copied

Hello,

 

I don't know if an upgrade broke this by changing something in Bridge, or if an upgrade reset preferences and I just need to fix a setting...

 

I have a large set of hierarchical keywords.  For example, I have France|Brittany|Carnac, and Birds|Owls|Little Owl.  When I would select a more specific keyword (such as Carnac or Little Owl in the examples), I would hold down the shift key, and Bridge would apply all the other keywords as well. 

 

Something changed around the end of August 2023.  Since then, the words are being applied differently; and I can't figure out how to get back the previous behaviour.  Now, it looks like Bridge is still applying the higher level keywords; but not showing that it has applied them.

 

For me, the biggest problem with the new way they are being applied is that the photo viewing app I use on my phone is not able to read the keywords the same way.  The app allows me to view pictures by "tags".  When I select this option, I could look at the tag "Owl" for example, and it would include all images with that keyword -- including Little Owls, Barn Owls, Great Grey Owls, etc.  Now, unfortunately, for any images saved by Photoshop since September, the app cannot extract individual keywords.  It shows a little owl taken in Carnac only as France|Brittany|Carnac,Birds|Owls|Little Owl, instead of including it in the list for each individual keyword.  It's not a problem with the app -- files from August and earlier are still read properly (even after I cleared its cache).  The problem is in how the keywords are being applied in Bridge, or written to the JPEG when I save in Photoshop.

 

Is there a way for me to get back to behaviour Bridge/Photoshop had until August?

 

Thanks

TOPICS
Keywords

Views

74

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Mar 01, 2024 Mar 01, 2024

Copy link to clipboard

Copied

Go to Preferences > Keywords and see if "Write Hierachical Keywords" is selected.

If you turn this off, your keywords should be saved as separate entries separated by semi colons.

 

gregreser_0-1709324654405.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 04, 2024 Mar 04, 2024

Copy link to clipboard

Copied

LATEST

Thank you.  I turned that off, and it seems to work now.  I'm not sure I understand why -- it *is* still writing the heirarchical keywords, but it's doing it differently, and the behaviour seems to be as i want it to be.  (Now i just need to go in and reapply keywords to the last six ,onths of images!)  Thanks again for your help.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 01, 2024 Mar 01, 2024

Copy link to clipboard

Copied

Keywords are simply plain text inside the image file. So a keyword can be written a|b|c or a; b; c. A reader can interpret hierarchical keywords as it desires. You can also have different delimiters than just the pipe glyph.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines