• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Keywords fail to write to file

Explorer ,
Oct 24, 2018 Oct 24, 2018

Copy link to clipboard

Copied

In Bridge 9.0.0.204, whenever I apply a keyword to several files, one always fails.  Once the other files are keyworded, I can then apply the keyword again and it works fine on the file that failed.  But this means always having to apply the keyword twice to files in the group.  I've tried this with different groups of files, always with the same error.  The files that report the error have nothing in common with each other.  It's not a file size or file type issue, and it doesn't matter whether the group is two files or ten.

Views

376

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Oct 24, 2018 Oct 24, 2018

Hi mspiraino,

Please let us know if the issue still persists.

Regards,

Abhishek Seth.

Likes

Translate

Translate
Community Expert ,
Oct 24, 2018 Oct 24, 2018

Copy link to clipboard

Copied

Try resetting your preferences.

Troubleshoot Adobe Bridge for freezes and performance issues

If that doesn't work, test with this script to see what happens. Save it in a text editor as a PLAIN TEXT file (not RTF) with file extension .jsx. Open Preferences->Startup Scripts and click the button to reveal the scripts folder. Drag the .jsx file in and relaunch Bridge. Run that script and see if all selected files have keywords added.

#target bridge

if(BridgeTalk.appName == 'bridge'){

    VT = MenuElement.create('command', 'Keyword Test', 'at the end of Tools');

    }

VT.onSelect = function(){

    keyTest();

    }

function keyTest(){

    var thumbs = app.document.selections;

    var keys = ['Test', 'HTest|Testing', ''];

    if(xmpLib == undefined){

        if(Folder.fs == 'Windows'){

            var pathToLib = Folder.startup.fsName + '/AdobeXMPScript.dll';

            }

        else{

            var pathToLib = Folder.startup.fsName + '/AdobeXMPScript.framework';

            }

        var libfile = new File(pathToLib);

        var xmpLib = new ExternalObject('lib:' + pathToLib);

        }

    try{

        app.synchronousMode = true;

        for(var a in thumbs){

            if(thumbs.hasMetadata){

                for(var b = 0; b < 2; b++){

                    var md = thumbs.metadata;

                    var xmp = new XMPMeta(md.serialize());

                    xmp.appendArrayItem(XMPConst.NS_DC, 'subject', keys, 0,XMPConst.PROP_IS_ARRAY);

                    xmp.appendArrayItem('http://ns.adobe.com/lightroom/1.0/', 'hierarchicalSubject', keys, 0, XMPConst.PROP_IS_ARRAY);

                    var updatedPacket = xmp.serialize(XMPConst.SERIALIZE_OMIT_PACKET_WRAPPER | XMPConst.SERIALIZE_USE_COMPACT_FORMAT);

                    thumbs.metadata = new Metadata(updatedPacket);

                    }

                }

            }

        app.synchronousMode = false;

        }

    catch(e){

        alert(e + e.line);

        }

    }

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 24, 2018 Oct 24, 2018

Copy link to clipboard

Copied

Hi mspiraino,

Please let us know if the issue still persists.

Regards,

Abhishek Seth.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 03, 2019 Oct 03, 2019

Copy link to clipboard

Copied

LATEST
The script worked for awhile. Now I continue to have the problem. Purging the cache doesn't seem to help

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 21, 2019 Sep 21, 2019

Copy link to clipboard

Copied

Only just had a chance to give this script a try and so far it seems to work

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines