• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Need a version of Bridge that will run on Mac OS 10.13.6 on a 2012 iMac

New Here ,
Jan 26, 2022 Jan 26, 2022

Copy link to clipboard

Copied

Bridge suddenly stopped working on a 2012 iMac running 10.13.6, High Sierra. I use as a capture station in the studio and this is as far as the machine will update in the OS. After installing Xrite software and calibrating the monitor, Bridge would no longer open. 

 

I thought I'd uninstall it and reinstall it from Creative Cloud, as anyone would, but after uninstalling, it disappeared from my list of available apps. 

 

 

Views

126

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 26, 2022 Jan 26, 2022

Copy link to clipboard

Copied

HI FDPryor,

 

Yeah, you are in a bit of trouble there. Not fully sure what was the oldest OS that could run on a 2012 iMac but the newest version of Bridge came out in 2019/2020 time period. I can see why you're still running that because that was not that long ago.

 

Anyhow, please try this: Go into your Adobe CC app and click on the Apps tab and then the All Apps list. Scroll down until you see Bridge. To the right you'll see 3 dots (an elipse "…"). Mouse down on that and you'll see an option of "Other Versions." Let me know if you see Bridge v. 10.x there.

 

Good luck!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 26, 2022 Jan 26, 2022

Copy link to clipboard

Copied

Hey, thanks for the help gary_sc,

It shows Bridge as Not Compatible. Gives me no alternatives. The mystery is why it was running on the machine just fine until I installed Xrite calibration software and created a profile for the display. 

 

Sadly, Light Room Classic is also incompatible and the CC version seems incapable of monitoring a watch folder or interfacing usefully with Camera Raw. I thought I was angry at losing Bridge; trying to do anything useful with Lightroom CC really excercised my naughty vocabulary. 

 

I had to put in an emergency order for a Mac Mini to use as a capture station. And I'm investigating Capture One as an image ingestion solution going forward. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 26, 2022 Jan 26, 2022

Copy link to clipboard

Copied

Hi FDpryor,

 

I can't say with any accuracy why it was working and then it isn't. I could guess, but that sometimes gets me into trouble.

 

There are legal reasons behind your problem, you can read up on it here:

https://appleinsider.com/articles/19/05/13/adobe-warning-of-legal-problems-if-users-keep-using-old-v...

 

Meanwhile, IF you have time machine, see if you can bring your computer back to the state it was before you uninstalled Bridge. Otherwise, you can try contacting Adobe and see if they can help you. Otherwise, there's not much to do but to buy a new computer (Yeah, ouch!).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 26, 2022 Jan 26, 2022

Copy link to clipboard

Copied

A 2012 iMac can run up to 10.15 Catalina, which can support current CC versions.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 26, 2022 Jan 26, 2022

Copy link to clipboard

Copied

This 2012 iMac won't run Catalina. When I try to upgrade it past High Sierra I get a message saying that it's not configured properly for the upgrade. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 26, 2022 Jan 26, 2022

Copy link to clipboard

Copied

Maybe you should call Apple and ask how to do that. The big question is what configuration causes this limitation.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

Any 2012 iMac supports Catalina so yes, call Apple for help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

Thanks for the suggestion. 

 

I'd have to pay for the support call and likely get the answer that I'm SOL. I asked the question in the Mac support forums instead. 

 

I vaguely remember (or have dreamed) a point sometime in the past where folks had to make a decision about formatting a drive or some other hardware when they did an update between OS versions. I'm sure the luddite buddy who previously owned this machine chose badly. I also seem to remember that it was an irreversable choice. Hope I'm totally wrong. 

 

In the meantime, I've had to purchase a new Mac Mini just to serve as a capture station for the studio. 

So... that's a solution of sorts. Yay?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

Internal drives are formatted APFS for new installs, so that could be it. You can make an appointment to an Apple Store and get free help there if you want.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

The Apple Support Community confirms that the OS beyond High Sierra can only live on a drive formatted as APFS. The previous owner formatted this one as HFS+. 

 

This is all moot, as I just learned that the software I use to control my studio monolights won't run beyond High Sierra.  So my solution is limited to:

A) leaving this machine to run the strobes, using a new machine to ingest, evaluate, grade and transfer captures to the Photoshop workstation. 

B) upgrading the studio with all new strobes that have software that will run on an up-to-date OS.

 

This, because the Elinchroms I have will not run on their new software.

Which leaves Profoto (great lights but lousy control software so... no_) Hensel (the software has a demo mode which looks like it might be acceptable), or new Elinchrom units... 

... sorry. This has become a question for a different forum. Or three different forums.

 

Thanks for your help, everyone. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

Elinchrom and Profoto are too pricey for me. I wish... A lot of studios use Speedotron Black line but I don't know about control software for those.

I'd say get a newer machine and use the old one for lighting control as needed.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 27, 2022 Jan 27, 2022

Copy link to clipboard

Copied

LATEST

I hear ya.  I used Speedos forever when I was assisting in the last century. Today I need the fine control/repeatability and desktop admin I get from monoblocks with good software. Unfortunately, when people redesign their software they often make it worse. Elinchrom's previous control software wasn't nearly as pretty as the new version, but the user interface was much better. 

 

And I've thought about leaving the iMac in the mix, but if I update the OS it will no longer run these strobes. If I leave the OS where it is, it's a security issue if I, or anyone else ever fires up the browser. And it's old enough that I expect it to fail and take my capture station down with it. 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines