• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Problem Moving Images Between Folders In Bridge (Windows 7 Professional)

Community Beginner ,
Feb 01, 2012 Feb 01, 2012

Copy link to clipboard

Copied

I have just bought a new computer with Windows 7 installed. I now also have Adobe CS5 Design Premium installed.

When I try to MOVE or DRAG and DROP an image from one folder to another using Adobe Bridge I get the following error message:

"The operation cannot be completed because you don't have sufficient permissions"

When I try the same thing in Windows Explorer it tells me that I need Administrator Permission. I click OK and it works in that programme.I am actually the Administrator

Can anybody tell me how I can configure Bridge to undertake this task please.

Many thanks in anticipation

Adrian 

Views

5.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Feb 07, 2012 Feb 07, 2012

Dear friends

To my great relief I have now sorted this issue and offer the following as the Correct Answer. My sincere and grateful thanks go to Curt and Yammer, above, who have helped me so much in sorting this Windows 7 issue which is clearly very relevant to Bridge users also. Any slowness to grasp what they have been saying is down to me!

The key to solving this issue lies is understanding that in terms of Windows 7 Security, every internal or external hard drive, plus folders, sub-folders and

...

Likes

Translate

Translate
LEGEND ,
Feb 01, 2012 Feb 01, 2012

Copy link to clipboard

Copied

Are you moving file from or to an external drive.  Permission problmes can arise with externals on some operations. 

If this is the case you can start Bridge by right clicking and choosing Run as Administator.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 02, 2012 Feb 02, 2012

Copy link to clipboard

Copied

Curt Y, you are a star, thank you so much. All my photo images are indeed stored on an external drive. Right clicking the Bridge icon and choosing 'Run as Administrator' does indeed now allow me to move stuff aound using Bridge and for that I am exceedingly grateful. Bridge still wont allow me to move these files however if I open it up in the normal way.

As Yammer P has suggested it seems I need to sort out the Security / Permissions issues in Windows 7 to be able to move files on the external drive through Windows. This is not a problem on the C Drive, only on the hard drive. Having spent all morning trying to sort this I'm away back now to have another go!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Feb 03, 2012 Feb 03, 2012

Copy link to clipboard

Copied

Unless you have a particular security setup, you should consider making files on the root of external drive available to 'Everyone', or at least 'Users', and making sure the permissions replicate through files and folders.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 03, 2012 Feb 03, 2012

Copy link to clipboard

Copied

Yammer, It sounds like I am tantalisingly close to sorting this issue thanks to your help but unfortunately I am not quite there yet. Would you be kind enough to set out for me step by step what I need to do to implement what you are suggesting above as I'm afraid I can't quite fathom it. In particular, how should I list my external drive (Drive i) for Permissions? Also when I have looked in the Permissions dialogue boxes there are check boxes relating to Special Permissiona under 'Advanced'. I haven't a clue what these are about but I suspect they may be relevant. Could you advise please. I really really appreciate your help. Thank you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Feb 04, 2012 Feb 04, 2012

Copy link to clipboard

Copied

Try this Windows 7 - Can't delete files on a external harddrive-Says I need permission when I have administra...

or this Permissionless external drive with NTFS

 

I don't really want to get into Windows support in a Bridge forum. Hopefully these links will put you on the right track.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 04, 2012 Feb 04, 2012

Copy link to clipboard

Copied

That's perfectly understandable Yammer. Will follow the links you have so helpfully sent and report back on the outcome in due course. Many thanks for all your help. Adrian

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 29, 2022 Mar 29, 2022

Copy link to clipboard

Copied

LATEST

Thanks!! 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 01, 2012 Feb 01, 2012

Copy link to clipboard

Copied

Forgot to add.  Make sure Bridge is latest version.  This issue was a problem with one of the earlier versions.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Feb 01, 2012 Feb 01, 2012

Copy link to clipboard

Copied

If its not straightforward in Explorer then it won't be in Bridge neither.

You need to sort out whatever permissions problem you have in Windows before you can expect it to work in Bridge. Which folders are giving problems? Usually it's the standard system/program folders which throw up these sort of warnings. You should keep your data files in a separate location.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 05, 2012 Feb 05, 2012

Copy link to clipboard

Copied

UPDATE

For those still following this thread, after hours of research I have now taken OWNERSHIP of the hard drive and all its files but unfortunately that in itself has not solved the problem of denied access. It seems that the solution relates to PERMISSIONS for the drive itself plus folders, sub-folders and files thereon.

I have selected a couple of folders and manually changed the Permissions to allow me Full Control and found that by doing this both Windows and Bridge do now allow me to move files between those folders without the Access Denied error message occurring. So far so good!

I have several hundred folders and several thousand image files on this and another external drive however and so I have posted a question on a Windows 7 user forum asking whether there is a way of applying a set of permissions to every folder on a drive in one fell swoop. To conclude this thread I will post the result when known! 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 05, 2012 Feb 05, 2012

Copy link to clipboard

Copied

One thing you might try, especially if you have created the files on the external with a different computer.

Right click on the parent folder, choose Properties,Secutity tag, then grant full permission to user you have logged in with.

If you have a different user when you made the files it casues a permission problem I guess.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Feb 06, 2012 Feb 06, 2012

Copy link to clipboard

Copied

Pixel Basher wrote:

 

I have selected a couple of folders and manually changed the Permissions to allow me Full Control and found that by doing this both Windows and Bridge do now allow me to move files between those folders without the Access Denied error message occurring. So far so good!

I have several hundred folders and several thousand image files on this and another external drive however and so I have posted a question on a Windows 7 user forum asking whether there is a way of applying a set of permissions to every folder on a drive in one fell swoop. To conclude this thread I will post the result when known! 

Absolutely. In fact, I don't know why you haven't already found the answer, as the question usually gets asked when you update a drive/folder's permissions: something along the lines of "do you also want to apply changes to subdirectories and files contained in this folder?"

This might help:

How to assign access rights to subfolders

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 07, 2012 Feb 07, 2012

Copy link to clipboard

Copied

Dear friends

To my great relief I have now sorted this issue and offer the following as the Correct Answer. My sincere and grateful thanks go to Curt and Yammer, above, who have helped me so much in sorting this Windows 7 issue which is clearly very relevant to Bridge users also. Any slowness to grasp what they have been saying is down to me!

The key to solving this issue lies is understanding that in terms of Windows 7 Security, every internal or external hard drive, plus folders, sub-folders and files thereon has an OWNER. Also each OWNER has a certain level of PERMISSION to do things such as moving files to a different folder, deleting or re-naming them etc. If you try to do things that you don't currently have Permission to do, that is when you get an ‘Access Denied’ error message. Also your system has an Admistrator or Administrators and at the outset you need to ensure through the Control Panel that you are listed as one of them. .

If, like me, you didn't realise these things, (and why would you if Microsoft or your computer or hard drive suppliers couldn't be bothered to really make sure you knew about them), then trying to fathom the ‘Access Denied’ problem becomes a stressful and frustrating nightmare as I can testify having spent a week at it!

The steps that I took to resolve the issue and which I believe now constitute the 'Correct Answer' are as follows:

  1. First make sure that you have Administrator rights on your system via the Control Panel

  2. Next ‘right click’ on the Drive whose files you want to gain full access to, for example the drive that your pictures are stored on, and click on 'Properties'.

  3. Under the Security tab you will see a list of Groups and Users on this drive and the Permissions that they have to do things.

  4. Before doing anything to edit these Permissions, first click on the Advanced button. This opens another window with a tab showing the Owner of this drive.
     
  5. Click on the Owner tab and if you are not already listed as the owner, make yourself the owner by selecting your name from the list. I believe it should appear there if you are an admistrator or user. (In my case at this stage the owner was initially shown as an obscure string of numbers and letters which I believe identified the drive when it was connected to the lap top I was using before I upgraded my machine)

  6. Now be sure to check the box that says "Replace Owner on Subcontainers and Objects" and the click Apply. On completion of this step, the drive in question and all the folders, subfolders and files thereon should now be 'owned' by you. You could check this out by right clicking on a particular folder then clicking Properties > Security > Advanced > Owner. Your name should appear. So far so simples!

  7. Now go back to the Security Tab for your drive (Step 2 / 3 above) and look at the Permissions you currently have. Your aim now is to allow yourself 'Full Control.' If you don’t currently have this level of permission click Edit, select your name on the list, check ‘Full Control’ and 'Apply' the change.

  8. I think I'm right in saying that at this point whilst still working in the Drive directory you are now given the option of ticking boxes which allow you to, in effect, cascade the permission you have just granted yourself to all the files and folders on that drive. Tick the box to allow this and Windows should then take care of the rest.If I'm not quite correct here then in my particular case, for example, all my images were stored on my external drive. The top level, or 'parent' folder in which all my pictures could be found was the 'My Pictures' folder and I had created a number of folders and subfolders ('child ' folders) within that folder. The permissions I gave to the Parent folder – My Pictures – were cascaded down through the Child folders.

  9. On completion of the above step I tested the result in Windows Explorer by dragging a few files back and forth between folders and it now worked perfectly - I was now able to move / delete / rename etc all files without now getting the dreaded access denied message. What a sense of relief! This meant that I could now open Bridge normally rather than having to right click it and 'Run As Admistrator' - albeit that is a very useful thing to do until you get the problem sorted as described.

Somebody said to me the other night that when you buy a car you buy it to enjoy the drive, not to have to tinker with the engine. Microsoft and companies that supply and install Windows 7 on new computers please take note!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Mentor ,
Feb 07, 2012 Feb 07, 2012

Copy link to clipboard

Copied

If you're as old as me, and worked in IT in the 80s, you'll know that IBM and Microsoft originally produced PCs for technical users--engineers, mathematicians, accountants, draughtsmen, etc. They were always complicated beasts, even when they booted off a floppy disk. The manual was huge, and you were expected to read it. Hardware configuration was complicated, and expansion cards required a Physics Nobel Prize to fit.

A few years later, Apple designed the Mac for non-technical people (an untapped market). They did very well, and IBM/Intel/Microsoft largely discounted this for the next few years. But eventually, Microsoft felt they were missing out, and half-heartedly copied the (optional) GUI idea in Windows 2/3. By 1995 they were getting into Plug-and-Play, but were still working with old hardware and an old underlying operating system.

Things have got better, since the adoption of the NT core in Windows 2000/XP, but PCs have always had this legacy of backwards-compatibility, and a large base of options-hungry users. Using your analogy, many PC users spent their Sundays in overalls, underneath the engine--that was part of the appeal. I have always told people (as the 'computer-guy' friend), that if you don't want to get your hands dirty, get a Mac, but people I knew bought PCs because they were cheaper, and it was easier to source hardware and cheap/free software. They ring me on a Sunday. C'est la vie!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
People's Champ ,
Feb 07, 2012 Feb 07, 2012

Copy link to clipboard

Copied

that if you don't want to get your hands dirty, get a Mac, but people I knew bought PCs because they were cheaper, and it was easier to source hardware and cheap/free software.

Thanks!

I'm not afraid of getting dirty hands but only for garden purpose... I use Mac for about 18 years now and yes they are not cheap. BUT, I rarely have to buy extra soap for dirty hands and don't need an overall

I can't remember having had a big problem with my Mac's, the small problems were easily fixed by myself, without the need for change of clothes or getting dirty hands.

Have also to confess I know next to nothing about Windows and am not able to help solving problems like I used to in the Mac department.

It might be a good idea to state clearly in the post which OS is being used

Keep up the good work!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 07, 2012 Feb 07, 2012

Copy link to clipboard

Copied

Pixel Basher wrote:

Dear friends

The key to solving this issue lies is understanding that in terms of Windows 7 Security, every internal or external hard drive, plus folders, sub-folders and files thereon has an OWNER. Also each OWNER has a certain level of PERMISSION to do things such as moving files to a different folder, deleting or re-naming them etc. If you try to do things that you don't currently have Permission to do, that is when you get an ‘Access Denied’ error message. Also your system has an Admistrator or Administrators and at the outset you need to ensure through the Control Panel that you are listed as one of them. .

Pixel Basher,

Thank you for the detailed fix report you supplied.  I believe this will be helpful to many future users.  I will probably reference your post next time someone has the same issues.  Yammer and I brought out the issues, but you had to do the legwork to actually get all the pieces working correctly.  Good job!

curt y

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines