• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

P: Camera Raw hangs trying to import or export some jpg files with malformed metadata.

Community Beginner ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

i installed the latest version of Lightroom that was release last week i believe,  When i try to import or export some jpg files the program hangs.  you can wait for hours and it will not complete.  Is anyone else seeing this  I have do this test on three windows computers.  Has anyone seen this problem?

 

I am running Windows 10 on two machines and Windows 11 on the other.

 

 

Bug Fixed
TOPICS
Windows

Views

371

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct answers

Adobe Employee , Jan 04, 2022 Jan 04, 2022

Setting status to fixed in 14.1

Status Fixed

Votes

Translate

Translate
Adobe Employee , Nov 04, 2021 Nov 04, 2021

Bug written - Set Status to Acknowledged

 

Update from engineering; The actual hang was due to the presence of the substring "Table_" within this JPEG's embedded XMP.  

Status Acknowledged

Votes

Translate

Translate
12 Comments
LEGEND ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

Upload one of the problem JPEGs to Google Drive or similar and post the sharing link here. We can see if it occurs on other installations and if it does, what might be going wrong.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Nov 03, 2021 Nov 03, 2021

Copy link to clipboard

Copied

I have uploaded the problem jpg to OneDrive, the link is below.  Let me know if  you cannot copy the file.

Thanks!

 

https://1drv.ms/u/s!ApX3cw9gqLDujs4Y2EOpkxod9riSqg?e=cfTeOh

Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 03, 2021 Nov 03, 2021

Copy link to clipboard

Copied

That file failed to import into my LR 11.0 and PS 23.0.0 (Mac OS) -- LR hung using 400% CPU, and PS hung using 100% CPU.  I had to force-quit them.

 

But the file opened in Mac OS Acrobat, Firefox, Safari, Preview, and Windows Irfanview.

 

The file contains malformed XMP metadata that doesn't conform to industry standards. However, it's a bug that LR and PS hang reading the file -- they should always give an error message when presented with malformed inputs.

 

Microsoft Photo may be the culprit, since it left its fingerprints in the XMP metadata.

 

Below are the pretty-printed contents of the XMP section of the file. Notice that it has two <rdf:Description> tags that are unmatched by </rdf:Description>.

 

<?xml version="1.0"?>
<?xpacket begin='' id='W5M0MpCehiHzreSzNTczkc9d'?>
<x:xmpmeta xmlns:x="adobe:ns:meta/">
  <rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
    <rdf:Description xmlns:xmp="http://ns.adobe.com/xap/1.0/" rdf:about="uuid:faf5bdd5-ba3d-11da-ad31-d33d75182f1b">
      <xmp:CreateDate>1992-08-10T11:01:17.448</xmp:CreateDate>
    </rdf:Description>
    <rdf:Description xmlns:dc="http://purl.org/dc/elements/1.1/" rdf:about="uuid:faf5bdd5-ba3d-11da-ad31-d33d75182f1b"/>
    <rdf:Description xmlns:MicrosoftPhoto="http://ns.microsoft.com/photo/1.0/" rdf:about="uuid:faf5bdd5-ba3d-11da-ad31-d33d75182f1b"/>
    <rdf:Description xmlns:dc="http://purl.org/dc/elements/1.1/" rdf:about="uuid:faf5bdd5-ba3d-11da-ad31-d33d75182f1b">
      <dc:subject>
        <rdf:Bag xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
          <rdf:li>1992_Bransion_Table_Rock_lake</rdf:li>
        </rdf:Bag>
      </dc:subject>
    </rdf:Description>
    <rdf:Description xmlns:MicrosoftPhoto="http://ns.microsoft.com/photo/1.0/" rdf:about="uuid:faf5bdd5-ba3d-11da-ad31-d33d75182f1b">
      <MicrosoftPhoto:LastKeywordXMP>
        <rdf:Bag xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
          <rdf:li>1992_Bransion_Table_Rock_lake</rdf:li>
        </rdf:Bag>
      </MicrosoftPhoto:LastKeywordXMP>
    </rdf:Description>
  </rdf:RDF>
</x:xmpmeta>
<?xpacket end='w'?>

 

 

Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 03, 2021 Nov 03, 2021

Copy link to clipboard

Copied

To work around this bug, you could use the free Exiftool utility to delete the XMP metadata from the file:

 

 

 

$ cp 1992_Bransion_Table_Rock_lake20191110_0016.jpg fresh.jpg
$ exiftool -xmp:all fresh.jpg
About                           : uuid:faf5bdd5-ba3d-11da-ad31-d33d75182f1b
Subject                         : 1992_Bransion_Table_Rock_lake
Last Keyword XMP                : 1992_Bransion_Table_Rock_lake
$ exiftool -xmp:all= fresh.jpg
    1 image files updated

 

 

 

This will delete the keywords that had been added (presumably by Microsoft Photo).  Your other photos may have other useful metadata stored in their XMP sections -- you could use Exiftool to examine them too.

Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 03, 2021 Nov 03, 2021

Copy link to clipboard

Copied

Moderators, @Rikk Flohr: Photography , please move into Bugs.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Nov 03, 2021 Nov 03, 2021

Copy link to clipboard

Copied

Thanks for digging into this one for me. I will fix this jpg lord knows how many more like this I may have.  

This file as been in lightroom for many years.  I have exported it many times without a problem. 

 

Thanks again! 

Votes

Translate

Translate

Report

Report
Community Beginner ,
Nov 03, 2021 Nov 03, 2021

Copy link to clipboard

Copied

I downloaded the exiftool and removed the XML data from the file like you suggested and now I can import the jpg into V11 Lightroom without a problem.  Thanks a bunch for looking into this!

Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 03, 2021 Nov 03, 2021

Copy link to clipboard

Copied

Glad the workaround is effective.

Votes

Translate

Translate

Report

Report
Community Expert ,
Nov 03, 2021 Nov 03, 2021

Copy link to clipboard

Copied

I've moved this to Bugs, and edited the subject line for clarity. 

Votes

Translate

Translate

Report

Report
LEGEND ,
Nov 03, 2021 Nov 03, 2021

Copy link to clipboard

Copied

Thanks Michael.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Nov 04, 2021 Nov 04, 2021

Copy link to clipboard

Copied

Bug written - Set Status to Acknowledged

 

Update from engineering; The actual hang was due to the presence of the substring "Table_" within this JPEG's embedded XMP.  

Rikk Flohr - Customer Advocacy: Adobe Photography Products
Status Acknowledged

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Jan 04, 2022 Jan 04, 2022

Copy link to clipboard

Copied

LATEST

Setting status to fixed in 14.1

Rikk Flohr - Customer Advocacy: Adobe Photography Products
Status Fixed

Votes

Translate

Translate

Report

Report