• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
12

P: Cannot merge panorama after updating to 10.14.6

Explorer ,
Aug 06, 2019 Aug 06, 2019

Copy link to clipboard

Copied

Since upgrading to OS 10.14.6, Lightroom Classic (8.3.1) cannot merge (21 frame) panoramic images. Just sits there forever and does nothing.

Bug Fixed
TOPICS
macOS , Windows

Views

445

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Aug 26, 2019 Aug 26, 2019
Please update macOS. Go to System Preferences > Software Update and install the following update:

macOS Mojave 10.14.6 Supplemental Update   –– Restart Required
This update contains bug fixes that improve the stability, performance, and security of your Mac, and is recommended for all users.

This update:


  • Resolves an issue that may cause certain Mac notebooks to shut down during sleep

  • Fixes an issue that may degrade performance when working with very large files

  • Addresses an issue that may preve
...

Votes

Translate

Translate
replies 121 Replies 121
121 Comments
Explorer ,
Aug 07, 2019 Aug 07, 2019

Copy link to clipboard

Copied

Just following up on this. So it's any large panorama that Lightroom Classic has an issue with since upgrading. It's like it won't use the full CPU (like it did before) to render it. Rendering panos in Photoshop works just fine (and uses the full CPU); it's just a Lightroom Classic issue -- almost like it's only using a 1/4 of the threads available to it.

Votes

Translate

Translate

Report

Report
Community Beginner ,
Aug 08, 2019 Aug 08, 2019

Copy link to clipboard

Copied

Good morning Ray,

I have had the same problem and I stumbled on a change (I hesitate to call it a solution) that got things going again: I changed the name of the files. I know. It is completely ridiculous to think that that pano s/w sulks until it sees the file names changed, but it has worked for me more than once. All I can say is try it and if it works we'll ask Adobe how is it that these two things could possibly be related.
Cheers,
Koro

Votes

Translate

Translate

Report

Report
LEGEND ,
Aug 08, 2019 Aug 08, 2019

Copy link to clipboard

Copied

It may be a corrupt cache or application state, or directory damage. Or it might be Lightroom, but you need to rule out that it’s a MacOS issue with your system first.

Please give your Mac the "once over"! Run the free Onyx (https://www.titanium-software.fr/en/o...), reboot. (In Onyx just run almost everything in the Maintenance tab, deselecting things you may not want deleted, like Launch Services . Hit the "Options" button and deselect more stuff like Cookies & Other Site Data, Browser History, Form Values, etc.), then hit Run Tasks. After it's done it will ask for a reboot.

If that doesn’t fix it run Disk Warrior if you can ($120), (https://www.alsoft.com), reboot. If you can’t do Disk Warrior, at least run First Aid from Disk Utility. Also just doing a "Safe Boot" can clear out caches (restart, hold down shift until you see "Safe Boot" on the screen, then reboot normally.

If that doesn’t work try launching Lightroom from your other (admin or test) account, with a new catalog, as a test. Does it run OK? If it does it may be a corrupted preference in your Username/Library folder. Check The Lightroom Queen site for instructions on how to reset your preferences (https://www.lightroomqueen.com).

Votes

Translate

Translate

Report

Report
Community Expert ,
Aug 09, 2019 Aug 09, 2019

Copy link to clipboard

Copied

If changing the file name works, then it may indeed be a cache problem. You could start by purging the Camera Raw cache (in the Preferences).
-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
LEGEND ,
Aug 09, 2019 Aug 09, 2019

Copy link to clipboard

Copied

Onyx will do that!

Votes

Translate

Translate

Report

Report
Community Expert ,
Aug 09, 2019 Aug 09, 2019

Copy link to clipboard

Copied

Yep, but Lightroom can do that itself.
-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Explorer ,
Aug 10, 2019 Aug 10, 2019

Copy link to clipboard

Copied

No luck. Same issues. Adobe, please address the obvious issue.

Votes

Translate

Translate

Report

Report
Explorer ,
Aug 12, 2019 Aug 12, 2019

Copy link to clipboard

Copied

I uninstalled Lightroom and re-installed it and that has mostly solved the problem.

Votes

Translate

Translate

Report

Report
LEGEND ,
Aug 12, 2019 Aug 12, 2019

Copy link to clipboard

Copied

Awesome, thanks for reporting the solution.

Votes

Translate

Translate

Report

Report
New Here ,
Aug 12, 2019 Aug 12, 2019

Copy link to clipboard

Copied

That's my problem, too. Reinstalling Lightroom is no solution, a clean and fresh install of 10.14.6 is no solution... Adobe's customer service seems to know the problem but decided that this is an Apple-problem because something changed in MacOS regarding memory caching.
Can't work any more with lightroom. Apple does not allow downgrades, no matter what. My system is right now completly useless.
Wondering what happens when 10.15.0 will show same caching behaviour... Lightroom will not be useable then, too.
Exporting RAWs is also impossible, LR freezes. Sorry, but this is really a desaster!
LR needs an update!

Votes

Translate

Translate

Report

Report
LEGEND ,
Aug 12, 2019 Aug 12, 2019

Copy link to clipboard

Copied

If you hire a REAL Mac tech he/she can downgrade you, but it’s many hours. Do a web search in your area.

Votes

Translate

Translate

Report

Report
Explorer ,
Aug 12, 2019 Aug 12, 2019

Copy link to clipboard

Copied

You can easily downgrade your OS using a previous Time Machine backup. That said, hopefully Adobe recognizes the problem and solves this sooner than later.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Aug 13, 2019 Aug 13, 2019

Copy link to clipboard

Copied

Lightroom Classic 8.4 was released yesterday. Please try installing this update and seeing if you still have issues with the panorama merging. So far, as a team, we've been unable to reproduce what you are experiencing. 

If, after the update, you are still seeing issues, then we need to get some detailed information from you regarding your OS version, free disk space, etc. 
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
New Here ,
Aug 13, 2019 Aug 13, 2019

Copy link to clipboard

Copied



Lightroom Classic now hangs when creating panoramas. The issue started while on 8.3 but I have now updated to 8.4 and still have the same issue. LR Classic been reliable for months but I now can't create any panoramas within Lightroom. The same images will merge within Photoshop (if I merge the HDR's prior to Photoshop) or PTGUI, but I prefer to stay within lightroom as it creates an ARW file. Depending on the file set, the preview step can hang, or it  can hang during merge. HDR still merges ok.  

Votes

Translate

Translate

Report

Report
New Here ,
Aug 13, 2019 Aug 13, 2019

Copy link to clipboard

Copied



Lightroom Classic now hangs when creating panoramas. The issue started while on 8.3 but I have now updated to 8.4 and still have the same issue. LR Classic been reliable for months but I now can't create any panoramas within Lightroom. The same images will merge within Photoshop (if I merge the HDR's prior to Photoshop) or PTGUI, but I prefer to stay within lightroom as it creates an ARW file. Depending on the file set, the preview step can hang, or it  can hang during merge. HDR still merges ok.  

Votes

Translate

Translate

Report

Report
Community Expert ,
Aug 13, 2019 Aug 13, 2019

Copy link to clipboard

Copied

Guys, a long shot, but can we get the contents of Help menu > System Info please? I can't reproduce it either, and I'm wondering if there's a hardware element that's shared across your system. Also, the camera used to capture the photos might offer some extra clues.
_______________________________________________
Victoria - The Lightroom Queen - Author of the Lightroom Missing FAQ & Edit on the Go books.

Votes

Translate

Translate

Report

Report
New Here ,
Aug 13, 2019 Aug 13, 2019

Copy link to clipboard

Copied

Thank you so much for having a look into this... it's driving me nuts! I've copied the header, let me know if you need the rest...

Lightroom Classic version: 8.4 [ 201908011719-03751b60 ]License: Creative Cloud
Language setting: en-GB
Operating system: Mac OS 10
Version: 10.14.6 [18G87]
Application architecture: x64
Logical processor count: 4
Processor speed: 3.3 GHz
Built-in memory: 16,384.0 MB
Real memory available to Lightroom: 16,384.0 MB
Real memory used by Lightroom: 450.6 MB (2.7%)
Virtual memory used by Lightroom: 11,382.9 MB
Memory cache size: 561.5MB
Internal Camera Raw version: 11.4 [ 273 ]
Maximum thread count used by Camera Raw: 3
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 5001MB / 8191MB (61%)
Camera Raw real memory: 5005MB / 16384MB (30%)
Displays: 1) 2880x1800

Graphics Processor Info: 
Metal: Intel(R) Iris(TM) Graphics 550

Votes

Translate

Translate

Report

Report
New Here ,
Aug 13, 2019 Aug 13, 2019

Copy link to clipboard

Copied

I'm having the same issue with 2 devices - Sony camera and DJI drone. Have copied the sys info below.

Votes

Translate

Translate

Report

Report
New Here ,
Aug 13, 2019 Aug 13, 2019

Copy link to clipboard

Copied

FYI I've already tried purging the camera raw cache and disabling the GPU acceleration. 

Votes

Translate

Translate

Report

Report
New Here ,
Aug 13, 2019 Aug 13, 2019

Copy link to clipboard

Copied

Another FYI (and I know this is non-specific, but...), until the last couple of days (i.e. the time I upgraded to 10.14.6) I had no real lag or performance issues with LR. However now in general use I get frequent spinning wheels and general slowdowns when just browsing the catalog etc. So that potentially backs up the theory re hardware related issues.

Votes

Translate

Translate

Report

Report
Adobe Employee ,
Aug 13, 2019 Aug 13, 2019

Copy link to clipboard

Copied

For those experiencing this issue, please check your free hard drive space. 
Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Explorer ,
Aug 13, 2019 Aug 13, 2019

Copy link to clipboard

Copied

For the record, my issue was specifically with any panos that were 21 frames -- same thing > DJI (Mavic 2) Pro drone. James, what might be helpful for the Lightroom team is to shoot them a Dropbox/Google Drive link to the DJI pano frames so that they can test it.

Votes

Translate

Translate

Report

Report
New Here ,
Aug 13, 2019 Aug 13, 2019

Copy link to clipboard

Copied

Thanks for your comment Rikk. Running at ~ 90-110GB free (500GB native drive), depending on preview cache.  

Votes

Translate

Translate

Report

Report
New Here ,
Aug 13, 2019 Aug 13, 2019

Copy link to clipboard

Copied

Thanks Ray... I can fire them the shots no problem if they need. However for me it's "anything". I've tried with a number of different DJI (same drone) shots, variable shot counts, plus Sony Camera shots. Perhaps tried around 10 different pano's shot over the last couple of days and nothing will merge. 

Votes

Translate

Translate

Report

Report
New Here ,
Aug 13, 2019 Aug 13, 2019

Copy link to clipboard

Copied

I'm using a Canon 5Ds. Having problems with anything regarding dng-fileformat. Exporting cr2 is no problem, exporting dng freezes. Creating HDRs does not work, creating panoramas does not work. Working with cr2 is no problem at all.

Set up a completly fresh 10.14.6, installed only Lightroom - same problems. LR freezes as long as dng-file format is created/exported.

Free disk space: 200GB

As far as I can see LR uses only one core while processing dng


Lightroom Classic-Version: 8.4 [ 201908011719-03751b60 ]Lizenz: Creative Cloud
Spracheinstellung: de-DE
Betriebssystem: Mac OS 10
Version: 10.14.6 [18G87]
Anwendungsarchitektur: x64
Anzahl logischer Prozessoren: 12
Prozessorgeschwindigkeit: 3,2 GHz
Integrierter Speicher: 8.192,0 MB
Für Lightroom verfügbarer phys. Speicher: 8.192,0 MB
Von Lightroom verwendeter phys. Speicher: 1.083,5 MB (13,2%)
Von Lightroom verwendeter virtueller Speicher: 2.167,8 MB
Cache-Speichergröße: 35,1MB
Interne Camera Raw-Version: 11.4 [ 273 ]
Maximale Anzahl Threads, die Camera Raw verwendet: 5
Camera Raw SIMD-Optimierung: SSE2,AVX,AVX2
Virtueller Speicher in Camera Raw: 457MB / 4095MB (11%)
Physischer Speicher in Camera Raw: 458MB / 8192MB (5%)
Monitore/Anzeigegeräte: 1) 2560x1440

Informationen zum Grafikprozessor: 
Metal: Intel(R) UHD Graphics 630



Anwendungsordner: /Applications/Adobe Lightroom Classic
Bibliothekspfad: /Users/admin/Pictures/Lightroom/Lightroom Catalog.lrcat
Einstellungen-Ordner: /Users/admin/Library/Application Support/Adobe/Lightroom

Installierte Zusatzmodule: 


Config.lua-Flags: None

AudioDeviceIOBlockSize: 512
AudioDeviceName: Externe Kopfhörer
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 48000
Build: Uninitialized
CoreImage: true
GL_ACCUM_ALPHA_BITS: 0
GL_ACCUM_BLUE_BITS: 0
GL_ACCUM_GREEN_BITS: 0
GL_ACCUM_RED_BITS: 0
GL_ALPHA_BITS: 8
GL_BLUE_BITS: 8
GL_DEPTH_BITS: 24
GL_GREEN_BITS: 8
GL_MAX_3D_TEXTURE_SIZE: 2048
GL_MAX_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_UNITS: 8
GL_MAX_VIEWPORT_DIMS: 16384,16384
GL_RED_BITS: 8
GL_RENDERER: Intel(R) UHD Graphics 630
GL_SHADING_LANGUAGE_VERSION: 1.20
GL_STENCIL_BITS: 8
GL_VENDOR: Intel Inc.
GL_VERSION: 2.1 INTEL-12.10.12
OGLEnabled: true
GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_array_range GL_APPLE_vertex_point_size GL_APPLE_vertex_program_evaluators GL_APPLE_ycbcr_422 GL_ATI_separate_stencil GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_barrier GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod 

Votes

Translate

Translate

Report

Report