Issue where the masking becomes uneditable with heavier edits in RAW editor.

New Here ,
Jan 28, 2022 Jan 28, 2022

Copy link to clipboard

Copied

I start my usual workflow by opening a RAW file in the RAW 14.1 editor to add some colour/ tonal adjustments, before opening the file as a smart object in Photoshop 2022. A while ago, I've become really intrigued by the 'select subject' masking option. As we know, in most cases the selection is great, however, not always perfect as the selection goes off and picks up some odd fragments of the background.

 

As I'm editing some outdoor fashion shoots (still in RAW editor), I am trying to perfect the subject selection mask by adding and subtracting, using the brush tool. However, I’ve recently discovered that when I open the smart object in Photoshop and then try to re-edit some of my mask selections in RAW editor, it recognises the mask selection, but doesn’t let me edit it.

I’ve noticed that the heavier the edit of the selection, the more often the issue happens.

I am editing CR2 and CR3 files. The Photoshop version is the most recent 23.1.1 and the OS is the newest Monterey 12.2. I’ve tried using older Photoshop updates, but it didn’t make any difference.

 

I am working on the 27”, 2019 Retina 5K iMac with:


Graphics: 
Radeon Pro Vega 48 8 GB
Memory: 64 GB 2667 MHz DDR4
Processor: 
3.6 GHz 8-Core Intel Core i9.


Has anyone experienced a similar issue? I’ve tried getting some help from Adobe several times, however with no successful outcome so far.

 

TOPICS
Cross-app workflows , macOS

Views

39

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation