Highlighted

ACR 12.3 disaster

Participant ,
Jul 21, 2020

Copy link to clipboard

Copied

Is ACR 12.3 a "Bridge" too far? I have posted before on the problem of opening a file from Bridge into PS when it first opens in ACR. It is virtually unusable due to EXTREEM lag between any slider adjustment and visual result (up to 15 seconds). I have had my hardware tested like never before, the latest drivers, removed all maner of start up programms to no avail. I have spent over 5 hours on line with Adobe support (I can't fault the effort but no cigar!) and there has been no improvement. ACR 12.3 opened from the PS Filters menu works perfectly. It also works in LR classic as a mater of interest.

Before the last major upgrade everything worked perfectly and my workflow was tidy and quick. Now if I use Bridge it is taking up to a full minute to get to an opened file in PS.

The sequence now is: click to open file in Bridge>wait>File opens in ACR<click open > wait>file opens in PS (no edits have been done so far)>Open Filters menu>open ACR filter> start work - up to a minute to get to this point.

I know this is a bit of a rant but it is really a disaster when an "improvement" wrecks a perfectly good application. If anyone has any suggestions I am happy to try them.

However please don't suggest hardware changes. My PC has been tested to the n'th degree (by Adobe, NVIDIA techies and others and my computer spec is significantly higher than PS requires. There have been no hardware changes since before the last upgrade.

The final Adobe advice was "wait for the next upgrade to see if it fixes the problem!". The upgrade was released today and it didn't!

Topics

Performance, Problem or error, Windows

Views

37

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

ACR 12.3 disaster

Participant ,
Jul 21, 2020

Copy link to clipboard

Copied

Is ACR 12.3 a "Bridge" too far? I have posted before on the problem of opening a file from Bridge into PS when it first opens in ACR. It is virtually unusable due to EXTREEM lag between any slider adjustment and visual result (up to 15 seconds). I have had my hardware tested like never before, the latest drivers, removed all maner of start up programms to no avail. I have spent over 5 hours on line with Adobe support (I can't fault the effort but no cigar!) and there has been no improvement. ACR 12.3 opened from the PS Filters menu works perfectly. It also works in LR classic as a mater of interest.

Before the last major upgrade everything worked perfectly and my workflow was tidy and quick. Now if I use Bridge it is taking up to a full minute to get to an opened file in PS.

The sequence now is: click to open file in Bridge>wait>File opens in ACR<click open > wait>file opens in PS (no edits have been done so far)>Open Filters menu>open ACR filter> start work - up to a minute to get to this point.

I know this is a bit of a rant but it is really a disaster when an "improvement" wrecks a perfectly good application. If anyone has any suggestions I am happy to try them.

However please don't suggest hardware changes. My PC has been tested to the n'th degree (by Adobe, NVIDIA techies and others and my computer spec is significantly higher than PS requires. There have been no hardware changes since before the last upgrade.

The final Adobe advice was "wait for the next upgrade to see if it fixes the problem!". The upgrade was released today and it didn't!

Topics

Performance, Problem or error, Windows

Views

38

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Have something to add?

Join the conversation