Highlighted

BUG: Cursor doesn't change properly to reflect tool in use

Explorer ,
May 14, 2019

Copy link to clipboard

Copied

Starting with Camera Raw 11.2, the cursor doesn't always change to reflect the tool in use properly. Here is the sequence to create the problem:

Select the adjustment brush (keyboard shortcut K)

Move an adjustment slider (example, Exposure); value box is highlighted in blue.

Use adjustment brush on image. The brush cursor turns into the default arrow, and the size of the brush disappears.

Subsequent uses of the brush act normally. This ONLY happens when an adjustment slider is moved.

This same cursor behavior is true for all tools (straighten, crop, etc), if an adjustment slider is moved prior to moving the tool.

This is irritating, especially when trying to use the adjustment brush.

I'm on a Mac, OS Mojave 10.14.4

Views

1.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

BUG: Cursor doesn't change properly to reflect tool in use

Explorer ,
May 14, 2019

Copy link to clipboard

Copied

Starting with Camera Raw 11.2, the cursor doesn't always change to reflect the tool in use properly. Here is the sequence to create the problem:

Select the adjustment brush (keyboard shortcut K)

Move an adjustment slider (example, Exposure); value box is highlighted in blue.

Use adjustment brush on image. The brush cursor turns into the default arrow, and the size of the brush disappears.

Subsequent uses of the brush act normally. This ONLY happens when an adjustment slider is moved.

This same cursor behavior is true for all tools (straighten, crop, etc), if an adjustment slider is moved prior to moving the tool.

This is irritating, especially when trying to use the adjustment brush.

I'm on a Mac, OS Mojave 10.14.4

Views

1.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 14, 2019 1
Adobe Employee ,
May 16, 2019

Copy link to clipboard

Copied

Hi Wes,

That does not sound good, as the cursor does not change in the Camera Raw plugin, could you please try updating the Camera Raw plugin to version 11.3 and let us know if you face the same issue after that? Camera Raw plug-in installer

Regards,
Sahil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 16, 2019 0
Explorer ,
May 16, 2019

Copy link to clipboard

Copied

Hi Sahil.

Sadly, the issue is the same after 11.3.

Here is also something interesting: if, while experiencing the problem, I press the Shift Key (or command), the proper cursor returns. It's as if the cursor function "loses focus" regarding the tool at hand, and needs to be "reminded" what tool is active.

--Wes

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 16, 2019 0
Explorer ,
Aug 13, 2019

Copy link to clipboard

Copied

This is STILL a problem with 11.4. C'mon. Fix this bug!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 13, 2019 0
Advocate ,
May 16, 2019

Copy link to clipboard

Copied

I am actually experiencing a similar problem. I'm on the latest version of everything, using the latest version of Mojave and a Wacom Intuos Pro with the latest driver release.

The specifics of the glitch I am getting are with the Adjustment Brush. When first opening the brush panel, it works fine. I can see my brush cursor fine and it paints normally. Then when I go to the panel and change a setting, any setting, then go back to paint on the image, the cursor turns back into the standard arrow. But when I release that bit of painting by lifting my stylus off of the wacom then click down again to start painting more, the cursor changes back to the standard brush cursor. This happens every time I change a setting in the panel.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 16, 2019 1
Explorer ,
May 16, 2019

Copy link to clipboard

Copied

Yes, that is my experience as well. Same for the other tools, such as crop, straighten, etc.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 16, 2019 0
Explorer ,
May 22, 2019

Copy link to clipboard

Copied

I still have this problem with 11.3.1

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 22, 2019 0
Explorer ,
May 23, 2019

Copy link to clipboard

Copied

Hi Wes,

Some time ago I had a problem with the cursor.  I eventually found that I had inadvertently turned on "Mouse Keys" a part of the the Mac Accessibility Shortcuts system which enables some keys to be used instead of a mouse to move the cursor on the monitor screen (Mac accessibility shortcuts - Apple Support ).  The shortcut to toggle Mouse Keys on/off is five presses on the Option Key.

All best wishes

Thom.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 23, 2019 0
Explorer ,
May 23, 2019

Copy link to clipboard

Copied

This didn't solve the problem. I'm pretty sure it's a bug, as others have the same problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 23, 2019 0
New Here ,
Oct 29, 2019

Copy link to clipboard

Copied

I have the same problem since an update this year. I actually can't use some tools in Camera Raw because the cursors won't change to the function of the tool. I wonder why Adobe broke it and if they care to fix it ever.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 29, 2019 0
mylifer LATEST
Community Beginner ,
Dec 11, 2019

Copy link to clipboard

Copied

Same here.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 11, 2019 0