• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

All of a sudden published 2017 course doesn't play audio on default (first) screen

Explorer ,
Jul 26, 2021 Jul 26, 2021

Copy link to clipboard

Copied

I have a lot of courses I've built in Captivate 2017.  Starting today, a published course won't play audio on the first screen.

It will play audio on other screens by using the TOC or advancing screens with a "Next" button that simply advances to the beginning of the next screen.

I just went back and checked some published output from older courses (like from a year or two ago) and they won't play either (clicking index.html in the published folder).  What could have caused this, and most importantly, how can I fix this?

 

Many thanks,

Eric

Views

24

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 26, 2021 Jul 26, 2021

Copy link to clipboard

Copied

I forgot to add - I have 65 courses I've authored over 7 years, including lots of maintenance and updates.

These are in 2 groups - a group of 25 that have the playbar included for screen navigation, and then 40 that have really simpleton navigation: buttons for Back, Pause, Play, and Next.  I inherited this group and this is what I'm working on now that started to not play audio on screen 1.

 

I've tried using Play audio (audio ID) on Enter for screen 1, but that doesn't seem to work.  I need to brute force the audio on screen 1 somehow.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 27, 2021 Jul 27, 2021

Copy link to clipboard

Copied

LATEST

Autoplay was disabled in Captivate for HTML5 output with the second release of CP2017, due to the decision of browsers to banish autoplay. The learner needs to agree to start the course by clicking at least once. That was already the situation for responsive projects on mobile devices before.

You can make the experience more engaging for the learners by using a poster image, which can have explanations is you want. More details in:

http://blog.lilybiri.com/poster-image-autoplay

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 26, 2021 Jul 26, 2021

Copy link to clipboard

Copied

This is now the way all Captivate courses work by default.  Adobe explains the reasons here:

https://helpx.adobe.com/captivate/kb/captivate-responsive-courses-not-autoplay-browsers.html

 

However, if courses you created years ago have suddenly just started obeying this behaviour, even though you haven't changed anything in those courses, then the only explanation is that something has changed in your IT environment.

 

Web browser enforcement of this behaviour (where audio does not play by default until the user interacts with the content) has been patchy.  But my suspicion is that you have just had a browser update that now mandates what should have been happening all along.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines