• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

cptx file association - both Cp8 and Cp2019 installed

New Here ,
Jan 31, 2023 Jan 31, 2023

Copy link to clipboard

Copied

I have an odd issue on a Windows 10 computer that has both Captivate 8 (one off purchase version, not subscription) and Captivate 2019 (subscription version) installed.

 

cptx files are associated with Captivate 8 (it was the first app installed) so of course when I double click on a Cp2019 created cptx in Explorer Cp8 opens, fails to load the file, and shows an error. No problem I thought, just right click and 'open with'. But when I browse to the Cp2019 exe (C:\Program Files\Adobe\Adobe Captivate 2019 x64\AdobeCaptivate.exe) then Cp8 still opens.

 

I can't find any setting in Cp2019 to set file associations, and if I go to Windows Settings > Apps > Default Apps > Choose default apps by file type some of the file types are associated with Cp8 and some with Cp2019 (you can tell by the icon) cptx shows th Cp8 icon, but clicking on it only lists that app as a possible default, not Cp2019.

 

Of course I can open cptx files in Cp2019 by opening Cp2019 itself and using the menu, but I'd much prefer to open them the easy way!

 

Any suggestions? It's a locked down work laptop so registry tweaks and the like won't be possible.

 

Thank you.

TOPICS
Advanced

Views

215

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 31, 2023 Jan 31, 2023

Copy link to clipboard

Copied

You really need to uninstall Captivate version 8 and just run with Captivate 2019.  But there is quite a few years difference between these two versions.  

Have you confirmed yet that you ARE actually able to open Captivate 2019, navigate with it to one of the CPTX files created in Captivate 8 and open it?  I suggest you check this first because when two versions of Captivate differ by too many versions eventually neither version can open files of the other.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 31, 2023 Jan 31, 2023

Copy link to clipboard

Copied

Thank you @RodWard - just to clarify these are projects created in Cp2019, they open fine in 2019 from the app menu, presumably it's the extra stuff in there that Cp8 doesn't support that causes the error messages.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 31, 2023 Jan 31, 2023

Copy link to clipboard

Copied

In the past I needed two versions of Captivate on the same system, and learned indeed that the best way is to open the application before browsing to the project and open it. I continue to do this even on systems where I have only one version installed. Why is that so bothersome to you? You can use the Preferences to choose different default paths for the two versions, making it easier. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 31, 2023 Jan 31, 2023

Copy link to clipboard

Copied

Thank you @Lilybiri - not too bothersome, just wondering if it was a simple fix but I think I'll just follow something similar to your workflow.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jan 31, 2023 Jan 31, 2023

Copy link to clipboard

Copied

LATEST

The problem that you are running into is that Captivate is BACKWARD compatible (because later versions of Captivate can open files created by earlier versions) but it is not FORWARD compatible.  This means that older versions of Captivate cannot open files created or even edited by later versions.  So, although your Captivate 2019 can open files created in Cp8, the opposite is not true. Cp8 will never be able to open files created or edited in Captivate 2019.  

 

This has been the case almost from the start of Captivate's history.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources
Help resources