• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

imgmd.json file is empty when publishing a HTML5 project on Captivate 2019 release 11.5.5.553

New Here ,
Feb 19, 2021 Feb 19, 2021

Copy link to clipboard

Copied

After creating a project and then publishing it, the imgmd.json file is empty causing the project to spin forever in blackboard.

Views

162

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 21, 2021 Feb 21, 2021

Copy link to clipboard

Copied

JSON is only used for png-files. Do you have PNG-files? I am not sure your loading issue is linked with JSON, there could be lot of other causes.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 22, 2021 Feb 22, 2021

Copy link to clipboard

Copied

Hi Lilybiri. Yes there are png files within the project. But whenever we publish the imgmd.json file is empty. If we add the folling lines to the imgmd.json file after we publish the project works as intended.

cp.imagesJSONCacheForLocal=true;cp.imageToJSONPathMap={
"___":"___"};

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Aug 04, 2022 Aug 04, 2022

Copy link to clipboard

Copied

Hi @defaultreiuvpyhl0b1 ! Did you find a reason/fix for why the imgmd.json file was publishing empty? Same issue is happening to me, though it is not happening in every published course. TIA!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Aug 23, 2022 Aug 23, 2022

Copy link to clipboard

Copied

If I remember correctly, imgmd.json is always empty when Quality setting 'High (24-bit)' is used for all slides. It is only populated for other quality settings. Check if all your slides are set to 'High'. The course should of course load just fine.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 30, 2022 Sep 30, 2022

Copy link to clipboard

Copied

LATEST

Thanks! I'll check on that! Appreciate it!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines