• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Issue with cpQuizInfoPointsscored when using a custom button.

Explorer ,
May 20, 2022 May 20, 2022

Copy link to clipboard

Copied

Hello everyone!

I didn't find an answer in the forums, so I really hope anyone can help me.

I have three slides with a simple button each, that appears at the end of a video, assigned with just 1 point. This button just takes you to the next slide.

If I press F9, I can see the 3 points in the advanced interaction. But when I preview the project, I cannot make those points to be assigned to the system variable cpQuizInfoPointsscored. It always shows 0 out of 3 points, and doesn't "pass" the test. I need this to be reported to an LMS.

Those points are just a way to check that you saw the videos 'til the end. I've another quiz slides, but with no points assigned, just not necessary. I gave a try to Advanced Actions, but I didn't get any light, since I wasn't able to assign any number to the variable cpQuizInfoPointsscored. I also tried creating my own variable, but wasn't able to connect this variable with the pointsscored system variable.

Leave a caption of the Advance Interaction panel with the points.

Thanks in advance!

Views

45

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , May 20, 2022 May 20, 2022

Please post always the full number of the version you are using (as found under Help, About Captivate).

The behavior you report is not normal, although I wouldn't have put Infinite attempt on those shape buttons, nor would I have pushed the pausing point to the last frame because that can cause issues, keep it a little bit earlier). Which Preview method did you use? If this is a non-responsive project use only the Preview HTML in Browser (F11). 

 

You shouldn't need a user variable in this case,

...

Likes

Translate

Translate
Community Expert ,
May 20, 2022 May 20, 2022

Copy link to clipboard

Copied

Please post always the full number of the version you are using (as found under Help, About Captivate).

The behavior you report is not normal, although I wouldn't have put Infinite attempt on those shape buttons, nor would I have pushed the pausing point to the last frame because that can cause issues, keep it a little bit earlier). Which Preview method did you use? If this is a non-responsive project use only the Preview HTML in Browser (F11). 

 

You shouldn't need a user variable in this case, scored objects will be taken into account in the quizzing system variables.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 20, 2022 May 20, 2022

Copy link to clipboard

Copied

Hi Lilybiri! Thank you for your quick response!

I fixed all the things you suggested, and I don't know which, but one of them made the trick and now it worked.

I really suposse it was the pausing point being in the last frame.

Thank you, thank you thank you!

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 20, 2022 May 20, 2022

Copy link to clipboard

Copied

LATEST

You're welcome!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines